Ping troubles

andymoore88andymoore88 Posts: 10Member ■□□□□□□□□□
Okay, I'm a bit of a lurker here, loads of info and you folks have helped me in the past, whether you knew it or not :)
I've finally gotten around to officially getting my Home lab up and running, I finally feel like I've learned enough to make use of it.

I've got three routers hooked up at the moment, R1 = 2620XM, R2 = 2611, and R3 is a 2620. I have switches that will be incorportated later.

For now, I run a cable modem to a wireless lynksis E1000. From there I run to my home network seperately from my Home Lab, I can't accidentally take down my Wife's internet connection, now can I? lol

Currently my issue is that I can ping google.com from R1, but I can't do that from R3 or R2. I have scoured these routers, but I am failing to see what the issue is.

I can ping the connecting interface between routers and the outbound interface on R1, but it stops there.

I can't get past address translation when traceroute from R3. Use google's IP address and ping fails, traceroute makes it to the inbetween interface, but stops there.

Anyone have a few moments to spare for this? I know it will be something blatantly simple and I'm fully prepared to feel emabarassed, lol.

Thanks in advance,
Andy

AndyR3 Running config


Current configuration : 856 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AndyR1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
!
!
ip name-server 24.217.0.5
ip name-server 24.178.162.3
ip name-server 24.247.15.53
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.123 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.2.1 255.255.255.0
clockrate 64000
!
interface Serial0/1
ip address 192.168.3.1 255.255.255.0
clockrate 64000
!
router rip
version 2
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
banner motd ^C
Welcome to Andy's CCNA Home Lab!!! ^C
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
!
!
end



AndyR3 Running config

Current configuration : 917 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AndyR3
!
!
memory-size iomem 10
ip subnet-zero
!
!
ip name-server 24.217.0.5
ip name-server 24.178.162.3
ip name-server 24.247.15.53
!
!
!
voice call carrier capacity active
!
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.3.2 255.255.255.0
!
interface Serial0/1
no ip address
shutdown
!
router rip
version 2
network 192.168.0.0
network 192.168.3.0
!
ip default-gateway 192.168.3.1
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
ip http server
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
banner motd ^C
Welcome to Andy's CCNA Home Lab! ^C
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
!
end

Comments

  • xnxxnx Posts: 464Member ■■■□□□□□□□
    Have you got static / default routes set up both ways on the connecting routers?
    Getting There ...

    Lab Equipment: Using Cisco CSRs and 4 Switches currently
  • andymoore88andymoore88 Posts: 10Member ■□□□□□□□□□
    I believe the routing tables are complete, yes sir.

    AndyR3#sho ip ro
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    R 192.168.1.0/24 [120/1] via 192.168.3.1, 00:00:19, Serial0/0
    R 192.168.2.0/24 [120/1] via 192.168.3.1, 00:00:19, Serial0/0
    C 192.168.3.0/24 is directly connected, Serial0/0
    S* 0.0.0.0/0 is directly connected, Serial0/0

    AndyR1#show ip ro
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is 192.168.1.1 to network 0.0.0.0

    C 192.168.1.0/24 is directly co92.168.2.0/24 is directly connected, Serial0/0
    C 192.168.3.0/24 is directly connected, Serial0/1
    S* 0.0.0.0/0 [1/0] via 192.168.1.1


    192.168.1.1 is the wireless Lynksis E1000
  • eteneten Posts: 67Member ■■□□□□□□□□
    Does your wireless router have routes to reach the 192.168.2.0/24 and 192.168.3.0/24?

    If you ping from R1 sourcing from S0/1, does that work?
  • andymoore88andymoore88 Posts: 10Member ■□□□□□□□□□
    I will see if I can add static routes for the .2 and .3 networks. I bet that is the problem. I'll update soon as I can.


    No, I cannot ping google.com from R1, sourcing from s0/1.
  • andymoore88andymoore88 Posts: 10Member ■□□□□□□□□□
    Well! There ya go folks, my wireless linksys had never heard of my subnets, and that was the problem. Thank you Eten! And everyone else!!!

    I love this site!

    Andy
  • GngoghGngogh Posts: 155Member
    Hi.. the problem is exactly what u said about your linksys router not knowing the routes to your subnet. all u need to do is to configure NAT on the router that connect your subnetworks to your home network.
  • JeanMJeanM Posts: 1,117Member
    Yep, always think that routing goes both ways ;)
    2015 goals - ccna voice / vmware vcp.
Sign In or Register to comment.