EtherChannel Question GURU TIME!

mikeybinecmikeybinec Senior MemberPosts: 482Member ■■■□□□□□□□
OK, I understand the bundling of the links under channel-group command.. I don't understand how the Port Channel command is related.. What exactly does it do or what's the purpose?

Thanks
Cisco NetAcad Cuyamaca College
A.S. LAN Management 2010 Grossmont College
B.S. I.T. Management 2013 National University

Comments

  • theodoxatheodoxa Posts: 1,340Member
    "Port-Channel N" is the bundled interface (a logical interface composed of up to 8 actual interfaces).

    (config)# interface range FastEthernet 0/17 - 24
    (config-if-range)# no switchport
    (config-if-range)# channel-protocol pagp
    (config-if-range)# channel-group 3 mode desirable non-silent
    (config-if-range)# exit
    (config)# interface Port-Channel 3
    (config-if)# ip address 10.1.3.4 255.255.255.0
    (config-if)# no shutdown
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
  • ZartanasaurusZartanasaurus Posts: 2,008Member
    After you bundle your interfaces, you need a way to configure the new interface you created. Whatever channel-group # you use becomes your port-channel interface #. Most anything you want to configure the physical ports to do must now be done at the logical interface level IE changing IPs, vlans, trunk mode, etc.
    Currently reading:
    IPSec VPN Design 44%
    Mastering VMWare vSphere 5​ 42.8%
  • mikeybinecmikeybinec Senior Member Posts: 482Member ■■■□□□□□□□
    theodoxa wrote: »
    "Port-Channel N" is the bundled interface (a logical interface composed of up to 8 actual interfaces).

    (config)# interface range FastEthernet 0/17 - 24
    (config-if-range)# no switchport
    (config-if-range)# channel-protocol pagp
    (config-if-range)# channel-group 3 mode desirable non-silent
    (config-if-range)# exit
    (config)# interface Port-Channel 3
    (config-if)# ip address 10.1.3.4 255.255.255.0
    (config-if)# no shutdown

    That's why I call out the gurus.. I was under the impression you make all the links trunks. It almost looks like a vlan here without defining the vlan or ??????

    thanks
    Cisco NetAcad Cuyamaca College
    A.S. LAN Management 2010 Grossmont College
    B.S. I.T. Management 2013 National University
  • theodoxatheodoxa Posts: 1,340Member
    mikeybinec wrote: »
    That's why I call out the gurus.. I was under the impression you make all the links trunks. It almost looks like a vlan here without defining the vlan or ??????

    thanks

    That's a Layer 3 Etherchannel. You can configure an Etherchannel as Layer 2 or Layer 3 [as long as you are using a Layer 3 Switch]. The main difference is you omit the "no switchport" command and include any desired trunking configuration (mode, encapsulation, allowed VLAN(s), etc...)

    (config)# interface range FastEthernet 0/17 - 24
    (config-if-range)# switchport trunk encapsulation dot1q
    (config-if-range)# switchport mode trunk
    (config-if-range)# switchport nonegotiate
    (config-if-range)# switchport trunk allowed vlan 10,20
    (config-if-range)# channel-protocol pagp
    (config-if-range)# channel-group 3 mode desirable non-silent
    (config-if-range)# exit
    (config)# interface Port-Channel 3
    (config-if)# no shutdown
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
  • mikeybinecmikeybinec Senior Member Posts: 482Member ■■■□□□□□□□
    Ahhh... None of my study materials brought up the layer 3 issue .. Thanks for clarification
    Cisco NetAcad Cuyamaca College
    A.S. LAN Management 2010 Grossmont College
    B.S. I.T. Management 2013 National University
  • DeathmageDeathmage Posts: 2,496Banned
    ahhh this made me learn something too! - switchport is used on a layer 2 switch but isn't used in a layer 3 switch?

    channel-protocol(Port-Channel) is used in place of switchport on a layer 3?
  • mikeybinecmikeybinec Senior Member Posts: 482Member ■■■□□□□□□□
    icon_cheers.gif I'm with you bruthuh.. We need to study together
    Cisco NetAcad Cuyamaca College
    A.S. LAN Management 2010 Grossmont College
    B.S. I.T. Management 2013 National University
  • DeathmageDeathmage Posts: 2,496Banned
    mikeybinec wrote: »
    icon_cheers.gif I'm with you bruthuh.. We need to study together

    If only we weren't on the exact opposite sides of the country ;)
  • theodoxatheodoxa Posts: 1,340Member
    Deathmage wrote: »
    ahhh this made me learn something too! - switchport is used on a layer 2 switch but isn't used in a layer 3 switch?

    channel-protocol(Port-Channel) is used in place of switchport on a layer 3?

    switchport = Layer 2
    no switchport = Layer 3

    On a Layer 3 switch, you would issue one of these command to change a port between Layer 2 (Access/Trunk) and Layer 3 (Routed Port with an IP Address). These commands will not work on a Layer 2 switch (generate an "incomplete command" error).

    "channel-protocol" defines the dynamic protocol [if you choose to use one] to use for negotiating Port-Channels, much like DTP is used to negotiate Trunks. PAgP is the original Cisco Proprietary Protocol and LACP is the newer Open Standard Protocol. You can also choose to configure the interface to always be part of the Port-Channel, so that no dynamic protocol is used.

    (config-if)# channel-protocol pagp
    (config-if)# channel-protocol lacp

    "channel-group" is the command used to include physical interfaces in the Port-Channel. Much like configuring a port to use a specific Access VLAN, if the Port-Channel doesn't already exist, it will be created automatically the first time you include an interface in it using the channel-group command.

    (config-if)# channel-group 1 mode on
    (config-if)# channel-group 1 mode desirable
    (config-if)# channel-group 1 mode active
    (config-if)# channel-group 1 mode passive

    "mode on" sets the interface to always be part of the Port-Channel
    "mode desirable" (PAgP) or "mode active" (LACP) will actively try to negotiate to include that interface in the Port-Channel
    "mode auto" (PAgP) or "mode passive" (LACP) will negotiate a Port-Channel, but won't initiate negotiations

    Port Aggregation Protocol - Wikipedia, the free encyclopedia
    Link aggregation - Wikipedia, the free encyclopedia
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
  • theodoxatheodoxa Posts: 1,340Member
    Configure an Interface to Always Be Part of Port-Channel 1

    (config-if-range)# channel-group 1 mode on

    Configure an Interface to Actively Negotiate to Be Part of Port-Channel 1 Using Cisco PAgP

    (config-if-range)# channel-protocol pagp
    (config-if-range)# channel-group 1 mode desirable

    Configure an Interface to Passively Negotiate to Be Part of Port-Channel 1 Using Cisco PAgP

    (config-if-range)# channel-protocol pagp
    (config-if-range)# channel-group 1 mode auto

    Configure an Interface to Actively Negotiate to Be Part of Port-Channel 1 Using LACP (IEEE 802.3ad)

    (config-if-range)# channel-protocol lacp
    (config-if-range)# channel-group 1 mode active

    Configure an Interface to Passively Negotiate to Be Part of Port-Channel 1 Using LACP (IEEE 802.3ad)

    (config-if-range)# channel-protocol lacp
    (config-if-range)# channel-group 1 mode passive

    One thing I forgot to mention in the last post is that with PAgP desirable mode, there is another option that can be added at the end of the command "non-silent". Basically, with PAgP the interface can be included in the Port-Channel after a certain period of time if no frames of any kind are received. There are some situations where this might be useful (interfaces connected to a monitoring device), but it adds a delay in bringing up the Port-Channel.
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
Sign In or Register to comment.