Help with VLANS, Trunks, and Sub-Interfaces
Spr5175
Registered Users Posts: 2 ■□□□□□□□□□
in CCNA & CCENT
Router 1
version 15.1 no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524AC2E
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree vlan 1,10,20,30,99 priority 0
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 172.25.0.1 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 172.25.4.97 255.255.255.224
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 172.25.6.97 255.255.255.224
!
interface GigabitEthernet0/0.30
encapsulation dot1Q 30
ip address 172.25.7.97 255.255.255.224
!
interface GigabitEthernet0/0.99
encapsulation dot1Q 99
ip address 172.25.0.17 255.255.255.252
!
interface GigabitEthernet0/1
ip address 172.25.0.5 255.255.255.252
duplex auto
speed auto
!
interface Serial0/1/0
ip address 200.1.1.1 255.255.255.248
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Dist switch
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
no ip domain-lookup
!
!
spanning-tree mode rapid-pvst
spanning-tree portfast default
spanning-tree vlan 1,10,20,30,99 priority 4096
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/2
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/3
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/4
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/5
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/6
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport trunk native vlan 99
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 172.25.5.65 255.255.255.224
!
interface Vlan20
ip address 172.25.6.65 255.255.255.224
!
interface Vlan30
ip address 172.25.7.65 255.255.255.224
!
interface Vlan99
ip address 172.25.0.17 255.255.255.252
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
Access layer switch
Current configuration : 3200 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname AccessSW1
!
!
!
no ip domain-lookup
!
!
spanning-tree mode rapid-pvst
spanning-tree vlan 1,10,20,30,99 priority 8192
!
interface FastEthernet0/1
switchport access vlan 20
switchport trunk native vlan 20
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 0002.168B.4401
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 20
switchport trunk native vlan 20
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 00D0.BC4C.5659
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 20
switchport trunk native vlan 20
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 0004.9A37.6BBD
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 20
switchport trunk native vlan 20
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 0050.0FA8.B941
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 20
switchport trunk native vlan 20
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 0001.6485.7E05
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
switchport port-security
spanning-tree portfast
!
interface FastEthernet0/7
spanning-tree portfast
!
interface FastEthernet0/8
spanning-tree portfast
!
interface FastEthernet0/9
spanning-tree portfast
!
interface FastEthernet0/10
spanning-tree portfast
!
interface FastEthernet0/11
spanning-tree portfast
!
interface FastEthernet0/12
spanning-tree portfast
!
interface FastEthernet0/13
spanning-tree portfast
!
interface FastEthernet0/14
spanning-tree portfast
!
interface FastEthernet0/15
spanning-tree portfast
!
interface FastEthernet0/16
spanning-tree portfast
!
interface FastEthernet0/17
spanning-tree portfast
!
interface FastEthernet0/18
spanning-tree portfast
!
interface FastEthernet0/19
spanning-tree portfast
!
interface FastEthernet0/20
spanning-tree portfast
!
interface FastEthernet0/21
spanning-tree portfast
!
interface FastEthernet0/22
spanning-tree portfast
!
interface FastEthernet0/23
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/24
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 172.25.5.65 255.255.255.224
!
interface Vlan20
ip address 172.25.6.65 255.255.255.224
!
interface Vlan30
ip address 172.25.7.65 255.255.255.224
!
interface Vlan99
ip address 172.25.0.17 255.255.255.252
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
i can ping all switch to and router to switch but not PC to PC any help would be much appreciated. About to ripe my hair out.
version 15.1 no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524AC2E
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree vlan 1,10,20,30,99 priority 0
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 172.25.0.1 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 172.25.4.97 255.255.255.224
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 172.25.6.97 255.255.255.224
!
interface GigabitEthernet0/0.30
encapsulation dot1Q 30
ip address 172.25.7.97 255.255.255.224
!
interface GigabitEthernet0/0.99
encapsulation dot1Q 99
ip address 172.25.0.17 255.255.255.252
!
interface GigabitEthernet0/1
ip address 172.25.0.5 255.255.255.252
duplex auto
speed auto
!
interface Serial0/1/0
ip address 200.1.1.1 255.255.255.248
clock rate 2000000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Dist switch
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
no ip domain-lookup
!
!
spanning-tree mode rapid-pvst
spanning-tree portfast default
spanning-tree vlan 1,10,20,30,99 priority 4096
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/2
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/3
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/4
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/5
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/6
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport trunk native vlan 99
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 172.25.5.65 255.255.255.224
!
interface Vlan20
ip address 172.25.6.65 255.255.255.224
!
interface Vlan30
ip address 172.25.7.65 255.255.255.224
!
interface Vlan99
ip address 172.25.0.17 255.255.255.252
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
Access layer switch
Current configuration : 3200 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname AccessSW1
!
!
!
no ip domain-lookup
!
!
spanning-tree mode rapid-pvst
spanning-tree vlan 1,10,20,30,99 priority 8192
!
interface FastEthernet0/1
switchport access vlan 20
switchport trunk native vlan 20
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 0002.168B.4401
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 20
switchport trunk native vlan 20
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 00D0.BC4C.5659
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 20
switchport trunk native vlan 20
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 0004.9A37.6BBD
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 20
switchport trunk native vlan 20
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 0050.0FA8.B941
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 20
switchport trunk native vlan 20
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 0001.6485.7E05
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
switchport port-security
spanning-tree portfast
!
interface FastEthernet0/7
spanning-tree portfast
!
interface FastEthernet0/8
spanning-tree portfast
!
interface FastEthernet0/9
spanning-tree portfast
!
interface FastEthernet0/10
spanning-tree portfast
!
interface FastEthernet0/11
spanning-tree portfast
!
interface FastEthernet0/12
spanning-tree portfast
!
interface FastEthernet0/13
spanning-tree portfast
!
interface FastEthernet0/14
spanning-tree portfast
!
interface FastEthernet0/15
spanning-tree portfast
!
interface FastEthernet0/16
spanning-tree portfast
!
interface FastEthernet0/17
spanning-tree portfast
!
interface FastEthernet0/18
spanning-tree portfast
!
interface FastEthernet0/19
spanning-tree portfast
!
interface FastEthernet0/20
spanning-tree portfast
!
interface FastEthernet0/21
spanning-tree portfast
!
interface FastEthernet0/22
spanning-tree portfast
!
interface FastEthernet0/23
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/24
switchport trunk native vlan 99
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 172.25.5.65 255.255.255.224
!
interface Vlan20
ip address 172.25.6.65 255.255.255.224
!
interface Vlan30
ip address 172.25.7.65 255.255.255.224
!
interface Vlan99
ip address 172.25.0.17 255.255.255.252
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end
i can ping all switch to and router to switch but not PC to PC any help would be much appreciated. About to ripe my hair out.
Comments
-
networker050184 Mod Posts: 11,962 ModSoftware firewall on PC?An expert is a man who has made all the mistakes which can be made.
-
Hondabuff Member Posts: 667 ■■■□□□□□□□I would agree. Turn off the firewall on both PC's then try the ping, if it works then just create an inbound rule on the firewalls to allow ICMP traffic.“The problem with quotes on the Internet is that you can’t always be sure of their authenticity.” ~Abraham Lincoln
-
Spr5175 Registered Users Posts: 2 ■□□□□□□□□□Checked that all firewalls are off and this is in packet tracer Sry did not clarify that.