ip default network
Why does R5 not receive a candidate default route? I'm trying to figure out how "ip default-network" works. How do i get it to propagate a candidate default?
As per topology i've got 5 routers, eigrp is enabled on all interfaces, lo0 on all routers is /32 with router number being advertised i.e. R1 1.1.1.1/32
On R2 i've summarized 1.1.1.1/32 to 1.0.0.0/8 towards R4.
R4#sh runn | sec router eigrp
router eigrp 1
default-metric 1000 100 254 1 1500
network 4.0.0.0
network 10.0.0.0
R4#
R5#sh runn | sec router eigrp
router eigrp 1
network 5.0.0.0
network 10.0.0.0
R5#
R4
Gateway of last resort is not set
1.0.0.0/8 is subnetted, 1 subnets
D 1.0.0.0 [90/435200] via 10.0.34.3, 00:01:42, Ethernet0/2
[90/435200] via 10.0.24.2, 00:01:42, Ethernet0/1
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 10.0.24.2, 00:01:42, Ethernet0/1
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 10.0.34.3, 00:01:42, Ethernet0/2
5.0.0.0/32 is subnetted, 1 subnets
D 5.5.5.5 [90/409600] via 10.0.45.5, 00:32:31, Ethernet0/0
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D 10.0.123.0/24 [90/307200] via 10.0.34.3, 00:01:42, Ethernet0/2
[90/307200] via 10.0.24.2, 00:01:42, Ethernet0/1
R5
Gateway of last resort is not set
D 1.0.0.0/8 [1/460800] via 10.0.45.4, 00:32:59, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [1/435200] via 10.0.45.4, 00:02:10, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [1/435200] via 10.0.45.4, 00:32:59, Ethernet0/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [1/409600] via 10.0.45.4, 00:32:59, Ethernet0/0
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D 10.0.24.0/24 [1/307200] via 10.0.45.4, 00:02:12, Ethernet0/0
D 10.0.34.0/24 [1/307200] via 10.0.45.4, 00:32:59, Ethernet0/0
D 10.0.123.0/24 [1/332800] via 10.0.45.4, 00:02:10, Ethernet0/0
R4(config)#ip default-network 1.0.0.0
R4(config)#do sh ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is 10.0.34.3 to network 1.0.0.0
* 1.0.0.0/8 is subnetted, 1 subnets
D* 1.0.0.0 [90/435200] via 10.0.34.3, 00:03:01, Ethernet0/2
[90/435200] via 10.0.24.2, 00:03:01, Ethernet0/1
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 10.0.24.2, 00:03:01, Ethernet0/1
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 10.0.34.3, 00:03:01, Ethernet0/2
5.0.0.0/32 is subnetted, 1 subnets
D 5.5.5.5 [90/409600] via 10.0.45.5, 00:33:50, Ethernet0/0
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D 10.0.123.0/24 [90/307200] via 10.0.34.3, 00:03:01, Ethernet0/2
[90/307200] via 10.0.24.2, 00:03:01, Ethernet0/1
R5#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is not set
D 1.0.0.0/8 [1/460800] via 10.0.45.4, 00:34:13, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [1/435200] via 10.0.45.4, 00:03:24, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [1/435200] via 10.0.45.4, 00:34:13, Ethernet0/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [1/409600] via 10.0.45.4, 00:34:13, Ethernet0/0
5.0.0.0/32 is subnetted, 1 subnets
C 5.5.5.5 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D 10.0.24.0/24 [1/307200] via 10.0.45.4, 00:03:26, Ethernet0/0
D 10.0.34.0/24 [1/307200] via 10.0.45.4, 00:34:13, Ethernet0/0
C 10.0.45.0/24 is directly connected, Ethernet0/0
L 10.0.45.5/32 is directly connected, Ethernet0/0
D 10.0.123.0/24 [1/332800] via 10.0.45.4, 00:03:24, Ethernet0/0
R5#
As per topology i've got 5 routers, eigrp is enabled on all interfaces, lo0 on all routers is /32 with router number being advertised i.e. R1 1.1.1.1/32
On R2 i've summarized 1.1.1.1/32 to 1.0.0.0/8 towards R4.
R4#sh runn | sec router eigrp
router eigrp 1
default-metric 1000 100 254 1 1500
network 4.0.0.0
network 10.0.0.0
R4#
R5#sh runn | sec router eigrp
router eigrp 1
network 5.0.0.0
network 10.0.0.0
R5#
R4
Gateway of last resort is not set
1.0.0.0/8 is subnetted, 1 subnets
D 1.0.0.0 [90/435200] via 10.0.34.3, 00:01:42, Ethernet0/2
[90/435200] via 10.0.24.2, 00:01:42, Ethernet0/1
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 10.0.24.2, 00:01:42, Ethernet0/1
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 10.0.34.3, 00:01:42, Ethernet0/2
5.0.0.0/32 is subnetted, 1 subnets
D 5.5.5.5 [90/409600] via 10.0.45.5, 00:32:31, Ethernet0/0
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D 10.0.123.0/24 [90/307200] via 10.0.34.3, 00:01:42, Ethernet0/2
[90/307200] via 10.0.24.2, 00:01:42, Ethernet0/1
R5
Gateway of last resort is not set
D 1.0.0.0/8 [1/460800] via 10.0.45.4, 00:32:59, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [1/435200] via 10.0.45.4, 00:02:10, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [1/435200] via 10.0.45.4, 00:32:59, Ethernet0/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [1/409600] via 10.0.45.4, 00:32:59, Ethernet0/0
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D 10.0.24.0/24 [1/307200] via 10.0.45.4, 00:02:12, Ethernet0/0
D 10.0.34.0/24 [1/307200] via 10.0.45.4, 00:32:59, Ethernet0/0
D 10.0.123.0/24 [1/332800] via 10.0.45.4, 00:02:10, Ethernet0/0
R4(config)#ip default-network 1.0.0.0
R4(config)#do sh ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is 10.0.34.3 to network 1.0.0.0
* 1.0.0.0/8 is subnetted, 1 subnets
D* 1.0.0.0 [90/435200] via 10.0.34.3, 00:03:01, Ethernet0/2
[90/435200] via 10.0.24.2, 00:03:01, Ethernet0/1
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 10.0.24.2, 00:03:01, Ethernet0/1
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 10.0.34.3, 00:03:01, Ethernet0/2
5.0.0.0/32 is subnetted, 1 subnets
D 5.5.5.5 [90/409600] via 10.0.45.5, 00:33:50, Ethernet0/0
10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
D 10.0.123.0/24 [90/307200] via 10.0.34.3, 00:03:01, Ethernet0/2
[90/307200] via 10.0.24.2, 00:03:01, Ethernet0/1
R5#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is not set
D 1.0.0.0/8 [1/460800] via 10.0.45.4, 00:34:13, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [1/435200] via 10.0.45.4, 00:03:24, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [1/435200] via 10.0.45.4, 00:34:13, Ethernet0/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [1/409600] via 10.0.45.4, 00:34:13, Ethernet0/0
5.0.0.0/32 is subnetted, 1 subnets
C 5.5.5.5 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D 10.0.24.0/24 [1/307200] via 10.0.45.4, 00:03:26, Ethernet0/0
D 10.0.34.0/24 [1/307200] via 10.0.45.4, 00:34:13, Ethernet0/0
C 10.0.45.0/24 is directly connected, Ethernet0/0
L 10.0.45.5/32 is directly connected, Ethernet0/0
D 10.0.123.0/24 [1/332800] via 10.0.45.4, 00:03:24, Ethernet0/0
R5#
Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
Comments
-
fredrikjj Member Posts: 879I found some threads that suggest that it's broken in IOS 15.
https://learningnetwork.cisco.com/thread/71553
MEMO_MEMO_MEMO: Failure of injecting default route to EIGRP with "ip default-network"
https://learningnetwork.cisco.com/thread/52226
Try the same config on IOS 12.4. -
EdTheLad Member Posts: 2,111 ■■■■□□□□□□Ah, was thinking about going back, thx for that, was driving me crazy!Networking, sometimes i love it, mostly i hate it.Its all about the $$$$