Botched my Linux installation

KGhaleonKGhaleon Member Posts: 1,347
This is the second time I've installed Linux, and decided to use my laptop so I could study for the Linux+. I went through the graphical setup and everything went smoothly until I rebooted. First thing I noticed was that Grub only saw Linux(Redhat), and I didn't have a boot disc for XP on me. Not biggie, since I had some at home. My windows XP partition that contained all my old data could wait.

Note: I installed Redhat on the 2GB of empty space I had available on the 18GB drive.

I proceeded to log in as root using the password I assigned during installation. The first thing I noticed was that I had no gui, it left me staring at a blank screen. So I typed "startx" and get a bunch of letters and crap, saying there is a problem with the display configurations. I figure that maybe it doesn't have the proper video or monitor installed...and decide that it's better to start over and reinstall redhat rather than install drivers using a command prompt.

I went into the redhat install and found that I had no idea how to delete the linux partitions without hurting my XP partition. I tried fdisk but it's completely different from the one I'm used to using. I then selected, "Remove all Linux partitions" and prayed that it wouldn't mistake my old NTFS partition for linux.

I still don't know if my XP partition survived, but I reinstalled Redhat and I'm playing around with the video settings toward the end of the install. Whenever I hit "test setting" after selecting a monitor the screen goes blank and doesn't really do anything.

Any helpful suggestions?

I'd like to make XP and Linux multi-bootable, but I'm having enough trouble just getting redhat to give me a freaking GUI. icon_sad.gif

KG
Present goals: MCAS, MCSA, 70-680

Comments

  • KGhaleonKGhaleon Member Posts: 1,347
    Btw, I have a Toshiba Satellite 1805-S204 laptop. I think it has a Trident CyberbladeXP video card.

    I looked up the monitor, and all I can really find on it is that it might be a "13.3 in. TFT Active Matrix."

    Redhat probed and came up with a "TOS5082" monitor which was what I originally selected. Now I'm just trying different monitors to see if I can get some different results from hitting the "Test setting" button on the next page. It always just gives me a blank screen.

    I'm guessing it's the video card which I selected toward the beginning of the installation. I selected Trident CyberbladeXP, so I don't see what the problem is.

    KG
    Present goals: MCAS, MCSA, 70-680
  • KGhaleonKGhaleon Member Posts: 1,347
    Upon closer examination, I get a "unable to probe video card" during the installation. I'm going to try to select another card from the list, but what am I suppose to do if my card isn't supported or the driver is needed?

    bleh...did a search and came up with this page:
    http://kristof.willen.be/toshiba/1805.html

    Looks like I'm in trouble. icon_redface.gif

    Looks like this is above my current Linux skills. Anyone care to give some advice on how to get my GUI to work? ^^; What are the commands I need to be using?

    KG
    Present goals: MCAS, MCSA, 70-680
  • fonduefondue Member Posts: 104
    Which version of RedHat are you installing?

    Try setting your video driver to vesa and monitor to generic laptop 1024x768. the vesa drivers are CPU hogs but will usually work in a pinch.

    Regarding your missing Windows Grub problem. Modify the menu.lst located in /boot/grub and add the following lines to the bottom.

    title Windows
    rootnoverify (hd0,0)
    chainloader +1

    Then reboot, if it's wrong reboot back into Linux and modify again. Note the (hd0,0) portion, depending on your Windows location you may need to change to (hd0,1) or (hd0,2) etc...
  • lordylordy Member Posts: 632 ■■■■□□□□□□
    Which version of RedHat did you try to install ?

    Installing Linux on laptops is kind of an advanced topic so I would just go ahead and try with a different distribution. Try Ubuntu for example.
    Working on CCNP: [X] SWITCH --- [ ] ROUTE --- [ ] TSHOOT
    Goal for 2014: RHCA
    Goal for 2015: CCDP
  • keatronkeatron Member Posts: 1,208 ■■■■■■□□□□
    I run Redhat on a Toshiba Satellite M30. Just try following Fondue's instructions and you should be fine.
  • KGhaleonKGhaleon Member Posts: 1,347
    I installed Redhat 7.2, which came with a book that I got from a class 2 or 3 years back. I don't really know how to download distros yet, since there's so many files that you have to download. I don't know where to begin.

    Thanks for the Grub solution, I'll try it when I get home. I can boot into the partition just fine with a floppy right now. The website above says that I just need to upgrade my XFree86 in order to use my video card.

    Could someone give me a walkthrough on how to do this? It's a little above my abilities with the linux shell.

    KG
    Present goals: MCAS, MCSA, 70-680
  • lordylordy Member Posts: 632 ■■■■□□□□□□
    RedHat 7.2 is OLD and EOL. Trash it.

    If you wanna try Ubuntu here are a few quick steps.

    1. Download this file (it's 600+ MB, so you need a good connection)
    http://mirror.mcs.anl.gov/pub/ubuntu-iso/5.10/ubuntu-5.10-install-i386.iso

    2. Burn it onto a CD with any burning program (e.g. Nero). Note that the files is an 'Image' so you have to look for options like "Burn image". Do NOT drag&drop this file onto a CD, it won't work.

    3. Throw the CD into your laptop and have a good time icon_wink.gif

    HTH,
    Lordy
    Working on CCNP: [X] SWITCH --- [ ] ROUTE --- [ ] TSHOOT
    Goal for 2014: RHCA
    Goal for 2015: CCDP
  • KGhaleonKGhaleon Member Posts: 1,347
    Hey, thanks. :)

    When I get off work I'll download this at another office tonight and give it a try. Is this the latest version of Ubuntu?

    KG
    Present goals: MCAS, MCSA, 70-680
  • RussSRussS Member Posts: 2,068
    I agree there Lordy. If I was putting *nix on a modern machine I would use Ubuntu, Mandrake 10 or Lycoris.
    www.supercross.com
    FIM website of the year 2007
  • KGhaleonKGhaleon Member Posts: 1,347
    Wow, it works awesomely(new word). I was able to log in and set up DHCP with the press of a few buttons. I also didn't need to go through the trouble of searching for drivers.

    Only problems I've seen are that my cdrom drive doesn't open and power management doesn't work properly. Those aren't major problems though...don't you have to mount drives for them to work, first? That must be what I'm missing.

    :edit:

    I forgot about the eject command. I'm such a linux noob.

    KG
    Present goals: MCAS, MCSA, 70-680
  • exkor5000exkor5000 Member Posts: 54 ■■□□□□□□□□
    make sure that /mnt/cdrom exists

    in shell type:
    mount /dev/cdrom /mnt/cdrom
    

    also give the output of:
    cat /etc/fstab
    

    X[/code]
  • Gennosuke HIGAKIGennosuke HIGAKI Member Posts: 68 ■■□□□□□□□□
    Installing Linux in a laptop is a quite challenging task, indeed. Did you try “SuperProbe” command? This tells us an accurate name of an installed video chip. Generally, Windoz uses a card name while Linux does an exact chip name, as you know? When I bought IBM thinkPad 535 before, the then X didn’t support the Trident video chip. What did I do? I bought and installed a copy of commercial X, Metro X Accelerator at over $300! Fortunately, my investment paid back well through my frequent business trips with the laptop.

    Okay, let’s follow your CD ROM issue In Linux, everything is dealt as file, as you know? First, check the CD ROM device

    # ls –al /dev/cdrom

    Mine shows “dev/cdrom -> /dev/hdc” The device file is symbolically linked to an actual device, hdc, i.e., EIDE 2nd primary drive. Next, check dead or alive

    # dmesg | grep hdc

    Find a character string of "hdc" in a text. Mine shows “CRD-8400B, ATAPI CD/DVD-ROM drive.” Dmesg keeps records of boot process. Try # dmesg | less

    At this stage, your smart kernel detected the hardware and made it accessible but still unsure of dead or alive. Like Windoz, auto mount became common in Linux too. If you put a CD ROM in the drive, an access lamp blinks? Okay, make it by hand Suppose you have a mount point as /mnt/cdrom

    # cat /etc/fstab

    Check file systems and hardware to be mounted at a bootup Mine shows “dev/cdrom /mnt/cdrom iso9660 noauto, owner, kudoz, ro 0 0

    # mount –t iso9660 /dev/cdrom /mnt/cdrom

    Follow the above fstab script manually

    # ls /mnt/cdrom

    If you see inside, your CD ROM drive works fine. If not, something mechanically wrong in the device. “/usr/bin/eject” opens the device I hope.
  • exkor5000exkor5000 Member Posts: 54 ■■□□□□□□□□
    your fstab format seems to be incorrect
    /dev/cdrom /mnt/cdrom iso9660 noauto, owner, kudoz, ro 0 0
    

    it looks ok, except for the "kudoz" part. according to your fstab, normal users will not be able to mout the cdrom unless they are root users. Therefore you need to add the term "user" in there. The fact that you've added a specific username (I assume it is) in the line doesnt mean that the user kudos will be able to understand that. (unless you've hacked the mount utility) I assume from this that you are working with root priveliges on your system OR use
    su -c "mount -o users /dev/cdrom"
    
    If you see inside, your CD ROM drive works fine. If not, something mechanically wrong in the device.

    The cdrom media itself can be corrupted.
    Also a CD can be recored in a different format that ISO9660, and for that reason it is better to not specify an exact filesystem when you mount a cdrom/dvd drive. Mount will detect it automatically. If it doesnt that you should be worrying about having a problem.

    In fact if you change "noauto" to "auto" in your fstab you can just mount the drive with
    mount -a
    


    This is what should be in there:
    /dev/cdrom /mnt/cdrom auto noauto, owner, user, ro 0 0
    

    use:
    mount /dev/cdrom
    

    you do not need to specify any additional info if the device is present in fstab, mount will check your fstab first and mount the drive to that you've sent in fstab.

    gluck

    X
  • remyforbes777remyforbes777 Member Posts: 499
    there are a few power modules that you might need to install. For instance I had to install powernow_k8, cpufreq_userspace, battery, fan, thermal, processor, button, ac, freq_table. I am running debian though so it might be different if you are using a different distro.
Sign In or Register to comment.