Inter-AS Option C problem

aladin1985aladin1985 Member Posts: 6 ■□□□□□□□□□
dear team
Currently, I built a topo (atached) and try to test Inter AS Option C
However, route can be learnt, ping it self ok, but cannot ping each other
Pls help to find out the problem

Thanks

[email protected]# show | no-more
## Last changed: 2015-06-09 03:53:37 UTC
version 12.1R1.9;
system {
host-name PE1;
root-authentication {
encrypted-password "$1$sffVvYQC$WDivU1FRhUGDOyACaHkxw0"; ## SECRET-DATA
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
}
interfaces {
em0 {
unit 0 {
family inet {
address 172.27.0.1/30;
}
family iso;
family mpls;
}
}
em1 {
unit 0 {
family inet {
address 11.11.11.1/24;
}
}
}
lo0 {
unit 0 {
family inet {
address 1.1.1.1/32;
}
}
unit 10 {
family inet {
address 10.10.10.10/32;
}
}
}
}
routing-options {
autonomous-system 64501;
}
protocols {
rsvp {
interface all;
}
mpls {
label-switched-path pe1-to-asbr1 {
to 3.3.3.3;
}
interface em0.0;
}
bgp {
group internal {
type internal;
local-address 1.1.1.1;
family inet {
labeled-unicast {
resolve-vpn;
}
}
neighbor 3.3.3.3;
}
group EBGP {
type external;
multihop;
local-address 1.1.1.1;
family inet-vpn {
unicast;
}
neighbor 6.6.6.6 {
peer-as 64502;
}
}
}
ospf {
traffic-engineering;
area 0.0.0.0 {
interface all;
}
}
ldp {
interface em0.0;
}
}
policy-options {
policy-statement vpna-export {
then {
community set vpna-64501-community;
accept;
}
}
policy-statement vpna-import {
from community 64502-vpna-community;
then accept;
}
community 64502-vpna-community members target:64502:2222;
community vpna-64501-community members target:64501:1111;
}
routing-instances {
vpna {
instance-type vrf;
interface em1.0;
interface lo0.10;
route-distinguisher 1.1.1.1:64501;
vrf-import vpna-import;
vrf-export vpna-export;
vrf-table-label;
}
}


[edit]
[email protected]# run show route table vpna


vpna.inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both


10.10.10.10/32 *[Direct/0] 00:01:53
> via lo0.10
11.11.11.0/24 *[Direct/0] 00:01:53
> via em1.0
11.11.11.1/32 *[Local/0] 00:01:53
Local via em1.0
20.20.20.20/32 *[BGP/170] 00:00:40, localpref 100, from 6.6.6.6
AS path: 64502 I
> to 172.27.0.2 via em0.0, label-switched-path pe1-to-asbr1
66.66.66.0/24 *[BGP/170] 00:00:40, localpref 100, from 6.6.6.6
AS path: 64502 I
> to 172.27.0.2 via em0.0, label-switched-path pe1-to-asbr1


[edit]
[email protected]# run ping 11.11.11.1 interface em1.0
PING 11.11.11.1 (11.11.11.1): 56 data bytes
64 bytes from 11.11.11.1: icmp_seq=0 ttl=64 time=0.654 ms
^C
--- 11.11.11.1 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.654/0.654/0.654/nan ms


[edit]
[email protected]# run ping 11.11.11.1 interface em1.0 rapid count 100
PING 11.11.11.1 (11.11.11.1): 56 data bytes
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
--- 11.11.11.1 ping statistics ---
100 packets transmitted, 100 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.044/0.152/0.803/0.133 ms


[edit]


[email protected]# show | no-more
## Last changed: 2015-06-09 03:53:09 UTC
version 12.1R1.9;
system {
host-name PE3;
root-authentication {
encrypted-password "$1$jPCP67hx$kTp7r.mC50fbzsFf/u.iD/"; ## SECRET-DATA
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
}
interfaces {
em0 {
unit 0 {
family inet {
address 172.27.0.18/30;
}
family mpls;
}
}
em1 {
unit 0 {
family inet {
address 66.66.66.1/24;
}
}
}
lo0 {
unit 0 {
family inet {
address 6.6.6.6/32;
}
}
unit 20 {
family inet {
address 20.20.20.20/32;
}
}
}
}
routing-options {
rib-groups {
inet-inet3 {
import-rib [ inet.0 inet.3 ];
import-policy lo0-only;
}
}
autonomous-system 64502;
}
protocols {
rsvp {
interface all;
}
mpls {
label-switched-path pe3-to-asbr2 {
to 4.4.4.4;
}
interface em0.0;
}
bgp {
group internal {
type internal;
local-address 6.6.6.6;
family inet {
labeled-unicast {
resolve-vpn;
}
}
neighbor 4.4.4.4;
}
group EBGP {
type external;
multihop;
local-address 6.6.6.6;
family inet-vpn {
unicast;
}
peer-as 64501;
neighbor 1.1.1.1;
}
}
ospf {
traffic-engineering;
area 0.0.0.0 {
interface em0.0;
interface lo0.0 {
passive;
}
}
}
ldp {
interface em0.0;
}
}
policy-options {
policy-statement lo0-only {
from {
route-filter 1.1.1.1/32 exact;
}
then accept;
}
policy-statement vpna-export {
then {
community set 64502-vpna-community;
accept;
}
}
policy-statement vpna-import {
from community 64501-community;
then accept;
}
community 64501-community members target:64501:1111;
community 64502-vpna-community members target:64502:2222;
}
routing-instances {
vpna {
instance-type vrf;
interface em1.0;
interface lo0.20;
route-distinguisher 6.6.6.6:64502;
vrf-import vpna-import;
vrf-export vpna-export;
vrf-table-label;
}
}


[edit]
[email protected]# run show route table vpna


vpna.inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both


10.10.10.10/32 *[BGP/170] 00:00:42, localpref 100, from 1.1.1.1
AS path: 64501 I
> to 172.27.0.17 via em0.0, label-switched-path pe3-to-asbr2
11.11.11.0/24 *[BGP/170] 00:00:42, localpref 100, from 1.1.1.1
AS path: 64501 I
> to 172.27.0.17 via em0.0, label-switched-path pe3-to-asbr2
20.20.20.20/32 *[Direct/0] 00:02:33
> via lo0.20
66.66.66.0/24 *[Direct/0] 00:02:32
> via em1.0
66.66.66.1/32 *[Local/0] 00:02:32
Local via em1.0


[edit]
[email protected]# run ping 11.11.11.11 interface em1.0
PING 11.11.11.11 (11.11.11.11): 56 data bytes
^C
--- 11.11.11.11 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss


[edit]
[email protected]# run ping 11.11.11.1 interface em1.0
PING 11.11.11.1 (11.11.11.1): 56 data bytes
^C
--- 11.11.11.1 ping statistics ---
2 packets transmitted, 0 packets received, 100% packet loss


[edit]
[email protected]# run ping 11.11.11.1 interface em1.0 rapid count 100
PING 11.11.11.1 (11.11.11.1): 56 data bytes
..................................................................^C
--- 11.11.11.1 ping statistics ---
67 packets transmitted, 0 packets received, 100% packet loss


[edit]


[email protected]# show | no-more
## Last changed: 2015-06-09 03:53:12 UTC
version 12.1R1.9;
system {
host-name ASBR1;
root-authentication {
encrypted-password "$1$WLndr8TF$AarKT8/YtR29TtnElXIIJ/"; ## SECRET-DATA
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
}
interfaces {
em0 {
unit 0 {
family inet {
address 172.27.0.9/30;
}
family mpls;
}
}
em1 {
unit 0 {
family inet {
address 172.27.0.6/30;
}
family iso;
family mpls;
}
}
lo0 {
unit 0 {
family inet {
address 3.3.3.3/32;
}
}
}
}
routing-options {
autonomous-system 64501;
}
protocols {
rsvp {
interface all;
}
mpls {
interface em1.0;
interface em0.0;
}
bgp {
group internal {
type internal;
local-address 3.3.3.3;
family inet {
labeled-unicast {
resolve-vpn;
}
}
export nhs;
neighbor 1.1.1.1;
}
group EBGP {
type external;
family inet {
labeled-unicast;
}
export ospf-bgp;
peer-as 64502;
neighbor 172.27.0.10;
}
}
ospf {
traffic-engineering;
area 0.0.0.0 {
interface em1.0;
interface lo0.0 {
passive;
}
}
}
ldp {
interface em1.0;
}
}
policy-options {
policy-statement nhs {
then {
next-hop self;
}
}
policy-statement ospf-bgp {
from protocol ospf;
then accept;
}
}


[edit]


[email protected]# show | no-more
## Last changed: 2015-06-09 03:52:34 UTC
version 12.1R1.9;
system {
host-name ASBR2;
root-authentication {
encrypted-password "$1$ark8Mw8k$LdUZe8pN4kaBw.8uj/oT50"; ## SECRET-DATA
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
}
interfaces {
em0 {
unit 0 {
family inet {
address 172.27.0.10/30;
}
family mpls;
}
}
em1 {
unit 0 {
family inet {
address 172.27.0.13/30;
}
family mpls;
}
}
lo0 {
unit 0 {
family inet {
address 4.4.4.4/32;
}
}
}
}
routing-options {
autonomous-system 64502;
}
protocols {
rsvp {
interface all;
}
mpls {
label-switched-path asbr2-to-pe3 {
from 4.4.4.4;
to 6.6.6.6;
}
interface em0.0;
interface em1.0;
}
bgp {
group internal {
type internal;
local-address 4.4.4.4;
family inet {
labeled-unicast {
resolve-vpn;
}
}
export nhs;
neighbor 6.6.6.6;
}
group EBGP {
type external;
family inet {
labeled-unicast;
}
export ospf-bgp;
peer-as 64501;
neighbor 172.27.0.9;
}
}
ospf {
traffic-engineering;
area 0.0.0.0 {
interface em1.0;
interface lo0.0 {
passive;
}
}
}
ldp {
interface em1.0;
}
}
policy-options {
policy-statement nhs {
then {
next-hop self;
}
}
policy-statement ospf-bgp {
from protocol ospf;
then accept;
}
}


[edit]

Comments

  • zoidbergzoidberg Member Posts: 365
    Can you edit your post, putting your output within code tags? It keeps the white space that way, making it so much easier to read. Use these tags, without the spaces: [ code ] <insert output here> [ / code ]

    Example:
    {primary:node0}
    [email protected]> show configuration security nat static    
    rule-set nat64 {
        from zone ingress;
        rule nat64 {
            match {
                source-address ::/0;
                destination-address 64:ff9b::/96;
            }
            then {
                static-nat {
                    inet;
                }
            }
        }
    }
    
  • zoidbergzoidberg Member Posts: 365
    Missing a LSP? asbr1-to-pe1
  • aladin1985aladin1985 Member Posts: 6 ■□□□□□□□□□
    dear Zoidberd
    I already fixed, still cannot because I think LDP RSVP between PE1 and ASBR1, PE3 and ASBR2 is same
    Before i use LDP also cannot
    If you can support through teamviewer, I can send teamviewer ID to you

    [email protected]# run show route table vpna


    vpna.inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both


    10.10.10.10/32 *[Direct/0] 00:01:31
    > via lo0.10
    11.11.11.0/24 *[Direct/0] 00:01:31
    > via em1.0
    11.11.11.1/32 *[Local/0] 00:01:31
    Local via em1.0
    20.20.20.20/32 *[BGP/170] 00:00:30, localpref 100, from 6.6.6.6
    AS path: 64502 I
    > to 172.27.0.2 via em0.0, label-switched-path pe1-to-asbr1
    66.66.66.0/24 *[BGP/170] 00:00:30, localpref 100, from 6.6.6.6
    AS path: 64502 I
    > to 172.27.0.2 via em0.0, label-switched-path pe1-to-asbr1

    PE1# run show mpls lsp
    Ingress LSP: 1 sessions
    To From State Rt P ActivePath LSPname
    3.3.3.3 1.1.1.1 Up 0 * pe1-to-asbr1
    Total 1 displayed, Up 1, Down 0


    Egress LSP: 1 sessions
    To From State Rt Style Labelin Labelout LSPname
    1.1.1.1 3.3.3.3 Up 0 1 FF 3 - asb1-to-pe1
    Total 1 displayed, Up 1, Down 0


    Transit LSP: 0 sessions
    Total 0 displayed, Up 0, Down 0

    [email protected]# run show mpls lsp
    Ingress LSP: 1 sessions
    To From State Rt P ActivePath LSPname
    1.1.1.1 3.3.3.3 Up 0 * asb1-to-pe1
    Total 1 displayed, Up 1, Down 0


    Egress LSP: 1 sessions
    To From State Rt Style Labelin Labelout LSPname
    3.3.3.3 1.1.1.1 Up 0 1 FF 3 - pe1-to-asbr1
    Total 1 displayed, Up 1, Down 0

    [email protected]# run show mpls lsp
    Ingress LSP: 1 sessions
    To From State Rt P ActivePath LSPname
    6.6.6.6 4.4.4.4 Up 0 * asbr2-to-pe3
    Total 1 displayed, Up 1, Down 0


    Egress LSP: 1 sessions
    To From State Rt Style Labelin Labelout LSPname
    4.4.4.4 6.6.6.6 Up 0 1 FF 3 - pe3-to-asbr2
    Total 1 displayed, Up 1, Down 0

    [email protected]# run show mpls lsp
    Ingress LSP: 1 sessions
    To From State Rt P ActivePath LSPname
    4.4.4.4 6.6.6.6 Up 0 * pe3-to-asbr2
    Total 1 displayed, Up 1, Down 0


    Egress LSP: 1 sessions
    To From State Rt Style Labelin Labelout LSPname
    6.6.6.6 4.4.4.4 Up 0 1 FF 3 - asbr2-to-pe3
    Total 1 displayed, Up 1, Down 0

    [email protected]# run show route table vpna


    vpna.inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both


    10.10.10.10/32 *[BGP/170] 00:01:23, localpref 100, from 1.1.1.1
    AS path: 64501 I
    > to 172.27.0.17 via em0.0, label-switched-path pe3-to-asbr2
    11.11.11.0/24 *[BGP/170] 00:01:23, localpref 100, from 1.1.1.1
    AS path: 64501 I
    > to 172.27.0.17 via em0.0, label-switched-path pe3-to-asbr2
    20.20.20.20/32 *[Direct/0] 00:02:39
    > via lo0.20
    66.66.66.0/24 *[Direct/0] 00:02:39
    > via em1.0
    66.66.66.1/32 *[Local/0] 00:02:39
    Local via em1.0
  • aladin1985aladin1985 Member Posts: 6 ■□□□□□□□□□
    dear Zoidberg

    i already fixed but also cannot
    before i use LDP also cannot. So I think the problem not belong to RSVP. I don't know whether problem related to GNS3 or not.
    If you have time to login directly through teamviewer, I will give it to you

    THanks
Sign In or Register to comment.