Eigrp default network advertisement
Hi, im doing a lab on Eigrp default network advertisement that is part of CCNP ROUTE 6.0 student lab manual book. the scenario is with 3 routers where one of them as a route to the internet, the route to the internet needs to be advertised to all other routers as the default route.
this route can be advertised by creating a static default-route and issue the command redistribute static in router eigrp configuration mode. when we do a sh ip route we can see in all routers that the gateway of last resort is set.
But the lab is tell me to configure a default-network with ip default-network command, and it says that this command propagates through the EIGRP system so that each router sees its candidate default network.
When i do a sh ip eigrp topo 172.31.0.0/16 on the other routers it says that the route is not in the topology table. or when i do a sh ip route on the router that has these default-network configured i see that the gateway of last resort is not set.
configurations are as follows:
Router R1
hostname R1
!
interface Loopback0
ip address 172.31.1.1 255.255.255.0
!
interface Serial0/0/0
bandwidth 64
ip address 192.168.100.1 255.255.255.248
clock rate 64000
no shutdown
!
router eigrp 100
network 172.31.0.0
network 192.168.100.0
no auto-summary
!
ip default-network 172.31.0.0
!
end
Router R2
hostname R2
!
interface Loopback1
ip address 192.168.200.1 255.255.255.252
!
interface Loopback5
ip address 192.168.200.5 255.255.255.252
!
interface Loopback9
ip address 192.168.200.9 255.255.255.252
!
interface Loopback13
ip address 192.168.200.13 255.255.255.252
!
interface Loopback1
!
interface Loopback21
ip address 192.168.200.21 255.255.255.252
!
interface Loopback25
ip address 192.168.200.25 255.255.255.252
!
interface Serial0/0/0
bandwidth 64
ip address 192.168.100.2 255.255.255.248
no shutdown
!
interface Serial0/0/1
bandwidth 64
ip address 10.1.1.2 255.255.255.248
clock rate 64000
no shutdown
!
router eigrp 100
network 10.0.0.0
network 192.168.100.0
network 192.168.200.0
no auto-summary
!
end
Router R3
hostname R3
!
interface Loopback1
ip address 192.168.1.1 255.255.254.0
!
interface Loopback5
ip address 192.168.5.5 255.255.254.0
!
interface Loopback9
ip address 192.168.9.9 255.255.254.0
!
interface Loopback13
ip address 192.168.13.13 255.255.254.0
!
interface Loopback17
ip address 192.168.17.17 255.255.254.0
!
interface Loopback21
ip address 192.168.21.21 255.255.254.0
!
interface Loopback25
ip address 192.168.25.25 255.255.254.0
!
interface Loopback100
ip address 10.1.3.1 255.255.255.252
!
interface Loopback172
ip address 172.16.1.1 255.255.255.0
!
interface Serial0/0/1
bandwidth 64
ip address 10.1.1.3 255.255.255.248
ip summary-address eigrp 100 192.168.0.0 255.255.224.0
no shutdown
!
router eigrp 100
network 10.0.0.0
network 172.16.0.0
network 192.168.0.0 0.0.31.255
no auto-summary
!
end
after configuring:
R1(config)# ip default-network 172.31.0.0
the lab says that the output on R2 should be:
R2# show ip eigrp topology 172.31.0.0/16
IP-EIGRP (AS 100): Topology entry for 172.31.0.0/16
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 40640000
Routing Descriptor Blocks:
192.168.100.1 (Serial0/0/0), from 192.168.100.1, Send flag is 0x0
Composite metric is (40640000/128256), Route is Internal
Vector metric:
Minimum bandwidth is 64 Kbit
Total delay is 25000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
Exterior flag is set
but this is not happening and i get this output instead:
R2# show ip eigrp topology 172.31.0.0/16
% IP-EIGRP (AS 100): Route not in topology table
Help or explanations are appreciated.
this route can be advertised by creating a static default-route and issue the command redistribute static in router eigrp configuration mode. when we do a sh ip route we can see in all routers that the gateway of last resort is set.
But the lab is tell me to configure a default-network with ip default-network command, and it says that this command propagates through the EIGRP system so that each router sees its candidate default network.
When i do a sh ip eigrp topo 172.31.0.0/16 on the other routers it says that the route is not in the topology table. or when i do a sh ip route on the router that has these default-network configured i see that the gateway of last resort is not set.
configurations are as follows:
Router R1
hostname R1
!
interface Loopback0
ip address 172.31.1.1 255.255.255.0
!
interface Serial0/0/0
bandwidth 64
ip address 192.168.100.1 255.255.255.248
clock rate 64000
no shutdown
!
router eigrp 100
network 172.31.0.0
network 192.168.100.0
no auto-summary
!
ip default-network 172.31.0.0
!
end
Router R2
hostname R2
!
interface Loopback1
ip address 192.168.200.1 255.255.255.252
!
interface Loopback5
ip address 192.168.200.5 255.255.255.252
!
interface Loopback9
ip address 192.168.200.9 255.255.255.252
!
interface Loopback13
ip address 192.168.200.13 255.255.255.252
!
interface Loopback1
!
interface Loopback21
ip address 192.168.200.21 255.255.255.252
!
interface Loopback25
ip address 192.168.200.25 255.255.255.252
!
interface Serial0/0/0
bandwidth 64
ip address 192.168.100.2 255.255.255.248
no shutdown
!
interface Serial0/0/1
bandwidth 64
ip address 10.1.1.2 255.255.255.248
clock rate 64000
no shutdown
!
router eigrp 100
network 10.0.0.0
network 192.168.100.0
network 192.168.200.0
no auto-summary
!
end
Router R3
hostname R3
!
interface Loopback1
ip address 192.168.1.1 255.255.254.0
!
interface Loopback5
ip address 192.168.5.5 255.255.254.0
!
interface Loopback9
ip address 192.168.9.9 255.255.254.0
!
interface Loopback13
ip address 192.168.13.13 255.255.254.0
!
interface Loopback17
ip address 192.168.17.17 255.255.254.0
!
interface Loopback21
ip address 192.168.21.21 255.255.254.0
!
interface Loopback25
ip address 192.168.25.25 255.255.254.0
!
interface Loopback100
ip address 10.1.3.1 255.255.255.252
!
interface Loopback172
ip address 172.16.1.1 255.255.255.0
!
interface Serial0/0/1
bandwidth 64
ip address 10.1.1.3 255.255.255.248
ip summary-address eigrp 100 192.168.0.0 255.255.224.0
no shutdown
!
router eigrp 100
network 10.0.0.0
network 172.16.0.0
network 192.168.0.0 0.0.31.255
no auto-summary
!
end
after configuring:
R1(config)# ip default-network 172.31.0.0
the lab says that the output on R2 should be:
R2# show ip eigrp topology 172.31.0.0/16
IP-EIGRP (AS 100): Topology entry for 172.31.0.0/16
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 40640000
Routing Descriptor Blocks:
192.168.100.1 (Serial0/0/0), from 192.168.100.1, Send flag is 0x0
Composite metric is (40640000/128256), Route is Internal
Vector metric:
Minimum bandwidth is 64 Kbit
Total delay is 25000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
Exterior flag is set
but this is not happening and i get this output instead:
R2# show ip eigrp topology 172.31.0.0/16
% IP-EIGRP (AS 100): Route not in topology table
Help or explanations are appreciated.
Comments
-
fredrikjj Member Posts: 879Something got messed up with this command in some IOS 15 release. There's more here: https://learningnetwork.cisco.com/thread/71553
The key to make it work in 15.x seems to be to stop advertising the network, apply ip default network, and then readvertise it:Hi guys,
Order of operations is important here. Do this:
1. Remove the network from being advertised in EIGRP ( no network X.X.X.X )
2. Add the ip default-network X.X.X.X command
3. Re-advertise the network in EIGRP.
This should work, and your neighbors should get the * candidate default route.
Router#show ip route eigrp | beg Gate
Gateway of last resort is not set
D* 192.168.1.0/24 [90/130816] via 172.16.1.1, 00:07:40, GigabitEthernet0/1
D* 192.168.2.0/24 [90/130816] via 172.16.1.1, 00:06:22, GigabitEthernet0/1
Router#
tested on VIRL with IOSv. -
Gngogh Member Posts: 165 ■■■□□□□□□□Thank you for your reply, unfortunately that solution does not work for me.. i have try different IOS's and no luck.
-
harry1975 Registered Users Posts: 2 ■□□□□□□□□□So when you do a show ip route on R1, do you see the network 172.31.0.0? What is the mask of it? If not showing up, then it may require a active interface that covers that network(172.16.0.0/16). Loopback 0 does not fall in that network. Remember that EIGRP will accept classfull or classless network statements, but you need to put the wild card mask to accept a classless network. Hope this helps.
-
_Gonzalo_ Member Posts: 113If I understood correctly, your lab is like this:
Internet--(172.31.1.0/24)--R1----R2----R3
With a static route and the redistribute static command, it works fine.
With ip default-network and without changing any other configuration, it does not.
First question is: are you are using a simulator? If so, always doubt them (after making sure that the configuration is correct) because they fail often.
So, for this case, and as far as I know, it should be working, as long as you publish the default network (which you did)
Some advice: If something doesn´t work as expected, I usually look it up on cisco´s sites. And if config is right and it still doesn´t work, hardware fault or simulator issue!