I can't ping from my 2500 router to my pc

kadshahkadshah A+, Network+, Security +, MCP & CCNAFrom NYC but currently living in ThailandMember Posts: 388 ■■■□□□□□□□
I have 2 2500 routers and 1 1900 switch. I have a 2 pc 1 imac as my lab.
I am unable to ping from any of the 2 routers to my PC. If i ping from my PC or iMac to either router i get a reply but destinataion is unreachable message. Every device has a ip address including the switch. I have enabled the no shutdown on the routers. The routers are able to ping to one another. My 1900 switch is connected to a Linsky router which is my default gateway. All devices in my lab are connectedto the switch. The routers can ping to the switch but not the PC or the Linsky router.
i get a reply and the same unreachable message. I'm sure I have forgot something can someone help me figure out what the problem might be.
Here's the output from one of my routers.

interface Ethernet0
description connection to Gateway
ip address 192.168.0.11 255.255.255.0
no ip route-cache
no ip mroute-cache
!
interface Serial0
bandwidth 64
ip address 192.168.10.2 255.255.255.0
encapsulation ppp
no ip route-cache
no ip mroute-cache
ppp chap password 7 060A062F490E
!
interface Serial1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
!
router rip
network 192.168.0.0
network 192.168.10.0

ip classless
no ip http server
!
banner motd ^CBLACK SABBATH RULES^C
!
line con 0
exec-timeout 0 0
password kaj
logging synchronous
login
line aux 0
transport input all
line vty 0 4
password kaj
login
!
end

Comments

  • happy420goluckyhappy420golucky Member Posts: 78 ■■□□□□□□□□
    Are you sure that your pc's have an ip address that is within the same subnet when you try to ping from your router. Try to ping your local host's from the switch, and post what your get.
    Every passing minute is a chance to turn it all around.
  • EricOEricO Member Posts: 93 ■■□□□□□□□□
    Two quick things:

    1. You might need ip subnet zero.
    2. What is the default gateway setting of your pc?
  • kadshahkadshah A+, Network+, Security +, MCP & CCNA From NYC but currently living in ThailandMember Posts: 388 ■■■□□□□□□□
    the default gateway settings for my computer is the linksys router which is 192.168.1.1. Here are the ip addresses for all devices on the network.

    R1 192.168.10.2
    R2 192.168.10.3
    PC1 192.168.1.101 (static)
    PC2 192.168.1.4 (static)
    iMac 192.168.1.116 (Static)
    DEFAULT GATEWAY (linsky)192.168.1.1
    Switch 1900 192.168.0.9
    I'm wondering as pointed out if maybe it's because all devices
    aren't in the same subnet.
  • hectorjhrdzhectorjhrdz Member Posts: 127
    ok, try this:

    interface Ethernet0
    description connection to Gateway
    ip address 192.168.1.x 255.255.255.0

    you are using a sufix /24 , so 192.168.0.x and 192.168.1.x are diferent networks.
  • kadshahkadshah A+, Network+, Security +, MCP & CCNA From NYC but currently living in ThailandMember Posts: 388 ■■■□□□□□□□
    thanks worked like a charm.
Sign In or Register to comment.