Redistributing Loopbacks into EIGRP
daniel280187
Member Posts: 37 ■■□□□□□□□□
in CCNP
Hi guys,
I am trying to redistribute some routes from OSPF into EIGRP. Please see the next example:
http://postimg.org/image/pc1cztm0z/
Description:
I am trying to Redistribute Loopbacks 0 and 1 from R3 and R4 (OSPF) into EIGRP. All of the other loopbacks are being filtered with a route-map before being redistribute. Notice that they are loopbacks with /24 and as I understand OSPF advertise them as /32 routes.
Issues:
1 - When looking the routing table in R2, I can see 2 routes for 10.1.4.0 and 2 more routes for 10.1.5.0.
I am trying to understand why am I receiving these 2 extra /24 routes for these loopbacks?. Should not I receive just one /32 route for each Loopback as it is the case for the routes originated by R3?
2 - Additionally I cannot see and Type 1 LSA being generated in OSPF for those Loopbacks. I can see type 5 instead for some of the routes which makes me think it might be an issue with these loopbacks being redistributed back into OSPF.
http://postimg.org/image/ahp10i19z/14035d83/
Thanks in advance for your comments to shed some light on this.
I am trying to redistribute some routes from OSPF into EIGRP. Please see the next example:
http://postimg.org/image/pc1cztm0z/
Description:
I am trying to Redistribute Loopbacks 0 and 1 from R3 and R4 (OSPF) into EIGRP. All of the other loopbacks are being filtered with a route-map before being redistribute. Notice that they are loopbacks with /24 and as I understand OSPF advertise them as /32 routes.
Issues:
1 - When looking the routing table in R2, I can see 2 routes for 10.1.4.0 and 2 more routes for 10.1.5.0.
I am trying to understand why am I receiving these 2 extra /24 routes for these loopbacks?. Should not I receive just one /32 route for each Loopback as it is the case for the routes originated by R3?
2 - Additionally I cannot see and Type 1 LSA being generated in OSPF for those Loopbacks. I can see type 5 instead for some of the routes which makes me think it might be an issue with these loopbacks being redistributed back into OSPF.
http://postimg.org/image/ahp10i19z/14035d83/
Thanks in advance for your comments to shed some light on this.
Comments
-
Node Man Member Posts: 668 ■■■□□□□□□□Hi Daniel,
Just shooting from the hip. Maybe try 'redistributing connected routes' will work. -
daniel280187 Member Posts: 37 ■■□□□□□□□□Don't think so Node Man, thanks for the suggestion though. I mean, the routes are being redistributed into EIGRP, the issue is that I am getting routes that I think should not being received (/24 routes). You can notice in the first image that R2 (EIGRP) gets the Loopbacks from OSPF.
-
james43026 Member Posts: 303 ■■□□□□□□□□Are you doing mutual redistribution? Are both R1 and R4 doing redistribution? And from which routing domain to which routing domain on each router?
-
daniel280187 Member Posts: 37 ■■□□□□□□□□james43026 wrote: »Are you doing mutual redistribution? Are both R1 and R4 doing redistribution? And from which routing domain to which routing domain on each router?
Hi, yes they are both (R1 and R4) doing mutual redistribution from OSPF 1 to EIGRP 100 and viceversa. I will be trying tomorrow to tag the routes as they are redistributed and then filter those tags in the opposite direction.
Hi DPG
The following is the config for R4 (Quite similar to R1)
!INTERFACES CONF
configure terminal
interface serial 0/1
description ### OSPF AREA 0 ###
ip address 172.16.1.2 255.255.255.252
no shutdown
interface fastethernet 0/0
description ### EIGRP 100 ###
ip address 172.16.21.4 255.255.255.0
no shutdown
interface loopback 0
ip address 10.1.4.1 255.255.255.0
no shutdown
interface loopback 1
ip address 10.1.5.1 255.255.255.0
no shutdown
interface loopback 2
ip address 10.1.6.1 255.255.255.0
no shutdown
interface loopback 3
ip address 10.1.7.1 255.255.255.0
no shutdown
exit
!
!OSPF_ROUTING_CONF
router ospf 1
router-id 4.4.4.4
passive-interface default
no passive-interface serial 0/1
area 0 authentication message-digest
network 172.16.1.0 0.0.0.3 area 0
network 10.1.0.0 0.0.255.255 area 0
exit
!OSPF Cost, Authentication and Hello Timers
interface serial 0/1
ip ospf hello-interval 8
ip ospf dead-interval 32
ip ospf message-digest-key 1 md5 blabla
exit
!EIGRP_ROUTING_CONF
router eigrp 100
no auto-summary
passive-interface default
no passive-interface fastethernet 0/0
network 172.16.21.0 0.0.0.255
exit
!REDIST_INTO_EIGRP
router eigrp 100
redistribute ospf 1 metric 10000 10 200 5 1500
exit
!REDIST_INTO_OSPF
router ospf 1
redistribute eigrp 100 subnets
exit
!FILTERING_ROUTES
access-list 10 permit 10.1.0.0 0.0.1.255
access-list 10 permit 10.1.4.0 0.0.0.255
access-list 10 permit 10.1.5.0 0.0.0.255
access-list 20 permit 10.1.8.0 0.0.0.255
access-list 20 permit 10.1.9.0 0.0.0.255
route-map INTO_OSPF permit 70
match ip address 20
exit
route-map INTO_EIGRP permit 80
match ip address 10
set metric 10000 10 200 5 1500
exit
router ospf 1
redistribute eigrp 100 subnets route-map INTO_OSPF
exit
router eigrp 100
redistribute ospf 1 route-map INTO_EIGRP
exit -
james43026 Member Posts: 303 ■■□□□□□□□□It appears to me that you have a redistribution loop. Can you post the running config for R1?