EIGRP Stub Assistance

MowMow Member Posts: 445 ■■■□□□□□□□
I wrote this on another post, but I figured it might get more action if it has its own post.

I have 3 routers, two of them are configured as EIGRP stubs, but they are forming an adjacency? R2 and R3 shouldn't be forming an adjacency, from what I know. Can anyone help me clarify?
7693d1459895732t-route-topolgy.png

R1:
R1#sh run | sec eigrp
no ip split-horizon eigrp 100
router eigrp 100
network 1.1.1.0 0.0.0.255
network 172.12.123.0 0.0.0.255

R2:
R2#sh run | sec eigrp
no ip split-horizon eigrp 100
router eigrp 100
network 2.2.2.0 0.0.0.255
network 172.12.23.0 0.0.0.31
network 172.12.123.0 0.0.0.255
eigrp stub connected summary

R3:
R3#sh run | sec eigrp
no ip split-horizon eigrp 100
router eigrp 100
network 3.3.3.0 0.0.0.255
network 172.12.23.0 0.0.0.31
network 172.12.123.0 0.0.0.255
eigrp stub connected summary
R3#


Thanks for any insight!

Comments

  • MowMow Member Posts: 445 ■■■□□□□□□□
    I think I may have this figured out. I think that a neighbor relationship and an adjacency are two similar, but different things. Two stub routers can form a neighbor relationship, meaning they know about each other, but not an adjacency, meaning they share routing tables and updates.
  • joetestjoetest Member Posts: 99 ■■□□□□□□□□
    This is just some ramblings going in my mind.. They share the same multiaccess network (1 Ethernet switch and 1 FR network). That's just 1 segment 2 times, but there's no routing hops in between.

    You probably only have 1 route to 1.1.1.0/24(R1's loopback right?) on R2/R3. If you on say R2 close the link/interface from where it learns the 1.1.1.0 route, it probably wont learn it again through R3 even though it knows it. That would be because of the stub feature.

    I hope it makes sense to you.

    If you really wanna get to the bottom if it by yourself you sniff the wires using wireshark in gns and look at the EIGRP packets.
Sign In or Register to comment.