Packet Tracer Help

TechnicalJayTechnicalJay ■■■□□□□□□□Posts: 213Member ■■■□□□□□□□
Hello,

I have a question about connecting 2 routers together and to be able to ping the other side. I am using the PC that has an IP of 192.168.2.5 and trying to ping 192.168.1.100. Any suggestions?

Thanks

Comments

  • v1ralv1ral ■■□□□□□□□□ Posts: 116Member ■■□□□□□□□□
    What does your routing look like?

    type "sh ip route" and copy and paste the output or show us you config.
  • DCDDCD Posts: 449Member
    Depending on your subnet mask your wan IP are not correct and are you using a static route or a routing protocol? Like V1ral said we need "show ip route" "show ip interface brief" and your configuration or a link to your PT file.
  • TechnicalJayTechnicalJay ■■■□□□□□□□ Posts: 213Member ■■■□□□□□□□
    I'm on my work computer at the moment and I don't have packet tracer with me here. Would the following routes be correct?

    Router0

    ip route 192.168.3.0 255.255.255.0 192.168.1.100

    Router 1

    ip route 192.168.4.0 255.255.255.0 192.168.2.5
  • v1ralv1ral ■■□□□□□□□□ Posts: 116Member ■■□□□□□□□□
    Your routes are incorrect.

    The last ip address should be the IP of WAN link on R1. R0 should be something like this: (Also I can barely read the screenshot so my IP maybe off)



    ip route 192.168.2.0 255.255.255.0 192.168.3.2

    Synatax:
    ip route [ip of target network] [SM of target network] [ip of next hop router]
  • TechnicalJayTechnicalJay ■■■□□□□□□□ Posts: 213Member ■■■□□□□□□□
    v1ral wrote: »
    Your routes are incorrect.

    The last ip address should be the IP of WAN link on R1. R0 should be something like this: (Also I can barely read the screenshot so my IP maybe off)



    ip route 192.168.2.0 255.255.255.0 192.168.3.2

    Synatax:
    ip route [ip of target network] [SM of target network] [ip of next hop router]

    I'm doing that and its not giving any errors but when i type 'sh ip route' the static route isn't listed. Any idea?
  • DefilerDefiler ■□□□□□□□□□ Posts: 9Member ■□□□□□□□□□
    I'm doing that and its not giving any errors but when i type 'sh ip route' the static route isn't listed. Any idea?

    When you do 'show ip route' its not listing a route you have setup on a interface?
    How odd is that... what version of PT?
  • TechnicalJayTechnicalJay ■■■□□□□□□□ Posts: 213Member ■■■□□□□□□□
    Thats correct. Version 6.3.0. Here is a new one. I believe I did everything right for the ip route syntax?




    Sorry its very hard to see.

    Left Side
    Router0
    Serial:192.168.5.1
    Ethernet:192.168.2.1
    PC: 192.168.2.101

    Right Side
    Router1
    Serial:192.168.4.1
    Ethernet:192.168.1.1
    PC:192.168.1.100

    IP Routing selecting Router1

    en
    conf t
    ip route 192.168.1.0 255.255.255.0 192.168.5.1(Router0)

    in enabled mode

    sh ip route

    only shows the serial and ethernet connetions
  • DCDDCD Posts: 449Member
    Do a ping from both routers. You will not get a static route if the next hop is not in the routing table. Fix the IP address or the subnet mask.
  • Ltat42aLtat42a ■■■□□□□□□□ Posts: 587Member ■■■□□□□□□□
    The serial ports on both routers need to be in the same subnet. From your config above, R0 is in the 5.0 network, R1 is in the 4.0 network.
  • clarsonclarson ■■■■□□□□□□ Posts: 897Member ■■■■□□□□□□
    you don't need the static route. with just two routers you don't need to do anything, but have your ip address and subnet mask right. once you configure the router's interfaces with ip address/subnet masks. It knows the networks that are attached to it. and will router between them. Which is why you use 3 routers to learn about routing protocols. To see how the routes are propagated.
    So, the syntax, ip route [ip of target network] [SM of target network] [ip of next hop router], is correct. There is a caveat, The ip of the target network isn't already configured on a port to the router.

    Your problem is probably with your ip addresses of the serial ports. 192.168.5.1 and 192.168.4.1. you don't say what subnet mask that you are using, but if it 255.255.255.0, those are separate networks and don't talk to each other. So, either change the host ip addresses to something like, 192.168.4.1 and 192.168.4.2. Or change the subnet mask to put them on the same network, something like 255.255.248.0
  • TechnicalJayTechnicalJay ■■■□□□□□□□ Posts: 213Member ■■■□□□□□□□
    Great thanks for the replies I'll give it a try later today
  • TechnicalJayTechnicalJay ■■■□□□□□□□ Posts: 213Member ■■■□□□□□□□
    Finally got it to work and understand it now. Thanks all for the help
Sign In or Register to comment.