Q. why I'm getting a port unreachable

yrwinsyrwins Posts: 81Member ■■□□□□□□□□
this is lab.
why I'm getting a port unreachable on wireshark but not on the router and also there is only 2 hop?

!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 06YFDUHH61wAE/kLkDq9BGho1QM5EnRtoyr8cHAUg.2
!
no aaa new-model
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
redundancy
!
!
csdb tcp synwait-time 30
csdb tcp idle-time 3600
csdb tcp finwait-time 5
csdb tcp reassembly max-memory 1024
csdb tcp reassembly max-queue-length 16
csdb udp idle-time 30
csdb icmp idle-time 10
csdb session max-session 65535
!!
!
interface Loopback1
ip address 192.168.12.3 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.12.10 255.255.255.248
duplex half
!
interface FastEthernet1/0
ip address 192.168.12.17 255.255.255.248
duplex half
!
router ospf 1
network 192.168.12.0 0.0.0.0 area 0
network 192.168.12.0 0.0.0.7 area 0
network 192.168.12.0 0.0.0.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
control-plane
!
!
!
mgcp profile default
!
!
!
gatekeeper
shutdown
!
banner motd ^C you are at R2 ^C
!
line con 0
password r2
login
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password r2
login
transport input all
!
!
end


Comments

  • Experienced_ISN'T_oldExperienced_ISN'T_old Posts: 26Banned ■□□□□□□□□□
    Port unreachable problem is usually an illegal immigration issue and Trump will build a sturdy fence to STOP IT, STOP IT, STOP it now.
  • yrwinsyrwins Posts: 81Member ■■□□□□□□□□
    a redneck on stick
  • theodoxatheodoxa Posts: 1,340Member
    Strange. That looks more like a traceroute which uses an incrementing TTL and ICMP error messages to determine the path. Port Unreachable means that the device is there, but the port is not open.
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
  • Sy KosysSy Kosys Posts: 105Member ■■□□□□□□□□
    There are some confusing bits in the diagram. Is this all segmented as /29? Also, where is the wireshark device in relation to this packet capture? Looks like it was filtered on 192.168.12.26 which should put it in the segment between R3 and R4, I'm guessing R4 directly.

    R4 fa0/0 192.168.12.26 /29 (assumption based upon available input)
    R3 fa1/0 192.168.12.25 /29
    R2 fa1/0 192.168.12.17 /29

    Port unreachable is from R2 (.17) to R4 (.26) according to wireshark capture on R4, but pings are fine in the reverse direction. What's the ping/traceroute behavior from R2 perspective?

    How is OSPF configured on the other routers too? You have some interesting network statements present on R2:
    network 192.168.12.0 0.0.0.0 area 0 <-- advertises no interfaces, as .0 is your network address
    network 192.168.12.0 0.0.0.7 area 0 <-- advertises the loopback only as .3 is covered by the wildcard mask, not fa1/0 and fa0/0
    network 192.168.12.0 0.0.0.255 area 0 <-- covers the whole damn /24 lol

    Also noticed both fa0/0 and 1/0 are running half duplex, is this by design?

    Anywho, let us know
    "The size of your dreams must always exceed your current capacity to achieve them. If your dreams do not scare you, they are not big enough.”
    ― Ellen Johnson Sirleaf
  • yrwinsyrwins Posts: 81Member ■■□□□□□□□□
    Hi guy's thanks...

    it's /29 network address - broadcast address ( host range)

    R4 fa0/0 192.168.12.26 /29 24-31 (25-30)
    R3 fa1/0 192.168.12.25 /29 24-31 (25-30)
    R2 fa1/0 192.168.12.17 /29 16-23 (17-22)

    yes it's a duplex half. but don't why it have to be half duplex...

    let me check on rest of the configuration
  • theodoxatheodoxa Posts: 1,340Member
    yrwins wrote: »
    yes it's a duplex half. but don't why it have to be half duplex...

    This would only really be required if connecting to a Hub (Basically a multiport repeater). That said, if one end is configured as Half Duplex and the other as Full Duplex, it will result in a lot of "late collisions" and "input errors" on the interface counters and will make the link act poorly.
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
Sign In or Register to comment.