Redistribute between OSPF EIGRP issue

shushshush Posts: 10Member ■□□□□□□□□□
Hi,
I'v got an exercise that including ospf with multi area (using virtual-link, because area 2 isn't directly connected to area 0 ) and redistribute between eigrp and ospf.
i have problem with the redistribution. The ASBR is R6. I don't have ping between R7(that is running only eigrp) between all the routers (R1-R5) that are running only ospf- R7 not get the routing of the ospf from R6.
I am new with all the redistribute subject, so i hope someone here can help me with it. I'm adding here picture of the topology and my configuration of all the routers:


[h=1]R1:[/h]
int fa0/0
des To_R2
ip add 10.0.0.1 255.255.255.252

int loopback1
ip add 11.11.11.11 255.255.255.255

router ospf 1
router-id 1.1.1.1
network 10.0.0.1 0.0.0.0 area 0
network 100.0.0.1 0.0.0.0 area 0


[h=1]R2:[/h]
int fa0/0
des To_R1_Area0
ip add 10.0.0.2 255.255.255.252

int fa0/1
des To_R3_Area1
ip add 20.0.0.1 255.255.255.252

int loopback1
ip add 22.22.22.22 255.255.255.255

router ospf 1
router-id 2.2.2.2
network 10.0.0.2 0.0.0.0 area 0
network 20.0.0.1 0.0.0.0 area 1
area 1 virtual-link 4.4.4.4


[h=1]R3:[/h]
int fa0/0
des To_R2
ip add 20.0.0.2 255.255.255.252

int fa0/1
des To_R4
ip add 20.0.0.5 255.255.255.252

int loopback1
ip add 33.33.33.33 255.255.255.255

router ospf 1
router-id 3.3.3.3
network 20.0.0.2 0.0.0.0 area 1
network 20.0.0.5 0.0.0.0 area 1


[h=2]R4:[/h]
int fa0/0
des To_R3
ip add 20.0.0.6 255.255.255.252

int fa0/1
des To_R5
ip add 30.0.0.1 255.255.255.252

int loopback1
ip add 44.44.44.44 255.255.255.255

router ospf 1
router-id 4.4.4.4
network 20.0.0.6 0.0.0.0 area 1
network 30.0.0.1 0.0.0.0 area 2
area 1 virtual-link 2.2.2.2


[h=1]R5:[/h]int fa0/0
des To_R4
ip add 30.0.0.2 255.255.255.252

int fa0/1
des To_R6
ip add 40.0.0.1 255.255.255.252

int loopback1
ip add 55.55.55.55 255.255.255.255

Router ospf 1
router-id 5.5.5.5
network 30.0.0.2 0.0.0.0 area 2
network 40.0.0.1 0.0.0.0 area 2


[h=1]R6:[/h]int fa0/0
des To_R5
ip add 40.0.0.2 255.255.255.252

int fa0/1
des To_R7
ip add 50.0.0.1 255.255.255.252

int loopback1
ip add 66.66.66.66 255.255.255.255

Router ospf 1
router-id 6.6.6.6
network 40.0.0.2 0.0.0.0 area 2
redistribute eigrp 1 subnets

router eigrp 1
network 50.0.0.1 0.0.0.0
redistribute ospf 1
no auto-summary


[h=1]R7:[/h]int fa0/0
des To_R6
ip add 50.0.0.2 255.255.255.252

int loopback1
ip add 77.77.77.77 255.255.255.255

router eigrp 1
network 50.0.0.2 0.0.0.0
no auto-summary

Comments

  • james43026james43026 Posts: 303Member
    Could you provide more information.

    1. Please post the routing table of at least R6 and R7
    2. Please run a traceroute from R7 to one of the OSPF routers and post the results.
    3. Please test to make sure that routing between all OSPF routers is working correctly. So ping and or trace route between R6 and R1
  • DCDDCD Posts: 449Member
    I glanced at your config and R6 is not complete R1 has a network statement for a network that is not attached to a interface. And I think I saw a couple of network without network statements. I would double check each router config again.
  • SimridSimrid Posts: 327Member
    When you are configuring redistribtion, devices need to learn how to reply to the ping (icmp-echo). I would suggest trying either a stactic route on your EIGRP node or redistributing from OSPF into EIGRP. Remember, when you are redistributing into EIGRP you will need to define the metrics.
    Network Engineer | London, UK | Currently working on: CCIE Routing & Switching

    sriddle.co.uk
    uk.linkedin.com/in/simonriddle
  • daveybdaveyb Posts: 28Member ■□□□□□□□□□
    You have a few problems here.

    1) You're not putting your loopbacks into OSPF or EIGRP.

    2) From Redistributing Routing Protocols - Cisco

    "IGRP and EIGRP need five metrics when redistributing other protocols: bandwidth, delay, reliability, load, and MTU, respectively. An example of IGRP metrics follows:"

    There are 2 ways to do this

    For all protocols being distributed into EIGRP:
    default-metric <bandwidth> <Delay> <reliability> <load> <MTU>

    eg
    default-metric 10000 100 255 1 1500

    Or just for OSPF
    redistribute ospf 1
    [FONT=arial, helvetica, Helvetica Neue, HelveticaNeue, Lucida Grande, sans-serif]<bandwidth> <Delay> <reliability> <load> <MTU>


    [/FONT]Once these two issues are corrected you should have full reachability.
  • james43026james43026 Posts: 303Member
    daveyb wrote: »
    You have a few problems here.

    1) You're not putting your loopbacks into OSPF or EIGRP.

    2) From Redistributing Routing Protocols - Cisco

    "IGRP and EIGRP need five metrics when redistributing other protocols: bandwidth, delay, reliability, load, and MTU, respectively. An example of IGRP metrics follows:"

    There are 2 ways to do this

    For all protocols being distributed into EIGRP:
    default-metric <bandwidth> <Delay> <reliability> <load> <MTU>

    eg
    default-metric 10000 100 255 1 1500

    Or just for OSPF
    redistribute ospf 1
    <bandwidth> <Delay> <reliability> <load> <MTU>


    Once these two issues are corrected you should have full reachability.

    Some great catches here. I'm interested to see what the OP has for us after looking into this.
Sign In or Register to comment.