Rip v2 to OSPF Redistribute - CCNA 4 WAN Case Study Problems

TC10284TC10284 Posts: 8Member ■□□□□□□□□□
Hello all.

I am trying to complete Phase 2 of the CCNA 4 WAN case study. I have the addressing correct according to what the instructor checked and when comparing to everyone else.
On phase 2, one of the bullets of items to complete is to Configure and redistribute RIP into the OSPF routing process.

After configuring all the routers (Limerick, Belfast, Cork, and Galway) with the appropriate routing protocols, IPs, etc, and then implementing the redistribute commands, I attempt to test the interfaces by pinging them using the IP address of each int.
I've found that I can get to all interfaces except the following:
When pinging from the Galway router to Limerick S0 (172.16.255.249)
from Galway to Belfast E0 (10.0.0.1)
from Galway to Befast S1 (172.16.255.250)

When pinging from the Limerick router to Galway E0 (172.16.4.1)
from Limerick to Galway S0 (172.16.255.245).

Below are each router's config (copy and paste from sh run):

#Limerick
en
config t

service timestamps debug uptime
service timestamps log uptime
no service password-encryption


hostname Limerick

enable secret class

ip subnet-zero

interface Ethernet0
no ip address
no ip directed-broadcast
shutdown

interface Ethernet1
no ip address
no ip directed-broadcast
shutdown

interface Serial0
ip address 172.16.255.249 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
clockrate 64000
no shut

interface Serial1
no ip address
no ip directed-broadcast
shutdown

router ospf 1
network 172.16.255.248 0.0.0.3 area 0

ip classless


line con 0
password cisco
login
transport input none

#Belfast

en
config t

service timestamps debug uptime
service timestamps log uptime
no service password-encryption

hostname Belfast

enable secret class

ip subnet-zero

interface Ethernet0
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no shut

interface Ethernet1
no ip address
no ip directed-broadcast
shutdown

interface Serial0
ip address 172.16.255.245 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
clockrate 64000
no shut

interface Serial1
ip address 172.16.255.250 255.255.255.252
no ip directed-broadcast
no shut

router ospf 1
network 10.0.0.0 0.255.255.255 area 0
network 172.16.255.244 0.0.0.3 area 0
network 172.16.255.248 0.0.0.3 area 0

ip classless


line con 0
exec-timeout 0 0
password cisco
login
transport input none
line aux 0
line vty 0 4
password cisco
login


#Cork


en
config t

service timestamps debug uptime
service timestamps log uptime
no service password-encryption

hostname Cork

enable secret class

ip subnet-zero

interface Ethernet0
ip address 172.16.0.1 255.255.252.0
no ip directed-broadcast
no shut

interface Serial0
ip address 172.16.255.241 255.255.255.252
no ip directed-broadcast
no shut

interface Serial1
ip address 172.16.255.246 255.255.255.252
no ip directed-broadcast
no shut

router ospf 1
redistribute rip subnets
network 172.16.0.0 0.0.3.255 area 0
network 172.16.255.240 0.0.0.3 area 0
network 172.16.255.244 0.0.0.3 area 0

router rip
version 2
network 172.16.0.0
no auto-summary

ip classless


line con 0
password cisco
login
transport input none
line aux 0
line vty 0 4
password cisco
login

#Galway

en
config t

service timestamps debug uptime
service timestamps log uptime
no service password-encryption

hostname Galway

enable secret class

ip subnet-zero

interface Ethernet0
ip address 172.16.4.1 255.255.252.0
no ip directed-broadcast
no shut

interface Serial0
ip address 172.16.255.242 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
no shut

interface Serial1
no ip addr
no ip directed-broadcast
shut

router rip
version 2
#Don't think I need the below
#redistribute ospf 1
network 172.16.0.0
no auto-summary

ip classless


line con 0
exec-timeout 0 0
password cisco
login
transport input none
line aux 0
line vty 0 4
password cisco
login


If you need any more information, I will be happy to give it. I found this PDF of the Case Study I am referring to.
http://faculty.ccri.edu/tonyrashid/Files/Cisco%20Project/CCNA4_CS1.pdf
Thanks for any help!
Tavis

Comments

  • TC10284TC10284 Posts: 8Member ■□□□□□□□□□
    Also,

    When comparing results to others in the class, they are having the same issue as I am.
    Tavis
  • EdTheLadEdTheLad Posts: 2,112Member
    Ok, the problem is that you have accounted for routes in one direction and not the other.You have redistributed routes from Rip into Ospf which is good, but the Galway router has no knowledge about the ospf routes.
    You could redistribute Ospf routes into Rip at Cork,but this isnt the best design here, it will work but if you added another entry point you could have a problem with "Mutual Redistribution"(read about it) and you would have to
    create distribution lists.
    The more simple approach would be to advertise a default route into Rip at Cork.Galway would receive this static route through Rip and send all unknown packets to Cork.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • TC10284TC10284 Posts: 8Member ■□□□□□□□□□
    Thank you very much. That did work.
    Also, on the Cork router, I found that a redistribute ospf 1 metric 1 would work as well. I do see what you are saying though.
    Tavis
Sign In or Register to comment.