Inter vlan connectivity

yovalyaryovalyar Posts: 10Member ■□□□□□□□□□
I made a packet tracer 6.3 lan . Configured with Router on a stick and DHCp
There is no connection between the vlans and also only vlan 30 got IP from the router's dhcp.
Can you help?? :)

Here is a config file form the router and the switch:
Router:!version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RTR-TLV-1
!
!
!
enable secret 5 $1$mERr$/Q/mbs3O9oHsKR7rNG4e81
enable password 1234
!
!
!
ip dhcp pool vlan10
network 192.168.1.0 255.255.255.224
default-router 192.168.1.1
dns-server 192.168.1.196
ip dhcp pool vlan20
network 192.168.1.160 255.255.255.224
default-router 192.168.1.161
dns-server 192.168.1.196
ip dhcp pool vlan30
network 192.168.1.128 255.255.255.224
default-router 192.168.1.129
dns-server 192.168.1.196
ip dhcp pool vlan40
network 192.168.1.64 255.255.255.224
default-router 192.168.1.65
dns-server 192.168.1.196
ip dhcp pool vlan50
network 192.168.1.32 255.255.255.224
default-router 192.168.1.33
dns-server 192.168.1.196
ip dhcp pool vlan60
network 192.168.1.96 255.255.255.224
default-router 192.168.1.97
dns-server 192.168.1.196
ip dhcp pool vlan70
network 192.168.1.224 255.255.255.224
default-router 192.168.1.225
dns-server 192.168.1.196
ip dhcp pool vlan80
network 192.168.1.192 255.255.255.224
default-router 192.168.1.193
dns-server 192.168.1.196
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.224
!
interface FastEthernet0/0.2
encapsulation dot1Q 20
ip address 192.168.1.161 255.255.255.224
!
interface FastEthernet0/0.3
encapsulation dot1Q 30
ip address 192.168.1.129 255.255.255.224
!
interface FastEthernet0/0.4
encapsulation dot1Q 40
ip address 192.168.1.65 255.255.255.224
!
interface FastEthernet0/0.5
encapsulation dot1Q 50
ip address 192.168.1.33 255.255.255.224
!
interface FastEthernet0/0.6
encapsulation dot1Q 60
ip address 192.168.1.97 255.255.255.224
!
interface FastEthernet0/0.7
encapsulation dot1Q 70
ip address 192.168.1.225 255.255.255.224
!
interface FastEthernet0/0.8
encapsulation dot1Q 80
ip address 192.168.1.193 255.255.255.224
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
!
ip classless
!
ip flow-export version 9


Switch
sion 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname TLV-SW2
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 40
!
interface FastEthernet0/2
switchport access vlan 40
!
interface FastEthernet0/3
switchport access vlan 40
!
interface FastEthernet0/4
switchport access vlan 40
!
interface FastEthernet0/5
switchport access vlan 40
!
interface FastEthernet0/6
switchport access vlan 40
!
interface FastEthernet0/7
switchport access vlan 40
!
interface FastEthernet0/8
switchport access vlan 60
!
interface FastEthernet0/9
switchport access vlan 60
!
interface FastEthernet0/10
switchport access vlan 60
!
interface FastEthernet0/11
switchport access vlan 60
!
interface FastEthernet0/12
switchport access vlan 60
!
interface FastEthernet0/13
switchport access vlan 60
!
interface FastEthernet0/14
switchport access vlan 60
!
interface FastEthernet0/15
switchport access vlan 60
!
interface FastEthernet0/16
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 30
!
interface FastEthernet0/18
switchport access vlan 30
!
interface FastEthernet0/19
switchport access vlan 30
!
interface FastEthernet0/20
switchport access vlan 20
!
interface FastEthernet0/21
switchport access vlan 20
!
interface FastEthernet0/22
switchport access vlan 20
!
interface FastEthernet0/23
switchport access vlan 20
!
interface FastEthernet0/24
switchport access vlan 20
!
interface GigabitEthernet0/1
switchport access vlan 20
switchport trunk allowed vlan 2-19,21-29,31-1002,1005
switchport mode trunk
!
interface GigabitEthernet0/2
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
banner motd DONT LOGIN THE SWITCH WITHOUT PREMISSION
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
!
!
line con 0
login
!
line vty 0 4
login
line vty 5 15
login
!
!
end

Comments

  • rob42rob42 Posts: 423Member
    Which Router are you using? I don't have any Routers with 24 fa ports (CPT V7).

    Maybe you could make your .pkt file available, via Dropbox, GoogleDrive or filedropper?

    Edit... Sorry, I misread your post. I can see now that you've a 24 port switch in the mix...
    No longer an active member
  • winsladewinslade Posts: 15Member ■□□□□□□□□□
    I played around with your lab

    TLV-SW2 seems to connect too all of its directly connected vlans (Vlans: 20,30,40,60)
    DHCP works on all the devices too, although i had to replace a few of the PC's. Not sure why...

    SW-TLV-2 only has ports in vlans 10 and 70 (Missing vlan 50 connections)
    SW-TLV-2 interface gig 0/1 is not in a trunking state
    SW-TLV-2, SW-TLV-3 and TLV-SW2 vlan databases are different (they all should know about all vlans)
    TLV-SW2 has "switchport access vlan 20" on gig 0/1, remove this command

    Also i excluded the ip's of the default gateways from DHCP (this is probably just a preference of mine)

    After these changes, i get full vlan to vlan connectivity
  • yovalyaryovalyar Posts: 10Member ■□□□□□□□□□
    Thanks a lot winslade
    ...can you send me a link to the packet file?
    I am novice in this .
    What do you mean "SW-TLV-2 only has ports in vlans 10 and 70 (Missing vlan 50 connections)" aren't the vlans data goes via the trunking.? That is I only need to configure diiffrent vlans on each switch and that info is known to the router and other switches via the trunking,
    as I understand -I dont need to configure acces ports to vlans which are not directly connected to the switch. I have the same to question regarding "SW-TLV-2, SW-TLV-3 and TLV-SW2 vlan databases are different (they all should know about all vlans)" ,isnt the databse is known via the trunking?
  • dontstopdontstop Posts: 578Member ■■■■□□□□□□
    That was fun!

    Give this a try: http://imgur.com/pQrqjyM

    It may take a few moments for the network to converge after adding these changes.
  • yovalyaryovalyar Posts: 10Member ■□□□□□□□□□
    Thanks mate. Appreciate it.
    I added all the vlans to all the switches (Switch config: vlan 10 ....Switch config: vlan 20 ...etc and it solved the problem.
    It took a while to get into it and I haven't seen any refrence to that. Is it strage or is it me :)
  • dontstopdontstop Posts: 578Member ■■■■□□□□□□
    Just for reference: Any switch that trunks a VLAN must be configured with that VLAN even if none of it's ports are on that VLAN. Otherwise the switch will just drop the traffic for it on the trunk as it doesn't know about it.

    I.e. <SW1> --- <SW2> --- <SW3>

    (SW1 & SW3) have VLAN 20 and trunk to SW2. If SW2 isn't configured with VLAN 20, it will not forward traffic for the VLAN 20. SW2 only needs to be configured with the VLAN 20 for it to become active and be willing to forward traffic between SW1 & SW3

    HTH
  • yovalyaryovalyar Posts: 10Member ■□□□□□□□□□
    If you will..
    Below is pkt with separte lans connected via frame relay.
    They can't communicate...
    Why?
    https://drive.google.com/file/d/0B-wqkAUoafjDUUt5VDlUWjVDLW8/view
  • HondabuffHondabuff Posts: 667Member ■■■□□□□□□□
    yovalyar wrote: »
    If you will..
    Below is pkt with separte lans connected via frame relay.
    They can't communicate...
    Why?
    https://drive.google.com/file/d/0B-wqkAUoafjDUUt5VDlUWjVDLW8/view

    Router(config)#interface Serial0/0/0
    Router(config-if)#no ip access-group 3 in
    “The problem with quotes on the Internet is that you can’t always be sure of their authenticity.” ~Abraham Lincoln
  • yovalyaryovalyar Posts: 10Member ■□□□□□□□□□
    Thanks Hondabuff
    Youe nailed the problem . I should have added £permit any any" at the end of access-group 3
Sign In or Register to comment.