Can't Ping Outside via Serial Interfaces, works with FastEthernet

awinterawinter Posts: 4Registered Users ■□□□□□□□□□
Hello,

I have the following setup:

Router 2
Serial
Router 1
Internet

10.1.1.2/24 10.1.1.1/24 192.168.1.254/24 192.168.2.1/24

I can ping from Router 2 to 192.168.1.254 with success
I can ping from Router 1 to 10.1.1.2 with success

I can't ping from Router 2 to 192.168.1.1 via a SERIAL connection between Router 2 and Router 1 it works however with Ethernet

Please, can someone explain why?

Thanks in advance.

Comments

  • awinterawinter Posts: 4Registered Users ■□□□□□□□□□
    Router 2
    Serial
    Router 1
    Internet

    10.1.1.2/24
    10.1.1.1/24
    192.168.1.254/24
    192.168.2.1/24
  • DCDDCD Posts: 449Member
    Supply the configuration for the R1 and R2. From the information you provide you misconfigured the one of the routers.
  • Ltat42aLtat42a Posts: 587Member ■■■□□□□□□□
    If using serial cables, did you set a clock rate on the DCE end of the cable?
  • dontstopdontstop Posts: 578Member ■■■■□□□□□□
    Do you have a routing protocol running? Sounds like maybe the Ethernet is working due to proxy arp. Routing only know about directly connected networks without a routing protocol the pings will fail (note: proxy arp) to networks the router isn't directly connected to.
  • awinterawinter Posts: 4Registered Users ■□□□□□□□□□
    Here are the two configs

    R1

    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$iW5B$.Gs35kpDvY1EPullF.b1S/
    !
    no aaa new-model
    clock timezone NL -3 30
    clock summer-time NDT recurring
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1 192.168.1.49
    ip dhcp excluded-address 192.168.10.1 192.168.10.49
    ip dhcp excluded-address 192.168.20.1 192.168.20.49
    !
    ip dhcp pool HOME
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 8.8.8.8 4.2.2.2
    !
    ip dhcp pool Pool10
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    dns-server 8.8.8.8 4.2.2.2
    !
    ip dhcp pool Pool20
    network 192.168.20.0 255.255.255.0
    default-router 192.168.20.1
    dns-server 8.8.8.8 4.2.2.2
    !
    !
    no ip domain lookup
    ip domain name homebase.net
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    !
    username andrew privilege 15 password 7 01100F175804
    !
    !
    interface FastEthernet0/0
    ip address 192.168.2.254 255.255.255.0
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface Serial0/0
    ip address 10.1.1.1 255.255.255.0
    !
    interface FastEthernet0/1
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.10
    encapsulation dot1Q 10
    ip address 192.168.10.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    !
    interface FastEthernet0/1.20
    encapsulation dot1Q 20
    ip address 192.168.20.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    !
    router rip
    version 2
    network 10.0.0.0
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.10.0
    network 192.168.20.0
    !
    ip default-gateway 192.168.2.1
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.168.2.1
    !
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list NAT_ADDRESSES interface FastEthernet0/0 overload
    !
    ip access-list standard NAT_ADDRESSES
    permit 192.168.1.0 0.0.0.255
    permit 192.168.10.0 0.0.0.255
    permit 192.168.20.0 0.0.0.255
    !
    control-plane
    !
    line con 0
    exec-timeout 0 0
    password 7 110A1016141D
    logging synchronous
    login local
    line aux 0
    login local
    line vty 0 4
    exec-timeout 0 0
    password 7 0822455D0A16
    logging synchronous
    login local
    transport input telnet ssh
    !
    ntp clock-period 17180043
    ntp server 50.22.155.163
    !
    end


    R1#

    AND HERE IS R2

    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname R2
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$wWEN$3lvonIc5JcQh2Z.a/sylE1
    !
    no aaa new-model
    clock timezone NL -3 30
    clock summer-time NDT recurring
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ip domain name homebase.net
    !
    !
    username andrew privilege 15 secret 5 $1$oIVK$FsdL65yQ9VNtJpDgRjfLe1
    !
    !
    ip ssh version 2
    !
    !
    interface FastEthernet0/0
    ip address dhcp
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address dhcp
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    ip address 10.1.1.2 255.255.255.0
    no fair-queue
    !
    router rip
    version 2
    network 10.0.0.0
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 10.1.1.1
    ip route 0.0.0.0 0.0.0.0 Serial0/0/0
    !
    ip http server
    no ip http secure-server
    !
    !
    control-plane
    !
    !
    line con 0
    exec-timeout 30 0
    password 7 01100F175804
    logging synchronous
    login local
    line aux 0
    exec-timeout 30 0
    password 7 094F471A1A0A
    logging synchronous
    login local
    line vty 0 4
    exec-timeout 30 0
    password 7 00071A150754
    logging synchronous
    login local
    !
    scheduler allocate 20000 1000
    ntp clock-period 17179076
    ntp server 192.168.2.254
    end

    This is the output of R1# show ip route

    R1#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route


    Gateway of last resort is 192.168.2.1 to network 0.0.0.0


    C 192.168.10.0/24 is directly connected, FastEthernet0/1.10
    C 192.168.20.0/24 is directly connected, FastEthernet0/1.20
    10.0.0.0/24 is subnetted, 1 subnets
    C 10.1.1.0 is directly connected, Serial0/0
    C 192.168.1.0/24 is directly connected, FastEthernet0/1
    C 192.168.2.0/24 is directly connected, FastEthernet0/0
    S* 0.0.0.0/0 [1/0] via 192.168.2.1
    R1#

    This Show IP Route R2

    R2#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route


    Gateway of last resort is 10.1.1.1 to network 0.0.0.0


    R 192.168.10.0/24 [120/1] via 10.1.1.1, 00:00:21, Serial0/0/0
    R 192.168.20.0/24 [120/1] via 10.1.1.1, 00:00:21, Serial0/0/0
    10.0.0.0/24 is subnetted, 1 subnets
    C 10.1.1.0 is directly connected, Serial0/0/0
    C 192.168.1.0/24 is directly connected, FastEthernet0/1
    R 192.168.2.0/24 [120/1] via 10.1.1.1, 00:00:21, Serial0/0/0
    S* 0.0.0.0/0 [1/0] via 10.1.1.1
    is directly connected, Serial0/0/0
    R2#

    Remember the problem is I cannot PING 192.168.2.1 from R2 or connect to the 192.168.2.X network. I can ping 192.168.2.254 only.

    Thanks in advance.
  • DCDDCD Posts: 449Member
    Your configuration is confusing you have
    Router 2
    Serial
    Router 1
    Internet

    10.1.1.2/24
    10.1.1.1/24
    192.168.1.254/24
    192.168.2.1/24


    But yourrouter config is this


    R1
    interface FastEthernet0/0
    ip address 192.168.2.254 255.255.255.0
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto



    interfaceFastEthernet0/1
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto



    You have two different subnets between R1 and the Internet.I don’t know why on R1 you have ip default-gateway 192.168.2.1 and ip route0.0.0.0 0.0.0.0 192.168.2.1. You have sub-interface on f0/1 and using a IPaddress on F0/1.
    I not sure what youare trying do but I would redo R1. Set a static IP address on the Ethernet interfaceand I would have the NAT changing the 10.1.1.0/24 to 192.168.2.X/24 network.Also if you could put description for the interface.
  • tunerXtunerX Posts: 447Member ■■■□□□□□□□
    Router 1 uses an inside source list that only includes the 192 networks. Router 2 will be using a 10 network as its source address.

    Also you would need ip nat inside on the serial interface of router 1.
  • awinterawinter Posts: 4Registered Users ■□□□□□□□□□
    Hi, Thanks all for your input. TunerX put me on the right path. Problem was ip nat inside was not declared for the serial interface and the ACL NAT_ADDRESSES did not have the 10.1.1.0 network allowed. Problem solved!

    Thanks again!
Sign In or Register to comment.