woohoo finally got my lab setup!!!

HELLZxPHADERHELLZxPHADER ■■□□□□□□□□ Posts: 74Member ■■□□□□□□□□
wt_network.jpg

Finally connected it to internet. If anybody need show runs, just let me know. My setup is still in noob stages but they work!!!=). Now its time to install some routing protocols and mess with it all over again. Please let me know of any other next step suggestions, thanks everyone!!!

Comments

  • thisisalex02thisisalex02 Posts: 136Member
    hey nice setup.. can you put up show runs for your 2621? thanks
    Switches are bridges on steroids!
  • HELLZxPHADERHELLZxPHADER ■■□□□□□□□□ Posts: 74Member ■■□□□□□□□□
    here is the original show run i used, I got it from tek-tips.com. That site is a very useful one for cisco hardware, troubleshooting, and configuration, lotta answers about hardware there. I tried to copy the config first, then after it worked, I removed some lines and edited others to make the rest of my hardware connected. Its perfect for a single router dhcp setup to internet.

    clock timezone EST -3
    ip subnet-zero
    !
    !Use your favorite nameserver either ISP or other
    !
    ip name-server xx.xx.xx.xx
    ip name-server xx.xx.xx.xx
    !
    !Use the router as a DHCP server for your network
    !
    no ip dhcp conflict logging
    !
    ! exclude a range for your printers, router and any other static device
    !
    ip dhcp excluded-address 10.1.1.1 10.1.1.9
    !
    ip dhcp pool DHCP-POOL
    network 10.1.1.0 255.255.255.0
    domain-name cox.rr.com
    dns-server 24.28.192.64 24.28.192.65
    default-router 10.1.1.1
    !
    !
    interface Ethernet0/0
    description Outside interface to COX/RR
    !
    !This will force the assigned MAC(if needed) to the Ethernet interface
    !
    mac-address 0050.9999.c3be
    ip address dhcp
    ip nat outside
    ip access-group 107 in
    !
    interface Ethernet0/1
    description Inside interface to your network
    ip address 10.1.1.1 255.255.255.0
    ip nat inside
    !
    ip nat inside source list 1 interface Ethernet0/0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0
    no http server
    !
    access-list 1 permit 10.1.1.0 0.0.0.255
    !
    !Access list 107 will deny private IP ranges from outside your network to come it as a
    !security measure. It also denies ICMP PINGs to help *hide* the router from scanners. Lastly
    !it denies the FINGER protocol.
    !
    access-list 107 deny ip 10.0.0.0 0.255.255.255 any log
    access-list 107 deny ip 172.0.0.0 0.255.255.255 any log
    access-list 107 deny ip 127.0.0.0 0.255.255.255 any log
    access-list 107 deny ip 255.0.0.0 0.255.255.255 any log
    access-list 107 deny ip 224.0.0.0 0.255.255.255 any log
    access-list 107 deny ip 192.168.50.0 0.0.0.255 any log
    access-list 107 deny icmp any any echo log
    access-list 107 deny tcp any any eq finger
    access-list 107 permit ip any any
    ! no cdp run
    !
    end


    You have to manually edit your dhcp-pool to match ur current dns-servers. I didnt use the mac address line.
  • RUN-DMCRUN-DMC ■■□□□□□□□□ Posts: 35Member ■■□□□□□□□□
    What type of WAN connection is this? Is that a cable modem in the diagram?

    Nice work too! :D
  • ccie_in_the_makingccie_in_the_making ■□□□□□□□□□ Posts: 27Member ■□□□□□□□□□
    you better not fail with a setup like that especially when a simulator is all you really need
  • mikej412mikej412 Posts: 10,090Member
    a simulator is all you really need
    Wow -- you found a simulator that actually works and does more then just its supported labs? Which one and version is it?

    I thought Boson was the best available -- and it could get someone through the CCNA (if it's all they had). But I've loaded working configs from routers into Boson (with just the supposedly supported commands) and had it fail. I've used the labs -- which worked -- and had the same configurations fail when I typed them in. My favorite was having to save and shutdown and reload configs and reconfigure the hosts to get some configurations to work. I wonder if that problem was ever fixed....

    If the CCNP version ever gets out of beta and actually works (for the commands it supports) -- then yeah -- there could be a bunch more CCNPs out there who have never touched a router and can't do the job in real life (unless they get a corporate job doing TPS reports).

    I think it was RouterSim -- it's also "cute" and I like being able to add equipment and links on the fly -- but after fighting with it, I never got it to do more than basic stuff. Loved the interface, but wasted a bunch of time before I gave up on it.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • RUN-DMCRUN-DMC ■■□□□□□□□□ Posts: 35Member ■■□□□□□□□□
    I think it was RouterSim -- it's also "cute" and I like being able to add equipment and links on the fly -- but after fighting with it, I never got it to do more than basic stuff.

    He said "cute" !
  • mikej412mikej412 Posts: 10,090Member
    dmc wrote:
    He said "cute" !
    Yeah -- like a puppy. Even when it pees (or doesn't work) on the dining room carpet -- you think it will outgrow it.... That's why I still have NetSim and RouterSim loaded on my laptop...... maybe someday they will work (or at least stop peeing on my laptop). icon_lol.gif
    :mike: Cisco Certifications -- Collect the Entire Set!
  • gworks1gworks1 ■□□□□□□□□□ Posts: 2Member ■□□□□□□□□□
    I didn't touch one "live" router to pass the test... I used Packet Tracer 3.2. This program worked great and had pre-made labs which hammered home my abilities in setting up NAT, VLAN's, ACL's and all-around troubleshooting.

    Maybe I just got lucky, but I passed the CCNA test on my first time after studying for only 3 weeks. (thanks mostly to Todd Lammle's book, Packet Tracer, and lots of practice questions/tests)...
  • mikej412mikej412 Posts: 10,090Member
    Please let me know of any other next step suggestions
    A second switch.... another 2950 would be great, but a 2900 series would be okay. If you start hunting now on eBay you should eventually get a good deal.

    You can do frame relay with what you have... but it would be more fun (for point-to-multipoint) with a 252x router acting as the frame switch (or an NM-4A/S or NM-4T or NM-8A/S for one of the 2600s).

    Definitely a good setup that will take you into the CCNP.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • SephirothSephiroth ■□□□□□□□□□ Posts: 1Member ■□□□□□□□□□
    Im in a CCNA Class in College and i need to set up a VLAN on CCNA RouterSim For some reason it will not WORK, IF anyone can help me i willl be in ur debt [email protected] is my email, PLEASE PLEASE I NEED HELP FAST
  • HumperHumper Posts: 647Member
    Sephiroth wrote:
    Im in a CCNA Class in College and i need to set up a VLAN on CCNA RouterSim For some reason it will not WORK, IF anyone can help me i willl be in ur debt [email protected] is my email, PLEASE PLEASE I NEED HELP FAST

    Just post it here and I will see what I can do to help.
    Now working full time!
  • darkplayerdarkplayer ■□□□□□□□□□ Posts: 23Member ■□□□□□□□□□
    Forgive my ignorance and bringing this thread back to life, so was this lab setup dealing with real equipment or part of a simulation?

    That whole setup looks really nice :D

    Thanks
  • HELLZxPHADERHELLZxPHADER ■■□□□□□□□□ Posts: 74Member ■■□□□□□□□□
    welp heres the current config, isp to 2621 @ 3 dhcp networks to 2950 intervlaned, and i just passed the 640-801 today wooohooo!!!!!!
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname 2621
    !
    no logging console
    enable password 7 030C5E070A15
    !
    ip subnet-zero
    !
    !
    no ip domain-lookup
    ip host forty x.x.x.x
    ip host fifty 10.1.1.2
    ip host twentyone 10.1.1.1
    ip host eleven 10.20.20.1
    ip host ten 10.10.10.1
    no ip dhcp conflict logging
    ip dhcp excluded-address 10.1.1.1
    !
    ip dhcp pool DHCP-POOL2621
    network 10.1.1.0 255.255.255.248
    domain-name comcast.com
    dns-server x.x.x.x x.x.x.x
    default-router 10.1.1.1 10.2.2.1
    !
    ip dhcp pool end
    !
    ip dhcp pool 2621sub2
    network 10.2.2.0 255.255.255.248
    domain-name comcast.com
    dns-server x.x.x.x x.x.x.x
    default-router 10.2.2.1
    !
    ip dhcp pool 2621sub3
    network 10.3.3.0 255.255.255.248
    domain-name comcoast.com
    dns-server x.x.x.x x.x.x.x
    default-router 10.3.3.1
    !
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address dhcp
    ip nat outside
    duplex auto
    speed auto
    !
    interface BRI0/0
    no ip address
    shutdown
    !
    interface Serial0/0
    ip address 10.50.50.1 255.255.255.252
    ip nat inside
    clockrate 64000
    !
    interface FastEthernet0/1
    no ip address
    ip nat inside
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.1
    encapsulation dot1Q 1 native
    ip address 10.1.1.1 255.255.255.248
    ip nat inside
    !
    interface FastEthernet0/1.2
    encapsulation dot1Q 2
    ip address 10.2.2.1 255.255.255.248
    ip nat inside
    !
    interface FastEthernet0/1.3
    encapsulation dot1Q 3
    ip address 10.3.3.1 255.255.255.248
    ip nat inside
    !
    interface Serial0/1
    ip address 10.40.40.1 255.255.255.252
    ip nat inside
    clockrate 64000
    !
    router ospf 21
    log-adjacency-changes
    network 10.0.0.0 0.255.255.255 area 0
    network x.x.x.0 0.0.0.255 area 0
    !
    ip nat inside source list 1 interface FastEthernet0/0 overload
    ip classless
    ip http server
    ip pim bidir-enable
    !
    access-list 1 permit 10.1.1.0 0.0.0.7
    access-list 1 permit 10.2.2.0 0.0.0.7
    access-list 1 permit 10.3.3.0 0.0.0.7
    access-list 2 permit 10.0.0.0 0.255.255.255 log
    access-list 10 permit any log
    !
    !
    dial-peer cor custom
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    access-class 10 in
    exec-timeout 16 0
    privilege level 15
    password 7 1211001B1E11
    login
    !
    end
  • thisisalex02thisisalex02 Posts: 136Member
    wow congrats.. what did you use as your study materials ? ? can you give a noob like me any tips?
    Switches are bridges on steroids!
  • mikej412mikej412 Posts: 10,090Member
    and i just passed the 640-801 today wooohooo!!!!!!

    Congratulations! icon_thumright.gif

    So.... what's next?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • HELLZxPHADERHELLZxPHADER ■■□□□□□□□□ Posts: 74Member ■■□□□□□□□□
    i sent you a message mike, tell me if you got it.
  • mikej412mikej412 Posts: 10,090Member
    I keep forgetting that I should check for messages.... or let techexams do popups! icon_lol.gif

    Funny you should ask.... I was already thinking about what you should add if you were going for the CCNP.

    Dedicated frame switch -- 252x with 4 or 10 ports. That way you can do point to multipoint frame-relay and have the multipoints to play with. The 10 port would take you to the CCIE level.... but you can tunnel a couple of the 4 port versions together later on if you need more frame relay ports.

    I nearly bought 2 2811 routers for my CCIE lab... but decided the money was better spent elsewhere. I haven't figured out the "bang-for-the-buck" difference between a 2600xm and the 2800x. I have the 3640 which run 12.4 and my 2600s have the upgraded boot roms that allow 32 meg flash.

    The 3550s have had end-of-life announced..... so maybe the prices will finally come down on eBay.... For the CCNP (BCMSN) it would be very nice to have one to do the layer 3 switching. And then another "cheap" switch -- 3 switches for STP and VTP is a lot more fun. :D A cheap 2900 enterprise series would work (but so would another 2950 or a 2nd 3550 icon_lol.gif ). The cheap 29xx would let you do ISL.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • HELLZxPHADERHELLZxPHADER ■■□□□□□□□□ Posts: 74Member ■■□□□□□□□□
    thanks for the response mike. I think i will start off with a second 2950, i want a 2801 bad because of the wireless card add on option to turn the thing into a wifi router with 3 slots left. A friend of mine has a 3640 so I just telnet to his sometimes, I also wanna stick with the slim line of cisco stuff. But thanks again for the advice.
  • 2lazybutsmart2lazybutsmart Posts: 1,119Member
    mikej412 wrote:
    (or an NM-4A/S or NM-4T or NM-8A/S for one of the 2600s).

    Our company bought a couple of NM-4Ts and none of them seem to be working on the 2600 series routers.

    Do you have --or have you ever had-- an NM-4T actually working on a 2600 series router?

    2lbs.
    Exquisite as a lily, illustrious as a full moon,
    Magnanimous as the ocean, persistent as time.
  • mikej412mikej412 Posts: 10,090Member
    Do you have --or have you ever had-- an NM-4T actually working on a 2600 series router?
    The NM-4T only works in the 2691, and not the other current 26xxXMs (so probably not the older 26xxs), also works in the 36xx, 37xx, or 38xx series routers. I guess that why I keep this link handy.

    http://www.cisco.com/warp/public/765/tools/quickreference/routermodxref.pdf

    I'm running a 4A/S in the 2620 right now.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • 2lazybutsmart2lazybutsmart Posts: 1,119Member
    mikej412 wrote:
    Do you have --or have you ever had-- an NM-4T actually working on a 2600 series router?
    The NM-4T only works in the 2691, and not the other current 26xxXMs (so probably not the older 26xxs), also works in the 36xx, 37xx, or 38xx series routers. I guess that why I keep this link handy.

    http://www.cisco.com/warp/public/765/tools/quickreference/routermodxref.pdf

    I'm running a 4A/S in the 2620 right now.

    Thanks for the link. pretty helpful.

    the 4A/S works on the 26xxXM's, too, right?

    2lbs.
    Exquisite as a lily, illustrious as a full moon,
    Magnanimous as the ocean, persistent as time.
  • mikej412mikej412 Posts: 10,090Member
    the 4A/S works on the 26xxXM's, too, right?
    Yes.

    Man... those 4Ts hardly work in anything!
    :mike: Cisco Certifications -- Collect the Entire Set!
  • skaeightskaeight Posts: 130Member
    It looks like this lab setup costs some serious cabbage. Cisco certifications don't come cheap apparently. What would be a reasonably cheap but yet accptable let setup which could be used for CCNA/CCNP?
  • mikej412mikej412 Posts: 10,090Member
    skaeight wrote:
    It looks like this lab setup costs some serious cabbage. Cisco certifications don't come cheap apparently. What would be a reasonably cheap but yet accptable let setup which could be used for CCNA/CCNP?

    Well... there is cheap, and then there is easier.... pick one. icon_lol.gif

    In chinaman's thread "What materials do I need for CCNP?"
    http://www.techexams.net/forums/viewtopic.php?t=15117
    I posted what I think could work -- but I actually had more than that...

    You shouldn't get distracted by the flashing lights, but you also shouldn't ignore them. I noticed Cisco Routers didn't like the PC Time Server I was using because the interfaces flashing light pattern was "wrong."

    The CCNA would be 4 routers (frame and router on a stick still required) and you could survive with the 2950 and 29xx or maybe even two 29xxs. 3 switches is still easier, but 2 works if you understand the stuff.
    :mike: Cisco Certifications -- Collect the Entire Set!
Sign In or Register to comment.