TCP/IP Vol II - errata?

bmaurobmauro Posts: 307Member
Looking for some help guys!

Going through the configuration exercises in Doyle's excellent TCP/IP Vol II (second edition).

I'm on Chapter 4 BGP filtering, and the configuration exercise. I'm banging my head against the wall since the bgp output and next hop information does not line up at all with the starting IP/Interface information that is given to you in the first step.

I've gone over the provided information several times and the "show ip bgp" commands in the book show routes taking paths that no not exist.

If anyone has the first edition - or possibly the digital version - could you please compare your Table 4-5 to what I have below? I don't want to skip this exercise, but it seems like there is a lot of missing/incorrect info. I've check for an errata and came up empty handed.

Here was the latest part that seems to be missing (hopefully I'm wrong):

Table 4-5 page 388

R5
AS-20
Loopback 0 192.168.255.5/32
Loopback 1 172.17.20.1/24
FastEthernet 1/0 10.0.0.29/30
FastEthernet 2/1 10.0.0.26/30

R5
!
router bgp 20
network 10.20.0.0 mask 255.255.0.0
network 20.0.0.0 mask 252.0.0.0
network 172.17.20.0 mask 255.255.255.0
network 172.17.21.64 mask 255.255.255.192
network 172.17.21.192 mask 255.255.255.240
neighbor 10.0.0.25 remote-as 10

R10
AS-50
Loopback 0 192.168.255.10/32
Loopback 1 10.50.0.1/16
Loopback 2 50.0.0.1/11
FastEthernet 1/0 10.0.0.73/30
FastEthernet 2/0 10.0.0.70/30

router bgp 50
no synchronization
bgp log-neighbor-changes
network 10.50.0.0 mask 255.255.0.0
network 50.0.0.0 mask 255.224.0.0
neighbor 10.0.0.69 remote-as 40
neighbor 10.0.0.74 remote-as 70

Yet here is part of the bgp table from R5:


R5#show ip bgp neighbors 10.0.0.82 advertised-routes
BGP table version is 33, local router ID is 192.168.255.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.50.0.0/16 10.0.0.82 0 0 50 i
*> 10.70.0.0/16 10.0.0.82 0 50 70 i

And part of the table from R10

R10#sh ip bgp
BGP table version is 39, local router ID is 192.168.255.10
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.10.0.0/20 10.0.0.81 0 20 10 i
* 10.0.0.74 0 70 60 10 i

Now my eyes are about ready to cross, so I apologize in advance here. But I don't see 10.0.0.81/82 anywhere in the IPs during initial interface configuration. This is the third or fourth error I've come across in this example and just wondering if someone has the first edition or digital that I can compare with.

Thanks in advance!

Comments

  • rtidrtid Posts: 18Member ■□□□□□□□□□
    I don't see it in the first edition, but the exercise setup is different. You've encountered one of the issues with Doyle's texts, which is he uses far too many specialized topologies to get a point across. The strength of using a reference network across an entire book is that a person could reasonably extrapolate the correct addresses if mistakes are made in print.

    My advice is to move forward, or test yourself with the objective using your own known topology. You can abstract the exercise objectives easily enough.
Sign In or Register to comment.