Windows Server 2016 Cluster creation issue

november24november24 Posts: 24Member ■■■□□□□□□□
edited January 30 in Microsoft
My home lab consists of 3 Windows Server 2016 hosts named HV01, HV02 and HV03, and a single domain controller named DC.
The DC also acts as the DNS for the 3 hosts and it has single a single NIC and is configured as follows:

   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.1.10(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.2
   DNS Servers . . . . . . . . . . . : 127.0.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

The hosts also have a single NIC with the following configuration:
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.1.21(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.2
   DNS Servers . . . . . . . . . . . : 192.168.1.10
                                                  192.168.1.2
   NetBIOS over Tcpip. . . . . . . . : Enabled

all the servers are connected to a single switch and a router that acts as a gateway.

The issue a faced each time I create a Cluster in Windows 2016, The cluster failed to create a record in DNS.
and I keep getting the event error message "
Cluster network name resource 'Cluster Name' failed registration of one or more associated DNS name(s) for the following reason: DNS server failure."


Comments

  • kaijukaiju Posts: 268Member ■■■■□□□□□□
    Read item 7 of the "Create the failover clsuter" section in this link.

    Work smarter NOT harder! Semper Gumby!
  • november24november24 Posts: 24Member ■■■□□□□□□□
    kaiju said:
    Read item 7 of the "Create the failover clsuter" section in this link.

    Thanks for the advice, in fact, I already followed what is in this document, but finally, I found a solution, I removed the secondary DNS server IP address from the NIC settings for all clients.
Sign In or Register to comment.