Router doesn't send a DHCP OFFER

hdgorodhdgorod Member Posts: 3 ■■□□□□□□□□
Hello to the community,

I am prepering for my CCNA exam and have the following task and issue:

I Have the following network devices in gns3: 
- R1: c3725 router and works as DHCP Server
- ESW1: a c3745 Router with NM-16ESW Slot, therefore operates es L3 Switch
- PC1: Is VPCS

Here the network topology:
- R1 f0/0 connected to ESW1 f1/0
- PC1 e0 connected to ESW1 f1/1

I have the following tasks:
1) Exclude first 10 IP addresses in subnet from pool
Pool name = vlan10
2) Network = 10.1.10.0/24 (Vlan 10)
3) Default Gateway = ESW1
4) DNS Server = R1
5) Make sure PC can ping the loopback of R1
6) Configure IP Helper, so PC1 can send DHCP Discover to R1

Here the IP Plan:
R1 f0/0: 10.1.1.254/24
R1 Loopback: 1.1.1.1/32
ESW1 f1/0: 10.1.1.1/24, and belongs to int vlan1
ESW1 f1/1: 10.1.10.1/24, and belongs to int vlan10

I have configured everything as it has to be configured. I can ping the loopback on R1 from the PC1 and back, but when PC1 sends DHCP Discover, R1 does recieve it, but doesn't send a DHCP offer. And i don't understand why. Because in Packet Tracer the same configuration works fine, but in gns3 it doesn't.

Here the output on R1 after i habe enabled debug ip hdcp packet:

*Mar  1 01:59:10.971: UDP: rcvd src=0.0.0.0(68), dst=10.1.1.1(67), length=372
*Mar  1 01:59:10.971: DHCPD: DHCPDISCOVER received from client 0100.5079.6668.00 on interface FastEthernet0/0.
R1#
*Mar  1 01:59:11.975: UDP: rcvd src=0.0.0.0(68), dst=10.1.1.1(67), length=372
*Mar  1 01:59:11.975: DHCPD: DHCPDISCOVER received from client 0100.5079.6668.00 on interface FastEthernet0/0.
R1#
*Mar  1 01:59:14.987: UDP: rcvd src=0.0.0.0(68), dst=10.1.1.1(67), length=372
*Mar  1 01:59:14.987: DHCPD: DHCPDISCOVER received from client 0100.5079.6668.00 on interface FastEthernet0/0.
R1#
*Mar  1 02:19:26.947: UDP: rcvd src=0.0.0.0(68), dst=255.255.255.255(67), length=372
*Mar  1 02:19:26.947: DHCPD: DHCPDISCOVER received from client 0100.5079.6668.00 on interface FastEthernet0/0.
R1#
*Mar  1 02:19:27.951: UDP: rcvd src=0.0.0.0(68), dst=255.255.255.255(67), length=372
*Mar  1 02:19:27.955: DHCPD: DHCPDISCOVER received from client 0100.5079.6668.00 on interface FastEthernet0/0.
R1#
*Mar  1 02:19:30.963: UDP: rcvd src=0.0.0.0(68), dst=255.255.255.255(67), length=372
*Mar  1 02:19:30.963: DHCPD: DHCPDISCOVER received from client 0100.5079.6668.00 on interface FastEthernet0/0.
R1#

Does anyone have an idea, why it doesn't work in gns3? May be there is some issue with the L3 switch? Or something of that kind?

Tagged:

Comments

  • hdgorodhdgorod Member Posts: 3 ■■□□□□□□□□
    edited April 14
    Here is the running config of R1: 

    R1#sh run
    Building configuration...

    ...
    !
    hostname R1
    !
    ...
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.1.10.1 10.1.10.10
    ip dhcp excluded-address 10.1.20.1 10.1.20.10
    !
    ip dhcp pool vlan10
       network 10.1.10.0 255.255.255.0
       default-router 10.1.10.1
       dns-server 10.1.1.254
    !
    ip dhcp pool vlan20
       network 10.1.20.0 255.255.255.0
       default-router 10.1.20.1
       dns-server 10.1.1.254
    !
    !
    no ip domain lookup
    !
    ...
    !
    !
    !
    !
    interface Loopback0
     ip address 1.1.1.1 255.255.255.255
    !
    interface FastEthernet0/0
     ip address 10.1.1.254 255.255.255.0
     duplex auto
     speed auto
    !
    ...
    !
    ip forward-protocol nd
    ip route 10.1.10.0 255.255.255.0 10.1.1.1
    ip route 10.1.20.0 255.255.255.0 10.1.1.1
    !
    !
    no ip http server
    no ip http secure-server
    !
    no cdp log mismatch duplex
    !
    !
    !
    !
    !
    !
    ...
    !
    !
    end




    Here is the running config of ESW1: 

    ESW1#sh run
    Building configuration...

    Current configuration : 2759 bytes
    !
    ...
    !
    hostname ESW1
    !
    ...
    !
    interface FastEthernet1/0
     duplex full
     speed 100
    !
    interface FastEthernet1/1
     switchport access vlan 10
     duplex full
     speed 100
    !
    interface FastEthernet1/2
     switchport access vlan 20
     duplex full
     speed 100
    !
    interface FastEthernet1/3
     duplex full
     speed 100
    !
    ...
    !
    interface Vlan1
     ip address 10.1.1.1 255.255.255.0
    !
    interface Vlan10
     ip address 10.1.10.1 255.255.255.0
     ip helper-address 10.1.1.254
    !
    interface Vlan20
     ip address 10.1.20.1 255.255.255.0
     ip helper-address 10.1.1.254
    !
    ip forward-protocol nd
    ip route 1.1.1.1 255.255.255.255 10.1.1.254
    !
    !
    ...
    !
    end
  • hdgorodhdgorod Member Posts: 3 ■■□□□□□□□□
    Ok, I have found the solution.
    There was really a problem with the L3 switch I have used.
Sign In or Register to comment.