Ping help

rdtechrdtech Posts: 23Member ■□□□□□□□□□
I have two cisco routers 2500, when I ping each of the routers the ping is successful, when I ping the two computer it hooks up to the routers they can not ping each other. when I ping from the routers I am able to ping both computer. When I ping from the computer it is able to ping both routers. thank you for anyone help.
ROOSEVD

Comments

  • Ching01Ching01 Posts: 83Member ■■□□□□□□□□
    Can you show me your configuration it's difficult to troubleshoot if we don't know your configuration.
  • brAunbrAun Posts: 66Member ■■□□□□□□□□
    em..., i think u should check ur routing protocol, u need routing protocol to route the traffic. make sure u configure rite the routing protocol..
    Failure is the mother of success, just never stop trying :)
  • mikej412mikej412 Posts: 10,090Member
    brAun wrote:
    i think u should check ur routing protocol
    Yep, I think brAun nailed it.

    Sounds like you have the default gateways on the PCs... and the routers know about their connected networks, but not the networks connected to the other router.

    You either need static routes or to run a routing protocol and advertise those networks.

    There is a CCNA TechLab here on Configuring a RIP Network that might push you in the right direction. The network you described looks like the network in this TechLab.
    http://www.techexams.net/technotes/ccna/lab_1_rip.shtml
    :mike: Cisco Certifications -- Collect the Entire Set!
  • binarysoulbinarysoul Posts: 993Member
    also make sure one router is properyly set as DCE althouth I believe this is automatic. Ensure, as other mentioned, you have RIP or IGRP properly enabled.
  • forbeslforbesl Posts: 454Member
    binarysoul wrote:
    also make sure one router is properyly set as DCE
    If this was his problem, his routers wouldn't be able to ping each other as he indicated in original post:
    from his original post:
    when I ping each of the routers the ping is successful

    Troubleshooting 101.....
  • rdtechrdtech Posts: 23Member ■□□□□□□□□□
    I do setup my DCE and my Ip Roting Protocol

    This is the routers configuration.



    R-1#sh run
    Building configuration...

    Current configuration:
    !
    version 11.0
    service udp-small-servers
    service tcp-small-servers
    !
    hostname R-2
    !
    !
    username R-2 password 7 030752180500
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    !
    interface Serial0
    no ip address
    shutdown
    no fair-queue
    !
    interface Serial1
    ip address 192.168.10.10 255.255.255.0
    encapsulation ppp
    ppp authentication chap
    !
    ip route 192.168.2.0 255.255.255.0 192.168.10.20
    !
    line con 0
    line 1 8
    transport input all
    line aux 0
    transport input all
    line vty 0 4
    login
    !
    end

    R-1#





    R-2>en
    R-2#sh run
    Building configuration...

    Current configuration:
    !
    version 11.0
    service udp-small-servers
    service tcp-small-servers
    !
    hostname R-2
    !
    !
    username R-1 password 7 030752180500
    !
    interface Ethernet0
    ip address 192.168.2.1 255.255.255.0
    !
    interface Serial0
    no ip address
    shutdown
    no fair-queue
    !
    interface Serial1
    ip address 192.168.10.20 255.255.255.0
    encapsulation ppp
    ppp authentication chap
    !
    ip route 192.168.1.0 255.255.255.0 192.168.10.10
    !
    line con 0
    line 1 8
    transport input all
    line aux 0
    transport input all
    line vty 0 4
    login
    !
    end

    R-2#
    ROOSEVD
  • BubbaJBubbaJ Posts: 323Member
    Both have the same hostname: R-2. that will mess up your CHAP authentication. You should also set the speed on the DCE side.
  • forbeslforbesl Posts: 454Member
    Nice enable password by the way....I think everyone should use "cisco" for their enable password :D
  • rdtechrdtech Posts: 23Member ■□□□□□□□□□
    I have two cisco routers 2500, when I ping each of the routers the ping is successful, when I ping the two computer it hooks up to the routers they can not ping each other. when I ping from the routers I am able to ping both computer. When I ping from the computer it is able to ping both routers. thank you for anyone help.



    This is the config Files.

    R-1#sh run
    Building configuration...

    Current configuration:
    !
    version 11.2
    !
    hostname R-1
    !
    !
    username R-2 password 7 01100F175804
    !
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    !
    interface Serial0
    ip address 192.168.10.10 255.255.255.0
    encapsulation ppp
    no fair-queue
    clockrate 64000
    ppp authentication chap
    !
    interface Serial1
    no ip address
    shutdown
    !
    no ip classless
    ip route 192.168.2.0 255.255.255.0 192.168.10.20


    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    end

    R-1#





    R-2#sh run
    Building configuration.

    Current configuration:
    !
    version 11.0
    service udp-small-servers
    service tcp-small-servers
    !
    hostname R-2
    !
    !
    username R-1 password 7 030752180500
    !
    interface Ethernet0
    ip address 192.168.2.1 255.255.255.0
    !
    interface Serial0
    no ip address
    shutdown
    no fair-queue
    !
    interface Serial1
    ip address 192.168.10.20 255.255.255.0
    encapsulation ppp
    ppp authentication chap
    !
    ip route 192.168.1.0 255.255.255.0 192.168.10.10


    !
    line con 0
    line 1 8
    transport input all
    line aux 0
    transport input all
    line vty 0 4
    login
    !
    end

    R-2#
    ROOSEVD
  • BubbaJBubbaJ Posts: 323Member
    O.K. You posted the router configs, but the other part is the PC configs. What do you get when you run ipconfig /all?
  • rdtechrdtech Posts: 23Member ■□□□□□□□□□
    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    IP Address. . . . . . . . . . . . : 192.168.2.2
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.2.1


    C:\>ping 192.168.1.2

    Pinging 192.168.1.2 with 32 bytes of data:

    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.

    Ping statistics for 192.168.1.2:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),







    Ethernet adapter Local Area Connection

    Connection-specific DNS Suffix .
    IP Address. . . . . . . . . . . . 192.168.1.2
    Subnet Mask . . . . . . . . . . . 255.255.255.0
    Default Gateway . . . . . . . . . 192.168.1.1



    This is the PCs Configuration

    C:\>ping 192.168.2.2

    Pinging 192.168.1.2 with 32 bytes of data:

    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.

    Ping statistics for 192.168.2.2:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
    ROOSEVD
  • EdTheLadEdTheLad Posts: 2,112Member ■■■■□□□□□□
    Disable the firewall on your pc's
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • rdtechrdtech Posts: 23Member ■□□□□□□□□□
    Both PCs firewall are disable already
    ROOSEVD
  • EdTheLadEdTheLad Posts: 2,112Member ■■■■□□□□□□
    From PC1 can you ping 192.168.10.10 if yes can you ping 192.168.10.20,
    why dont you first try the setup with hdlc on the serial links.Break the problem down to localise the problem.

    Your missing your enable passwords on both routers, you have the username and password but you dont have a local password set.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • rdtechrdtech Posts: 23Member ■□□□□□□□□□
    I can not ping serial interface of the routers


    C:\>ping 192.168.10.20

    Pinging 192.168.10.20 with 32 bytes of data:

    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.

    Ping statistics for 192.168.10.20:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

    C:\>ping 192.168.10.10

    Pinging 192.168.10.10 with 32 bytes of data:

    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.

    Ping statistics for 192.168.10.10:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)
    ROOSEVD
  • mikej412mikej412 Posts: 10,090Member
    What do the routing tables on the routers look like?
    sh ip route

    What's the IOS version on these routers? From the config it look like some sort of 11

    And what the heck... how about a
    sh ip int brief
    for each router too.
    :mike: Cisco Certifications -- Collect the Entire Set!
Sign In or Register to comment.