Question for the experts
I have created a lab set up. I have Router1, Router2, and Router3, connected via a Frame Relay cloud. Router1 is my hub. 2 and 3 are the spokes. I can successfully ping from R1 to both of R2 and R3 serial interfaces and vice versa. I can not ping R3 from R2 and can not ping R2 from R3. Below is the config from R2 and R3 - and followed by R1's config. Please point me in the right direction so I can start doing the rest of my labs. Thanks in advance.
These are partial configs cause i dont think the other stuff is relevant - i am not running routing protocols as i just have this set up and want to be able to ping the serial interfaces prior to moving forward. Thanks
R2 config
!
interface Serial0
no ip address
encapsulation frame-relay
no fair-queue
!
interface Serial0.200 point-to-point
ip address 172.12.123.2 255.255.255.0
frame-relay interface-dlci 201
no frame-relay inverse-arp
!
interface FastEthernet0/0
ip address 172.12.23.2 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
shutdown
R3 config -
interface Serial0
no ip address
encapsulation frame-relay
frame-relay map ip 172.12.123.1 301 broadcast
!
interface Serial0.300 point-to-point
ip address 172.12.123.3 255.255.255.0
frame-relay interface-dlci 301
no frame-relay inverse-arp
!
interface FastEthernet0/0
ip address 172.12.23.3 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
shutdown
R1 config -
interface Serial0
ip address 172.12.123.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.12.123.2 102 broadcast
frame-relay map ip 172.12.123.3 103 broadcast
no frame-relay inverse-arp
no fair-queue
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
These are partial configs cause i dont think the other stuff is relevant - i am not running routing protocols as i just have this set up and want to be able to ping the serial interfaces prior to moving forward. Thanks
R2 config
!
interface Serial0
no ip address
encapsulation frame-relay
no fair-queue
!
interface Serial0.200 point-to-point
ip address 172.12.123.2 255.255.255.0
frame-relay interface-dlci 201
no frame-relay inverse-arp
!
interface FastEthernet0/0
ip address 172.12.23.2 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
shutdown
R3 config -
interface Serial0
no ip address
encapsulation frame-relay
frame-relay map ip 172.12.123.1 301 broadcast
!
interface Serial0.300 point-to-point
ip address 172.12.123.3 255.255.255.0
frame-relay interface-dlci 301
no frame-relay inverse-arp
!
interface FastEthernet0/0
ip address 172.12.23.3 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
shutdown
R1 config -
interface Serial0
ip address 172.12.123.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.12.123.2 102 broadcast
frame-relay map ip 172.12.123.3 103 broadcast
no frame-relay inverse-arp
no fair-queue
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
Comments
-
JVE Member Posts: 76 ■■□□□□□□□□I was able to get these to ping by taking off the subinterfaces, thus removing the point-to-point state of the R2 and R3 interfaces, but should i not have been able to ping from R2 to R3 through R1? and same for the other? Let me know before i proceed. Thanks
-
david_r Member Posts: 112JVE,
Why do you have both of these lines in your config?
frame-relay map ip 172.12.123.1 301 broadcast
!
interface Serial0.300 point-to-point
ip address 172.12.123.3 255.255.255.0
frame-relay interface-dlci 301
Also,
I think you need to read through this. http://www.cisco.com/warp/public/125/12.html#topic2 and the next topic.
If you are going to configure point-to-point connections, you need a different network for each and need to route at the hub router.
BTW, Inverse-ARP is your friend. Configure with it enable, do a show frame map and build your maps from that. -
JVE Member Posts: 76 ■■□□□□□□□□Thank you my friend. I need to start looking at the cisco site more often!