IIS 6 Date Format

Hi Guys, a question for the IIS "nuts" sorry "experts"

I have a SQL application with a Browser front end running under IIS6 on a SQL2000/W2003 box. I am in Australia and need a date format d/m/y, but the application shows m/d/y. The progam help desk blames IIS and indicate that they get the date format from the server and that its not coded into the appliation.

I have logged in as Domain Admin, Local Admin, IUSR_servername and set each's regional settings to the correct country code. I have modified the metabase in IIS for the AspLCID. Modified the registry for both HKEY_CURRENT_USER\Control Panel\International and HKEY_USERS\.DEFAULT\Control Panel\International with no success.

Any idea's
Isn't Bill such a Great Guy!!!!

Comments

  • SWMSWM Member Posts: 287
    Don't you hate that. You post a question and finally solve it your self. icon_mad.gif
    Any way for any one else with a similar problem, IIS6 runs w3wp.exe on your server. W3wp.exe by default starts as a "network service" and hence used the regional settings of the network service user account.

    I configured my default application pool identity in IIS from network service to "local system". Restarted IIS and TADA all OK.

    Hope this helps someone else. :D
    Isn't Bill such a Great Guy!!!!
  • SlowhandSlowhand MCSE: Cloud Platform and Infrastructure, MCSA: Windows Server 2003/2012/2016, CCNA Routing & Switchi Bay Area, CaliforniaMod Posts: 5,163 Mod
    That's actually a really handy thing to know. Sorry there were no responses, but thanks for the tip.

    Free Microsoft Training: Microsoft Learn
    Free PowerShell Resources: Top PowerShell Blogs
    Free DevOps/Azure Resources: Visual Studio Dev Essentials

    Let it never be said that I didn't do the very least I could do.
  • sprkymrksprkymrk Member Posts: 4,884 ■■■□□□□□□□
    SWM wrote:
    Any way for any one else with a similar problem, IIS6 runs w3wp.exe on your server. W3wp.exe by default starts as a "network service" and hence used the regional settings of the network service user account.

    I configured my default application pool identity in IIS from network service to "local system". Restarted IIS and TADA all OK.

    Oh yeah, I was gonna say that. icon_lol.gificon_scratch.gif
    Nice tip!
    All things are possible, only believe.
  • _kk_kk Member Posts: 1 ■□□□□□□□□□
    I have done as you said (change default application pool to 'local system') and re-started the IIS. Still no luck. any clue?
  • benchrbenchr Member Posts: 1 ■□□□□□□□□□
    Don't change IIS user account to solve this problem! icon_eek.gif IIS runs as network service on purpose, it is lower privilege than system.

    You are better off keeping it this way, and change the date/time format for network service (or do it for all users on the machine if its easier).

    Thanks,
    Ben Chronister
  • dynamikdynamik Banned Posts: 12,314 ■■■■■■■■□□
    _kk wrote:
    I have done as you said (change default application pool to 'local system') and re-started the IIS. Still no luck. any clue?

    Did you also change the regional settings like he did?
    benchr wrote:
    Don't change IIS user account to solve this problem! icon_eek.gif IIS runs as network service on purpose, it is lower privilege than system.

    You are better off keeping it this way, and change the date/time format for network service (or do it for all users on the machine if its easier).

    Thanks,
    Ben Chronister

    Excellent point!
  • AresDRacoAresDRaco Registered Users Posts: 1 ■□□□□□□□□□
    We had the same problem at work, this works for windows 7 but also in Windows server 2008

    Apply regional and language settings to reserved accounts - Microsoft Windows Help
Sign In or Register to comment.