*TechSims* CCNA [online router sim v0.3]

WebmasterWebmaster Posts: 10,292Admin
It still needs a lot of work, but I present to you: the beta version of our online router simulator:

icon_arrow.gif www.techexams.net/testsim/techsim.php

Just give it a shot and let me know what you think. please keep in mind that this is just a very preliminary version and still needs a lot of work.

If you do not have a recent version of a Java VM it can be installed automatically. This works for most browsers, but you may need to install it manually.

We recommend you install "JAVA SOFTWARE FOR YOUR DESKTOP" before trying to use our TechSims
icon_arrow.gif http://java.com/en/download/download_the_latest.jsp

Current beta:
version 0.3
build 2
Last update: March 7, 2004, 9:10 AM

**********************************
Supported/recognized commands:

enable
disable
hostname
configure terminal
exit
end
logout
ip classless
ip subnet-zero
interface ethernet 0
interface serial 0
interface serial 0
ip address
description
bandwidth
clock rate
enable password
enable secret
router rip
copy running-config startup-config
copy startup-config running-config
shutdown
show version
show running-config
show startup-config
?

Special keys:
<TAB> - auto command completion (currently only in User and Priv Exec mode, other will be added very soon)
<CTRL-Z> - exits configuration mode
<CTRL-B> - move one character left
<CTRL-F> - move one character rigth


restart sim



The following commands are supported but do not relate to the CCNA exams, they are added for the BSCI exam:
router isis
is-type level-1
net
ip router isis
isis circuit-type level-1
isis circuit-type level-2-only

- When a command is entered that is currently not supported, the sim will reply with "% Command not supported".

- At any time, you can use the command "restart sim" to restart the TechSim, with the default minor configuration.

- Not all abbreviated versions of the currently supported commands are recognized, if your favorite one is missing let me know and I'll add it. ;)


**********************************

Johan :D
«1

Comments

  • WebmasterWebmaster Posts: 10,292Admin
    Added ip address command, more show running-config output that can actually be changed, isis command (for BSCI routing exam).

    Currently working on improved password support, including vty and console password, password encryption and better relationship between enable and secret.
  • WebmasterWebmaster Posts: 10,292Admin
    Made some significant changes to the interface, making it look more 'real'.


    Comments anyone? icon_rolleyes.gif
  • Ricka182Ricka182 Posts: 3,359Member
    Well, I made through all 10 steps successfully. unfortunately, I can only say it "looks" good, since I have no idea what it should look like.
    i remain, he who remains to be....
  • celticfccelticfc Posts: 3Member ■□□□□□□□□□
    im using Safari and the sim worked great...

    cheers!
  • RamsesKRamsesK Posts: 86Member ■■□□□□□□□□
    well done, it looks exactly as a router promt looks like, i have a question about this, i did all of the techsim test very well, i took three courses about cisco routing technologies and cisco wna administration but finally after finish it i tought "what can i do with this if it is not applicable in the real world" i mean this scenarios are not seen everydays working in the computers environment, at least not in regular places with a bounche of pcs, i know this interface is known for a network administrator and something else so i am happy to answer that test good but where exactly can i apply this knowledge if i dont see these routers and promts everywhere, i also bought a linsys router and it has a kind of web page set up that doesn't allow me to manipulate a lot of things, specially about wireless, anyway any further help will be great .

    thanks and good job in this forum and actually in this place its great always look for the stuff you guys have for study purposes

    thank you very much :D
    Formule One Racing Addict...
  • SartanSartan Posts: 152Inactive Imported Users
    Unfortunately, I beleive that a grasp of true networking is impossible without hands on experience. That's just my opinion. The routers are there, but if you specialize im cisco particularly, you might find yourself lacking in other important skillsets, such as server administration. (Excuse the runon sentence)

    To Webmaster:
    I tried the sim, and unfortunately it didn't work for me, I couldn't press enter. I'm using the Sun java runtime development libaries on a fresh install of XP. I haven't had an opportunity to try it on linux browsers but I'll do that tomorrow.
    Network Tech student, actively learning Windows 2000, Linux, Cisco, Cabling & Internet Security.
  • WebmasterWebmaster Posts: 10,292Admin
    Ramsesk,

    The prompt in our TechSim is similar to what you get when you connect to a router by using a console cable (http://www.techexams.net/technotes/ccna/lab_hardware.shtml)
    or when you connect to the router by using a telnet session. What you see is the command-line interface to configure the IOS, Cisco's OS. Experience with other brands of routers is often not very useful when it comes to configuring Cisco routers.
    Sartan wrote:
    I'm using the Sun java runtime development libaries on a fresh install of XP
    So do I ;)
    You probably need to click on the right side of the blue arrow before you click enter. I know it is kind of a limitation right now, but I'm sure I'll solve that eventually.
  • WebmasterWebmaster Posts: 10,292Admin
    I just uploaded a new version of our online router sim for the CCNA TechSim. I has some major improvements compared to the previous version:

    - Added a startup configuration (and copy start run, copy run start, show start commands)
    - Added support for auto command completion (TAB key) (doesn't work for some commands in config modes yet.)
    - Added support for CTRL-Z to exit config modes.
    - Added support for CTRL-B (left) and CTRL-F (right)

    - Improved password system (enable, secret. Others will be added soon, including better encryption options)
    - Improved ip address configuration command. Now actually validates the format of an the IP address and subnet mask (subnet mask validation will be improved soon, currently accepts ip address as subnetmask)
    - Improved the 'looks' (larger window, horizontal cursor, black background/white text)
    - Improved the use of the ? command, now works in all modes (not for partial commands yet)
    - Removed the need to 'click right from the blue arrow' to begin.


    Things I'm working on:
    - terminal history support (commands and shortkeys)
    - CDP commands
    - more show commands (interface, hosts etc.)
    - password encryption
    - more TechSims (labs in our sim)
    - lots and lots more....

    After I added all the commands for the CCNA exam, I will add a second router to the sim (see diagram) which can be configured by starting a telnet session from router1. Then I'll also add more routing related commands and eventually, hopefully, access-lists....

    Let me know what you think of it...
  • JOblessELementJOblessELement Posts: 134Member
    ... and I thought the Dutch were only good at soccer :P

    Really nice work. Though I always have two windows (applets) of the RouterSim running simultaneously ... must be an Opera problem. (And to test it I can't log in to the site on another browser since I'm already logged in here)
    I am free of all prejudices. I hate everyone equally.
  • WebmasterWebmaster Posts: 10,292Admin
    Well, you thought wrong ;)

    I have to admit I haven't tested it on all non-IE browsers. Although 98% of our visitors use IE, I will download a couple of other browsers to see if the sim works.
  • aladinzaladinz Posts: 1Member ■□□□□□□□□□
    Very realistic, keep up the good work, it is really great.
  • baselinebaseline Posts: 1Member ■□□□□□□□□□
    it was fun!
    I hope you make harder tests to do :)

    thanks
  • beefreebeefree Posts: 1Member ■□□□□□□□□□
    I pull up the TErouter and when press enter key nothing happens. I am using safari on powerbook g4 - os 10.3 panther with java.

    ~Jefree
  • WebmasterWebmaster Posts: 10,292Admin
    Try clicking the bottom line of the black part (right above Welcome...) and then press Enter. I suspect your browser doesn't allow th focus to be set to a java applet element.
  • scott.march@jrspharma.com[email protected] Posts: 1Member ■□□□□□□□□□
    icon_cool.gif The Sim looks great. I only wish you had one for the ccnp switch exam
  • Gabriel TekuGabriel Teku Posts: 1Member ■□□□□□□□□□
    Hey,
    I would be very grateful if someone helps in this one:
    I have 3 cisco 2500 series routers to configure. Of all the interfaces configured all of them are up BUT only 2 of them have LINE PROTOCOL UP, the rest have line protocol down.
    I have tried checking over and over plus reconfig from scratch and yet no solution.
    How can I troubleshoot this problem... ? What could be the problem?

    Lapiro
  • ricky0481ricky0481 Posts: 14Member ■□□□□□□□□□
    well i doest work for me icon_cry.gif i press the enter botton and nothing happens on none of my computers (windows & Mac os X) i yet have to try on linux

    edit: got it to work on windows
  • mvngocmvngoc Posts: 1Member ■□□□□□□□□□
    I am unable to run this tech sim
    i hav downloaded the jre.

    still it is not working

    it gives the message that No Java 2 SDK, Standard Edition v 1.4.2 support for APPLET

    Kindly help me

    pls mail to [email protected]

    thanx
  • BrizzadBrizzad Posts: 1Member ■□□□□□□□□□
    I too am having toruble getting the Java to work. I have installed it but the website is still trying to install it. It doesnt seem to want to instal correctly. I work in an IS departmentt and this version of JRE has ben a real pain in the ass.

    By the way, This is a great webiste and Im so glad there is a froum fro this subject matter.

    Thanks fellas.
    Brad Householder
  • WebmasterWebmaster Posts: 10,292Admin
    Thanks for your comments guys. I will have a look later today and hope you can try it after that. There are several ways to load a Java applet, and it now seems that I haven't done it in the most optimal way.
  • WebmasterWebmaster Posts: 10,292Admin
    Ok, I've made some changes to the code that loads the applet into the Java plug-in. Please try again and let me know it it works. Be sure to delete your temp internet files before trying. If it still doesn't work, please provide your OS and browser version.
  • skully93skully93 Posts: 321Member
    bowing.gif bowing.gif bowing.gif bowing.gif

    Very impressive! I'm sure that someday, when I get into the Cisco stuff, this will come in very handy!

    Thanks for all your hard work!
    I do not have a psychiatrist and I do not want one, for the simple reason that if he listened to me long enough, he might become disturbed.

    -- James Thurber
  • KMAN24KMAN24 Posts: 44Member ■■□□□□□□□□
    I am also having a Java Issue, Running 1.4.2. Just hangs there with the coffee cup in the corner.

    Any suggestions ?
  • mikeyoungmikeyoung Posts: 101Member
    A couple of Java issues to begin with, but easily corrected with a quick download and install.

    Other than that, it is an excelltent sim for folks starting out and wanting to get the feel of "cisco."

    Thank you for your hard work in developing it. I am sure it will be much used.

    Mike Young
    Lack of will power has caused more failure than lack of intelligence or ability.
  • DistractionDistraction Posts: 5Member ■□□□□□□□□□
    Just a thought here Johan and for those you can't seem to run the router sim. I had to wait about 5 seconds before the Java cup went away and the router screen popped up. You folks might have an issue with the Java Virtual Machine not being loaded on your stations. SUN decided to stop support of this as well so "googling" for this when I needed it in the past has been a real pain. Here is the site to download it:

    http://www.vanweteringen.com/jheroen/vm/modules.php?name=Downloads

    Just a thought :)

    (Just starting on studying CCNA, I'm a Nortel switch guy)
    "Third-Grade Scientists Succesfully Vaporize Water"
  • WebmasterWebmaster Posts: 10,292Admin
    Thanks for the information and the link.
    SUN decided to stop support of this as well
    :o & icon_confused.gif

    I just check and the offer the following "JAVA SOFTWARE FOR YOUR DESKTOP", which I just tried and it works perfectly:
    http://java.com/en/download/download_the_latest.jsp
  • WebmasterWebmaster Posts: 10,292Admin
    I was just reading this thread from the start again, and although it isn't used as much as I hoped initially, I would like to spend some time on the TechSims, adding some features/commands and labs. The main problem is simply that I'm not a developer/programmer and knew next to nothing of Java when I started creating this sim. And creating accurate labs and behavior of the commands, i.o.w. the Cisco stuff itself is hard enough already.

    A while ago someone contacted me by PM offering to help develop this free sim (unfortunaly I haven't heard from him again). Although I'm fairly happy with the way it looks and feels, the code itself is a mess and I'm quite sure it's not coded in an efficient manner (<-understatement ;)). I think someone with a bit more Java knowledge could easily add some extra features (command history for example). Maybe we should make it partly open source (so anyone can create labs). Please let me know by PM or reply to this message when you are interested in helping us out with this project. Although we discussed this 'behind the scenes' a long time ago, I'd love to hear some opinions from others about this as well. In the meanwhile I'll try to find some time to clean up the code.
  • ipconfigipconfig Posts: 1Member ■□□□□□□□□□
    it is great job but ihave 2 questions
    what is the command for change the password?
    is there any default password in routers and swiches ?


    thanks alot
  • c-napc-nap Posts: 15Inactive Imported Users ■□□□□□□□□□
    Hey good job with the routersim, but I have a few suggestions. First would be to add abbreviated commands such as "config t" instead of just having "configure terminal". I'm not sure about the new cisco exams, but I remember the older cisco exam as recognizing the abbreviated commands. I know for a fact that the cisco routers do. Second, bit of advice is to give full reign over the router. Allow the user to use configure the router as if it were the real thing, instead of just giving them commands -- all though that's still a good option. Third, is just a purely interface kind of thing, and that is to allow the java applet to expand to full screen upon maximizing the window. So far so good though! GREAT job, hopefully we won't have to spend all that money on a Boson router sim, or even buying an older Catalyst 2500 in the future.
  • WebmasterWebmaster Posts: 10,292Admin
    Thanks for the comments C-NAP.

    The TechSims do support abbreviated commands, just not all of them (basically the ones I use personally ;) and some other common combinations. Even TAB works in some user and priv exec mode. But as I mentioned in the initial post of the topic:
    - Not all abbreviated versions of the currently supported commands are recognized, if your favorite one is missing let me know and I'll add it.
    c-nap wrote:
    Second, bit of advice is to give full reign over the router. Allow the user to use configure the router as if it were the real thing, instead of just giving them commands -- all though that's still a good option.
    Yeah, that would be nice. Apart from the obvious reason (people can go thru the 'lab' excersice) implementing the steps allows me to 'direct' the user's actions, hence make it easier to program the response. The sim is just not advanced enough to react correctly on other actions (though you can do some things outside the scope of the built-in lab).
«1
This discussion has been closed.