Dynamips and the RIP Routing LAB.

tech_monkeetech_monkee Posts: 3Member ■□□□□□□□□□
Hello everyone. this has to be one of the coolest sites i've found for tech related exams and knowledge.

i wanted to ask a few questions about the RIP Routing lab on here.

my current setup is dynagen/dynamips.
	[[Router HostA]]
	f0/0 = RouterA f0/0

	[[ROUTER RouterA]]
	s1/1 = RouterB s1/1

	[[Router RouterB]]
	f0/0 = HostB f0/0

	[[Router HostB]]

now i've done everything in that lab exactly as it should be aside from not using pc's as hosts.

here's what happens, each router can ping the other one fine.

each host can ping each router (gateway) on the F0/0 port only and can't see the S1/1 interfaces at all.

does the slot mean anything when configuring? aside from the fact that my F0/0 is in slot 0 and the S1/1 are in Slot 1 of the router i can't see the problem.

also; they won't let me play with the routers here at work icon_sad.gif they only let me setup and configure switches :p.

Comments

  • dtlokeedtlokee Posts: 2,381Member
    what router platform are you specifying in the net file? That will determin the slot layouts.

    I'm guessing here, but being a switch guy did you specify the "ip defaut-gateway" command on the routers you're using as hosts? If you did you will need to turn off IP routing on those routers with the "no ip routing" command. If you didn't you need to add a default gateway to your Host A and Host B routers. You can do it with the "ip route 0.0.0.0 0.0.0.0 <next hop ip address>" command or the "ip default-gateway" command if you turn off ip routing
    The only easy day was yesterday!
  • tech_monkeetech_monkee Posts: 3Member ■□□□□□□□□□
    7200 model routers. the default dynagen uses.

    the default gateways on HostA/HostB are set to the ips of the F0/0 port of the router they are connected too.

    i'll try the 'no ip routing' command when i get to work in a while since i'm a bad time trying to setup dynamips on my linux box at home.

    thanks for the help.
  • tech_monkeetech_monkee Posts: 3Member ■□□□□□□□□□
    ....and there it is :)
    no ip routing
    
    did the trick
    Sending 5, 100-byte ICMP Echos to 192.168.33.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/248/1072 ms
    
    Sending 5, 100-byte ICMP Echos to 192.168.22.6, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/45/64 ms
    HostB#ping 192.168.22.5
    
    Sending 5, 100-byte ICMP Echos to 192.168.22.5, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 76/88/96 ms
    
    Sending 5, 100-byte ICMP Echos to 192.168.11.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/69/112 ms
    
    Sending 5, 100-byte ICMP Echos to 192.168.11.42, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 92/100/112 ms
    

    thanks again for the help.
Sign In or Register to comment.