nat configuration question

dnt123dnt123 ■□□□□□□□□□ Posts: 17Member ■□□□□□□□□□
Hi all, I'm having a problem configuring NAT to connect to the internet on my 2621 router that is connected to a cable modem which uses dhcp. My current configuration is listed below, and i was wondering if i'm missing anything or if something is incorrect. Any advice would be greatly appreciated appreciated. Thanks alot!

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
ip audit po max-events 100
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
no fair-queue
!
interface FastEthernet0/1
ip address 192.168.x.x 255.255.255.0
ip nat inside
duplex auto
speed auto
!
ip nat inside source list 102 interface FastEthernet0/0 overload
ip http server
no ip http secure-server
ip classless
!
!
access-list 102 permit ip 192.168.0.0 0.0.0.255 any
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

Comments

  • dtlokeedtlokee Posts: 2,381Member
    I think you ACL needs to be modified, but I can't tell because you've changed your IP address to 192.168.x.x (I don't understand why) but your acl is only going to match on 192.168.0.x due to a wildcard mask of 0.0.0.255
    The only easy day was yesterday!
  • dnt123dnt123 ■□□□□□□□□□ Posts: 17Member ■□□□□□□□□□
    My apologies, my ip address used for that line is 192.168.0.1 for interface fa0/1.
  • dtlokeedtlokee Posts: 2,381Member
    You are mssing a default route, but the NAT stuff looks good
    The only easy day was yesterday!
  • dnt123dnt123 ■□□□□□□□□□ Posts: 17Member ■□□□□□□□□□
    I see, so its not working becuase there is no default route? I also set my pc's tcp/ip settings to have an

    ip address of: 192.168.0.2
    subnet: 255.255.255.0
    default gateway: 192.168.0.1

    should anything else be configured to have my computer connect to the internet? Thanks again
  • dtlokeedtlokee Posts: 2,381Member
    Your router will need a default route to the next hop router (ISP)
    The only easy day was yesterday!
  • dnt123dnt123 ■□□□□□□□□□ Posts: 17Member ■□□□□□□□□□
    Thanks that sounds good to me!, gonna give that a try
  • dtlokeedtlokee Posts: 2,381Member
    you may be able to use the "ip route 0.0.0.0 0.0.0.0 dhcp" command to use the default gateway provided by your ISP as the default route. This was added in 12.3(icon_cool.gifT so depending on the IOS version this may not be available.


    EDIT: Damn smilies turned (icon_cool.gif into a smiley face
    The only easy day was yesterday!
  • NetstudentNetstudent Posts: 1,694Member
    icon_lol.gif I just thought maybe you thought you were cool for knowing that.
    There is no place like 127.0.0.1 BUT 209.62.5.3 is my 127.0.0.1 away from 127.0.0.1!
  • dnt123dnt123 ■□□□□□□□□□ Posts: 17Member ■□□□□□□□□□
    Its working now thanks alot!, I also found out that you should do a power cycle on your cable modem so it recognizes your router and also add dns server addresses on your tcp/ip settings in windows.
  • ChrisPinSgChrisPinSg ■□□□□□□□□□ Posts: 8Member ■□□□□□□□□□
    nat / pat i hate it i still dont get it, so what to put for the source list and acl, am gonna borrow ccna icnd when pple return it to the library. bet i wouldnt really get it there, i did it on packet tracer 5 times but still dont get what the commands mean lol
  • networker050184networker050184 Mod Posts: 11,962Mod Mod
    For the source list you put the number of the access-list you create. You create the access-list to only allow what hosts or network you want to be translated. The concepts are pretty simple once you get the hang of it, but it can get a bit confusing at times. You should definitley get a book to learn about NAT, but you can read this How NAT Works from the Cisco technical documentation to get you started now.
    An expert is a man who has made all the mistakes which can be made.
Sign In or Register to comment.