Troubleshooting OSPF

pitusapitusa Posts: 10Member ■□□□□□□□□□
Hello guys,
I just got into another problem with this CNNA. Simulating on r1r2.com, I configured (actually I found it already configured) the routers like shows below. But they can't ping to the neighbhors ethernet.
Thanks a lot for any pointer.



I got the following configuration (2 routers, e0 and s0 each)

r1
ip subnet-zero
!
interface Ethernet0
ip address 200.200.200.129 255.255.255.192
no ip directed-broadcast
!
interface Serial0
ip address 200.200.200.6 255.255.255.252
no ip directed-broadcast
ip ospf message-digest-key 1 md5 7 asecret
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router ospf 10
area 0 authentication message-digest
network 200.200.200.4 0.0.0.3 area 0
network 200.200.200.128 0.0.0.63 area 0
!
ip classless
!
r1 router

ip subnet-zero
!
interface Ethernet0
ip address 200.200.200.65 255.255.255.192
no ip directed-broadcast
!
interface Serial0
bandwidth 64
ip address 200.200.200.5 255.255.255.252
no ip directed-broadcast
ip ospf authentication-key cisco
clockrate 56000
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router ospf 10
network 200.200.200.4 0.0.0.3 area 0
network 200.200.200.64 0.0.0.63 area 0
!
ip classless

I can't ping to e0 of any of the routers from the neighbhor router.

I issued a 'sh ip ospf events' and I got this:
10:06:04: OSPF: Rcv pkt from 200.200.200.129, Ethernet0, area 0.0.0.0 : src not on the same network

sh ip route shows: (router 1)
mwh01#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR

Gateway of last resort is not set

200.200.200.0/26 is subnetted, 1 subnets
C 200.200.200.64 is directly connected, Ethernet0
C 192.168.1.0/24 is directly connected, Serial0

router 2
sh ip route
mwh02#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR

Gateway of last resort is not set

200.200.200.0/26 is subnetted, 1 subnets
C 200.200.200.128 is directly connected, Ethernet0
C 192.168.1.0/24 is directly connected, Serial0

Comments

  • jgreeniejgreenie Posts: 1Member ■□□□□□□□□□
    10:06:04: OSPF: Rcv pkt from 200.200.200.129, Ethernet0, area 0.0.0.0 : src not on the same network



    this line says it all---they are not on same subnet
  • pitusapitusa Posts: 10Member ■□□□□□□□□□
    Thanks for replying,

    I don't understand....Are areas suppose to be formed of the same subnets ?
    Or I can have more than one subnet inside the same area ?
    Regards,
    Andres
  • statstat Posts: 1Member ■□□□□□□□□□
    Areas don't have to be in the same subnet. I don't understand your configuration though. Look at your show IP route command. It has your serial interface advertising 192.168.1.0 on both routers??
Sign In or Register to comment.