vlan between catalyst 2950 and 6509

livenliven Member Posts: 918
Ok,

Trying very hard to get this working...

I have vlan on a 2950 that I need to connect to a vlan on a 6509.

Lets say the vlan is 555

I got it configured and working on the 2950.

But on the 6509 (which I don't have much experience with), I can not get the VLaN to create.

I have tried:

conf t
vlan 555

The I do

sh vlan id 555

and I see the vlan.

but when I do:

sh run

I don't see vlan 555...

So i keep trying, and I try to assign 555 to an interface:


conf t
int gig2/25
switchport accesss
switchport access vlan 555


then sh run displays that the interface is assigned to the vlan 555, but that is the only place I see vlan 555. All the other vlans show up in the running config. There are about 6 other vlans and they all work and show up in the running config.

Earlier we managed to get this vlan to show up ( I don't know how my co-worker did it), but the line protocol wouldn't come up.

We tried turning the port that was assigned to the vlan into a trunk port, but this didn't help.
We tried plugging the cat6 cable connected to the port into a latop but this didn't bring the line proto up either.

I am really lost here.

Why will the vlan not show up in the running config?
What does it take to get the line protocol to come up?


I know I sound like a noob here, and yes I should probably know this stuff... But like I said I don't have much layer 3 switching under my belt. Plus this is a very complex production network that has a VERY important purpose. I can't afford to break it.

Now I can play with this one interface all I want because it is connected to non production gear (this stuff will go production in a few months).

Finally sorry to ask this in this forum, if it is not appropriate please delete or move the message.
I just thought this might be a place I could get an answer or point in the right direction.


Thanks!
encrypt the encryption, never mind my brain hurts.

Comments

  • CCIE_2011CCIE_2011 Member Posts: 134
    there two file saved along with a switch :
    1.start config
    2.vlan.dat

    vlan.dat is a binary file. it have all vlan created by the switch. you'll not see any created vlan config in the start/run config
    . : | : . : | : .
  • NetwurkNetwurk Member Posts: 1,155 ■■■■■□□□□□
    Use the show vlan commands to see the state of your VLANs. As CCIE_2011 stated, the VLAN config info is stored in the vlan.dat file, so you won't see anything if you do a show run, show start, or wr ter command.
  • Paul BozPaul Boz Member Posts: 2,620 ■■■■■■■■□□
    If the layer 3 vlan interface is showing up in the running config you're fine. Have you tried routing it in the non-production gear yet?
    CCNP | CCIP | CCDP | CCNA, CCDA
    CCNA Security | GSEC |GCFW | GCIH | GCIA
    [email protected]
    http://twitter.com/paul_bosworth
    Blog: http://www.infosiege.net/
  • livenliven Member Posts: 918
    Thanks fellas for the input.

    I was aware of the vlan.dat file.

    But the weird thing is that I have a bunch of other vlans on this switch. They show up when doing

    show vlan

    and

    show run...


    I have not had a chance to build this setup in my work lab. I will do this on monday (hopefully).

    I will post more information as I obtain it.

    Thanks again.
    encrypt the encryption, never mind my brain hurts.
  • CCIE_2011CCIE_2011 Member Posts: 134
    the vlan.dat will always contain vlans created, vlans names, number.... etc.
    in the run config you'll see vlans assign to an interface(physical and logical[SVI]).
    I think every command that start with [Vlan x] and any command in the vlan config mode you'll not see it.

    If you are still confused please paste your config for us to discuss
    . : | : . : | : .
  • darkuserdarkuser Member Posts: 620 ■■■□□□□□□□
    not sure if anyone said this
    but do you have a trunk between the two devices ?

    and what are the vtp modes of the switches ?

    ie are they in the same vtp domain with the same p/w ?
    rm -rf /
  • APAAPA Member Posts: 959
    quick post...

    1) Are you talking about the vlan interfaces showing up in the running config?? As that is correct with L3 switches.... Just configuring vlan 555 does not mean you have created a vlan interface!!! Only means you have created the Logical VLAN within the VLAN database on the switch.

    The only time you should see your logical vlans(vlan database) appearing in the running-config is if the switch is in vtp transparent mode......

    2) Line protocol on a vlan interface will always be down until the corresponding vlan has been created in the VLAN database.

    So you should have L3 vlan interface configured on the 6509 plus the logical vlan 555 created in the VLAN database.... Then you should see the line protocol as up.....

    Can't elaborate much more at the moment as heading out but will check this tomorrow to ensure you understand what I am saying :)

    Hope this helps

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
Sign In or Register to comment.