Assigning permissions to another users mailbox in 2007

ssjaronx4ssjaronx4 Member Posts: 37 ■■□□□□□□□□
Hi Guys,

I've been getting ready for the exam this morning and have just realised that the Advanced options for setting mailbox rights has gone in 2007. Can't believe I didn't notice this before now but I guess all the empthersis on powershell in the learning materials I have has just neglected to mention this.

How do you set rights for one user over another users mailbox now? I'm assuming you have to set all the options in the Security tab in AD as you use to with Send As rights.

Also any tips on what areas tend to come up most on the exam would be great as Ive got the exam booked for Friday. Not feeling to confident ATM so I'm glad the second shot offer is still running :D


  • CorySCoryS Member Posts: 208
    I think as far as the permissions question you are looking for the add-mailboxpermission with the -accessrights switch
    MCSE tests left: 294, 297 |
  • ssjaronx4ssjaronx4 Member Posts: 37 ■■□□□□□□□□
    Thanks for the reply. I actually like that command. Makes apllying full control and send as quite simple. Still, it would have been useful if Microsoft had kept the GUI view of those controls as well.
  • royalroyal Member Posts: 3,352 ■■■■□□□□□□
    SP1 allows you to do it from the GUI.
    “For success, attitude is equally as important as ability.” - Harry F. Banks
  • CorySCoryS Member Posts: 208
    In SP1 doesnt it only allow you to delegate the fullaccess parameter? Thought I found that and was annoyed but it may have been something else :)
    MCSE tests left: 294, 297 |
  • ssjaronx4ssjaronx4 Member Posts: 37 ■■□□□□□□□□
    Cool. Have they added send as to the gui this time?

    Also, anyone know how to add someone as a member of an AD group using powershell? i've tried

    set-group -identity Test1 -addmember / -newmember / -members

    I've also tried setting the user account as a member of using

    set-user -identity adam -memberof / -addgroup / -addgroupmembership / -addtogroup.

    It seems i am unable to find the right syntax for this sort of function.
  • ssjaronx4ssjaronx4 Member Posts: 37 ■■□□□□□□□□
    I have another question regarding an error I'm receiving trying to create a RSG. I've taken a backup using the backup utility of the first 2 SG's. Then I've used ExTRA to create a RSG for the first storage group, restored the first storagegroup database to the RSG and then tried to mount the database in the RSG so I can copy etc stuff from the group and play around with the functionality.

    However the database won't mount and I can't use any of the functions without doing it. I keep getting the following error:

    Error encountered while trying to mount the database :
    Error encountered while trying to mount the database (Mailbox Database) in the recovery storage group (RRecovery Storage Group). Error message is: Exchange is unable to mount the database that you specified. Specified database: DC1\RRecovery Storage Group\Mailbox Database; Error code: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-544) ..

    Anyone know why this is occuring and what I'm doing wrong?
  • CorySCoryS Member Posts: 208
    Not sure if this is how you proceeded but you are supposed to create the RSG, (verify it is there by running the appropriate EMS commands such as get-storagegroup) then mount the RSG database, then you run the restore (if you are using NTBackup make sure you are not backing up and restoring based on the file level but using the Exchange aware component meaning select the actual information store), this will restore to the RSG by default but you must make sure you have it mounted and you have the switch enabled for it to be overwritten which you can setup via EMS or the Management console.

    Sometimes when you miss a step or 2 you can get a bunch of flakey errors, however I have not researched your MAPI error at all so this may be completely unrelated... As for your other questions, send as is a no go in the GUI as far as I understand, and I dont quite understand what you are trying to accomplish with your second question. Good luck however!
    MCSE tests left: 294, 297 |
  • ssjaronx4ssjaronx4 Member Posts: 37 ■■□□□□□□□□
    Nice one Cory. Didnt realise you should mount the RSG before doing the restore. Deleted the restored files, and mounted sucessfully. Restore the backup to the RSG and managed to merge the database without issue. Cheers for the help!

    Did anyone use the Microsoft Press book to study for the exam? Just wondering how the practice tests on the CD compare to the exam itself? Are there any sims etc on the 236 ATM? I'm assuming it doesn't yet cover SP1?
  • CorySCoryS Member Posts: 208
    Back in early December the books that were out there were still a bit fresh and I decided that I was going to just lab it out and go through as many scenarios that I could. I setup a VMWare lab with an Edge box and a HT/CAS/MB server, going through and creating users and applying policies, quotas, and other various tasks both in the GUI and EMS was extremely helpful, when I got curious I used the technet site and as there were alot of resourceful blog posts around that time concerning resource scheduling and other various EMS tasks that seemingly would have been in the RTM GUI (of course not though right? :) )

    After taking it, and actually reading a few reviews on the books though I would say for someone thats just starting to dive into it get your hands on the "How to **** at Configuring Exchange 2007" by Henrik Walter, I actually had my work purchase it for me after I passed the test as it would be a good reference if I ever needed to refer back.

    I would link you to the Royal post where he listed a bunch of books but its only a few posts away if I remember.

    MCSE tests left: 294, 297 |
  • HeroPsychoHeroPsycho Inactive Imported Users Posts: 1,940
    I used the Sybex book. The practice tests on it were absolutely nothing like the real exam. From my previous experiences with the MS Press books, expect the same.

    If you want a real practice exam, go with Transcenders or something like that.
    Good luck to all!
  • al riskyal risky Member Posts: 3 ■□□□□□□□□□
    HI guys

    I got the same problem as ssjaronx4 when trying to mount the RSG after restoring from the TSM client for exchange. Deleted the previous attempt and created another RSG, which I then mounted and set flags to "allow overwrite by retore". This time my restore failed immidiately, with an error

    0xc7ff1005 - Error returned from a callback function call (0xFFFFFC05) and (0xFFFFFDD9)

    This error is referred to in article

    But i'm dubious about deleting transaction logs from the live environment and i'm also not even sure if you can delete the curent transaction log, as surely it would be in use?
Sign In or Register to comment.