trying to remember BGP....
So i got a new job and i'm going back through my old text books to just refresh my memory a bit..
Doing some BGP stuff in dynamips with the following topology
(there are two links between R2 and R3 for redundancy)
EIGRP is running between R2 and R3
R1 Config:
interface Serial1/0
ip address 172.16.1.1 255.255.255.0
interface Loopback9
ip address 192.168.15.1 255.255.255.0
router bgp 65100
no synchronization
bgp log-neighbor-changes
network 192.168.15.0
neighbor 172.16.1.2 remote-as 65101
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.16.1.2
R2 Config
interface Loopback1
ip address 192.168.2.2 255.255.255.255
interface Serial1/0
ip address 172.16.1.2 255.255.255.0
interface Serial1/2
ip address 10.1.1.1 255.255.255.0
interface Serial1/3
bandwidth 256
ip address 10.2.2.1 255.255.255.0
router eigrp 10
network 10.1.1.0 0.0.0.255
network 10.2.2.0 0.0.0.255
network 172.16.0.0
network 192.168.2.2 0.0.0.0
auto-summary
!
router bgp 65101
no synchronization
bgp log-neighbor-changes
neighbor 172.16.1.1 remote-as 65100
neighbor 192.168.3.3 remote-as 65101
neighbor 192.168.3.3 update-source Loopback1
neighbor 192.168.3.3 next-hop-self
no auto-summary
R3 Config
interface Loopback1
ip address 192.168.3.3 255.255.255.255
interface Serial1/2
ip address 10.1.1.2 255.255.255.0
interface Serial1/3
bandwidth 256
ip address 10.2.2.2 255.255.255.0
interface Serial1/4
ip address 192.168.1.1 255.255.255.0
router eigrp 10
network 10.1.1.0 0.0.0.255
network 10.2.2.0 0.0.0.255
network 192.168.1.0
network 192.168.3.3 0.0.0.0
auto-summary
!
router bgp 65101
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.2 remote-as 65102
neighbor 192.168.2.2 remote-as 65101
neighbor 192.168.2.2 next-hop-self
no auto-summary
R4 Config
interface Loopback20
ip address 20.20.20.20 255.255.255.255
interface Serial1/4
ip address 192.168.1.2 255.255.255.0
router bgp 65102
no synchronization
bgp log-neighbor-changes
network 20.20.20.20 mask 255.255.255.255
neighbor 192.168.1.1 remote-as 65101
ip route 0.0.0.0 0.0.0.0 192.168.1.1
So i have full connectivity between all the routers, R1 can ping the 20.20.20.20 loopback on R4.
I'm just not sure if i should be advertising the 172.16.0.0 and 192.168.1.0 into EIGRP on the two routers in AS65101.
If they are not advertised into EIGRP then i don't have connectivity between AS65100 and AS65102.
I'm probably forgetting something as it has been a while since i have looked at BGP but yea just wondering if my setup is correct.
cheers.
Doing some BGP stuff in dynamips with the following topology
AS65100 AS65101 AS65102 R1---------------------R2-------R3--------------------R4 R2-------R3
(there are two links between R2 and R3 for redundancy)
EIGRP is running between R2 and R3
R1 Config:
interface Serial1/0
ip address 172.16.1.1 255.255.255.0
interface Loopback9
ip address 192.168.15.1 255.255.255.0
router bgp 65100
no synchronization
bgp log-neighbor-changes
network 192.168.15.0
neighbor 172.16.1.2 remote-as 65101
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.16.1.2
R2 Config
interface Loopback1
ip address 192.168.2.2 255.255.255.255
interface Serial1/0
ip address 172.16.1.2 255.255.255.0
interface Serial1/2
ip address 10.1.1.1 255.255.255.0
interface Serial1/3
bandwidth 256
ip address 10.2.2.1 255.255.255.0
router eigrp 10
network 10.1.1.0 0.0.0.255
network 10.2.2.0 0.0.0.255
network 172.16.0.0
network 192.168.2.2 0.0.0.0
auto-summary
!
router bgp 65101
no synchronization
bgp log-neighbor-changes
neighbor 172.16.1.1 remote-as 65100
neighbor 192.168.3.3 remote-as 65101
neighbor 192.168.3.3 update-source Loopback1
neighbor 192.168.3.3 next-hop-self
no auto-summary
R3 Config
interface Loopback1
ip address 192.168.3.3 255.255.255.255
interface Serial1/2
ip address 10.1.1.2 255.255.255.0
interface Serial1/3
bandwidth 256
ip address 10.2.2.2 255.255.255.0
interface Serial1/4
ip address 192.168.1.1 255.255.255.0
router eigrp 10
network 10.1.1.0 0.0.0.255
network 10.2.2.0 0.0.0.255
network 192.168.1.0
network 192.168.3.3 0.0.0.0
auto-summary
!
router bgp 65101
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.2 remote-as 65102
neighbor 192.168.2.2 remote-as 65101
neighbor 192.168.2.2 next-hop-self
no auto-summary
R4 Config
interface Loopback20
ip address 20.20.20.20 255.255.255.255
interface Serial1/4
ip address 192.168.1.2 255.255.255.0
router bgp 65102
no synchronization
bgp log-neighbor-changes
network 20.20.20.20 mask 255.255.255.255
neighbor 192.168.1.1 remote-as 65101
ip route 0.0.0.0 0.0.0.0 192.168.1.1
So i have full connectivity between all the routers, R1 can ping the 20.20.20.20 loopback on R4.
I'm just not sure if i should be advertising the 172.16.0.0 and 192.168.1.0 into EIGRP on the two routers in AS65101.
If they are not advertised into EIGRP then i don't have connectivity between AS65100 and AS65102.
I'm probably forgetting something as it has been a while since i have looked at BGP but yea just wondering if my setup is correct.
cheers.
CCIE# 38186
showroute.net
showroute.net
Comments
-
cisco_trooper Member Posts: 1,441 ■■■■□□□□□□rakem wrote:I'm just not sure if i should be advertising the 172.16.0.0 and 192.168.1.0 into EIGRP on the two routers in AS65101.
If they are not advertised into EIGRP then i don't have connectivity between AS65100 and AS65102.
cheers.
You will need to advertise the address that you intend to peer with into your IGP (in your case EIGRP). BGP works over TCP port 179 so it just needs to know how to get to the peer address of the neighbor. I don't see any specific need to advertise your 172.16.1.0/24 or 192.168.1.0/24 networks into your IGP. -
kpjungle Member Posts: 426cisco_trooper wrote:rakem wrote:I'm just not sure if i should be advertising the 172.16.0.0 and 192.168.1.0 into EIGRP on the two routers in AS65101.
If they are not advertised into EIGRP then i don't have connectivity between AS65100 and AS65102.
cheers.
You will need to advertise the address that you intend to peer with into your IGP (in your case EIGRP). BGP works over TCP port 179 so it just needs to know how to get to the peer address of the neighbor. I don't see any specific need to advertise your 172.16.1.0/24 or 192.168.1.0/24 networks into your IGP.
Unless the synchronization rule is in effect. (BGP wont advertise routes learned through iBGP unless its also known through an IGP), i guess?
Example: Router R2 wont advertise the routes learned from R4 (via R3), unless it also knows those routes from an IGP (EIGRP between R2 and R3).
But you are safe to turn off the synchronization rule since all your internal routers run BGP (iBGP).
Update: Just labbed this up. you dont need to advertise the link from R1 to R2 and the link from R3 to R4 into EIGRP for it to work. You should also make sure that the update-source from both internal routers are set to the loopback. This puzzled me at first, but it seems as long as one of them has the right source address, it will establish when the router with the correct source address "asks" the other router.Studying for CCNP (All done) -
lildeezul Member Posts: 404also its a good idea to use loopback addresses for neighborship, becuase they will not go down unless the router itself goes down.... a physical interface has some probabilty of failing.
so your going to have to use the update source command, and the ebpg-multihop command after the neighbor command.NHSCA National All-American Wrestler 135lb -
tech-airman Member Posts: 953rakem,rakem wrote:So i got a new job and i'm going back through my old text books to just refresh my memory a bit..
Doing some BGP stuff in dynamips with the following topologyAS65100 AS65101 AS65102 R1---------------------R2-------R3--------------------R4 R2-------R3
(there are two links between R2 and R3 for redundancy)
Why do you have redundant links between R2 and R3?rakem wrote:EIGRP is running between R2 and R3
Why do you have EIGRP running between R2 and R3?rakem wrote:R1 Config:
interface Serial1/0
ip address 172.16.1.1 255.255.255.0
interface Loopback9
ip address 192.168.15.1 255.255.255.0
router bgp 65100
no synchronization
bgp log-neighbor-changes
network 192.168.15.0
neighbor 172.16.1.2 remote-as 65101
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.16.1.2
R2 Config
interface Loopback1
ip address 192.168.2.2 255.255.255.255
interface Serial1/0
ip address 172.16.1.2 255.255.255.0
interface Serial1/2
ip address 10.1.1.1 255.255.255.0
interface Serial1/3
bandwidth 256
ip address 10.2.2.1 255.255.255.0
router eigrp 10
network 10.1.1.0 0.0.0.255
network 10.2.2.0 0.0.0.255
network 172.16.0.0
network 192.168.2.2 0.0.0.0
auto-summary
!
router bgp 65101
no synchronization
bgp log-neighbor-changes
neighbor 172.16.1.1 remote-as 65100
neighbor 192.168.3.3 remote-as 65101
neighbor 192.168.3.3 update-source Loopback1
neighbor 192.168.3.3 next-hop-self
no auto-summary
R3 Config
interface Loopback1
ip address 192.168.3.3 255.255.255.255
interface Serial1/2
ip address 10.1.1.2 255.255.255.0
interface Serial1/3
bandwidth 256
ip address 10.2.2.2 255.255.255.0
interface Serial1/4
ip address 192.168.1.1 255.255.255.0
router eigrp 10
network 10.1.1.0 0.0.0.255
network 10.2.2.0 0.0.0.255
network 192.168.1.0
network 192.168.3.3 0.0.0.0
auto-summary
!
router bgp 65101
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.2 remote-as 65102
neighbor 192.168.2.2 remote-as 65101
neighbor 192.168.2.2 next-hop-self
no auto-summary
R4 Config
interface Loopback20
ip address 20.20.20.20 255.255.255.255
interface Serial1/4
ip address 192.168.1.2 255.255.255.0
router bgp 65102
no synchronization
bgp log-neighbor-changes
network 20.20.20.20 mask 255.255.255.255
neighbor 192.168.1.1 remote-as 65101
ip route 0.0.0.0 0.0.0.0 192.168.1.1
So i have full connectivity between all the routers, R1 can ping the 20.20.20.20 loopback on R4.
I'm just not sure if i should be advertising the 172.16.0.0 and 192.168.1.0 into EIGRP on the two routers in AS65101.
Why are you not sure if you should be advertising the 172.16.0.0 and 192.168.1.0 into EIGRP?rakem wrote:If they are not advertised into EIGRP then i don't have connectivity between AS65100 and AS65102.
How does BGPv4 make routing decisions?rakem wrote:I'm probably forgetting something as it has been a while since i have looked at BGP but yea just wondering if my setup is correct.
cheers.
When R1 sends a packet to R2 that is destined for R4, is BGP going to route the packet through iBGP to R3? -
cisco_trooper Member Posts: 1,441 ■■■■□□□□□□tech-airman wrote:Why do you have redundant links between R2 and R3?
Why not? Redundancy is a good thing, especially in production environments. I have redundant links/paths in nearly ALL of my labs and you can bet I have redundancy all over my production network. In this case, however, I might suggest that he may intend to look into BGP path selection, perhaps even watch it pick a new path when he downs one of the links.tech-airman wrote:Why do you have EIGRP running between R2 and R3?
R2 and R3 appear to be iBGP peers that are peered on loopback addresses. Without an IGP then he would have to have two static routes on each of R2 and R3 to take advantage of his redundant links. Why go through all that trouble when EIGRP can do it with very little overhead. iBGP over an IGP is a good configuration, especially when peering on loopback addresses, and especially if he starts getting more devices involved within AS65101. You have to have a route to the neighboring address to establish a BGP session. -
Mrock4 Banned Posts: 2,359 ■■■■■■■■□□tech-airman wrote:How does BGPv4 make routing decisions?
Hows a rainbow made? whys the sky blue? how does a posi track rear end on a plymouth work? It just does. -
networker050184 Mod Posts: 11,962 ModMrock4 wrote:tech-airman wrote:How does BGPv4 make routing decisions?
Hows a rainbow made? whys the sky blue? how does a posi track rear end on a plymouth work? It just does.
Love that movie! One of my favorite all time quotesAn expert is a man who has made all the mistakes which can be made.