Hmm - encapsulation problem here

Computer idiotComputer idiot Member Posts: 46 ■■□□□□□□□□
I'm setting up a simple encapsulation scenario with one 2600 router and one 2950 switch. I'm using fastethernet 0/1 for the trunk port on the switch. However, I'm not able to ping the router. All else seems ok.

Any suggestions? I'm putting in my router and switch configs here. I know it has to be a simple problem, but I don't see it.

ROUTER

Router#sh run
Building configuration...

Current configuration : 2209 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.2.0.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20 native
ip address 10.20.0.1 255.255.255.0
!
interface FastEthernet0/0.25
encapsulation dot1Q 25
ip address 10.25.0.1 255.255.255.0
!
router eigrp 100
network 10.0.0.0
no auto-summary
!
!
ip http server
ip http path flash:/gui
!
!
tftp-server flash:/phone/ATA/ATA030100SCCP040211A.zup alias ATA030100SCCP040211A
.zup
tftp-server flash:/phone/7940-7960/P0030702T023.bin alias P0030702T023.bin
tftp-server flash:/phone/7940-7960/P0030702T023.loads alias P0030702T023.loads
tftp-server flash:/phone/7940-7960/P0030702T023.sb2 alias P0030702T023.sb2
tftp-server flash:/phone/7940-7960/P0030702T023.sbn alias P0030702T023.sbn
tftp-server flash:/phone/7970-7971/apps70.1-1-3-30.sbn alias apps70.1-1-3-30.sbn

tftp-server flash:/phone/7970-7971/cnu70.3-1-3-30.sbn alias cnu70.3-1-3-30.sbn
tftp-server flash:/phone/7970-7971/cvm70sccp.8-0-3-32.sbn alias cvm70sccp.8-0-3-
32.sbn
tftp-server flash:/phone/7970-7971/dsp70.1-1-3-30.sbn alias dsp70.1-1-3-30.sbn
tftp-server flash:/phone/7970-7971/jar70sccp.8-0-3-32.sbn alias jar70sccp.8-0-3-
32.sbn
tftp-server flash:/phone/7970-7971/SCCP70.8-0-4SR2S.loads alias SCCP70.8-0-4SR2S
.loads
tftp-server flash:/phone/7970-7971/term70.default.loads alias term70.default.loa
ds
tftp-server flash:/phone/7970-7971/term71.default.loads alias term71.default.loa
ds
!
control-plane
!
!
!
!
!
!
!
!
!
telephony-service
load 7960-7940 P0030702T023
load ATA ATA030100SCCP040211A
load 7971 SCCP70.8-0-4SR2S
load 7970 SCCP70.8-0-4SR2S
max-conferences 4 gain -6
web admin system name Admin password cisco
transfer-system full-consult
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

Router#

SWITCH

Switch#sh run
Building configuration...

Current configuration : 1590 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
ip subnet-zero
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
switchport trunk native vlan 20
switchport mode trunk
no ip address
!
interface FastEthernet0/2
no ip address
!
interface FastEthernet0/3
no ip address
!
interface FastEthernet0/4
no ip address
!
interface FastEthernet0/5
no ip address
!
interface FastEthernet0/6
no ip address
!
interface FastEthernet0/7
no ip address
!
interface FastEthernet0/8
no ip address
!
interface FastEthernet0/9
no ip address
!
interface FastEthernet0/10
no ip address
!
interface FastEthernet0/11
no ip address
!
interface FastEthernet0/12
no ip address
!
interface FastEthernet0/13
no ip address
!
interface FastEthernet0/14
no ip address
!
interface FastEthernet0/15
no ip address
!
interface FastEthernet0/16
no ip address
!
interface FastEthernet0/17
no ip address
!
interface FastEthernet0/18
no ip address
!
interface FastEthernet0/19
no ip address
!
interface FastEthernet0/20
no ip address
!
interface FastEthernet0/21
no ip address
!
interface FastEthernet0/22
no ip address
!
interface FastEthernet0/23
no ip address
!
interface FastEthernet0/24
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan2
description Management VLAN
ip address 10.2.0.4 255.255.255.0
no ip route-cache
!
ip default-gateway 10.2.0.1
ip http server
!
!
line con 0
logging synchronous
line vty 0 4
login
line vty 5 15
login
!
end

Switch#

Comments

  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Do you have vlan 2 configured on the switch?
    i.e. switch(config)#vlan 2
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • networker050184networker050184 Mod Posts: 11,962 Mod
    You are pretty close. Check this out and you should find your issue pretty ease. Might even be something left from a previous config you forgot to take off.
    An expert is a man who has made all the mistakes which can be made.
  • Computer idiotComputer idiot Member Posts: 46 ■■□□□□□□□□
    You are pretty close. Check this out and you should find your issue pretty ease. Might even be something left from a previous config you forgot to take off.

    I went over your link. Maybe I should have seen something, but nothing caught my eye as to what my mistake might be. I know I have my subinterfaces numbered differently, but it was from a practice exercise. Other than that, I still don't see my error.

    I also noticed that the light for the fa 0/1 port on the switch isn't on at all, though the light for the fa 0/2 port is (which is plugged into a different device).
  • networker050184networker050184 Mod Posts: 11,962 Mod
    From the link:
    !-- Select FastEthernet 0/0 for the trunk configuration.
    !-- No L2 or Layer 3 (L3) configuration is done here.

    c2600(config)#int fastEthernet 0/0
    c2600(config-if)#no shut
    c2600(config-if)#exit


    Your configuration has the IP assigned to the main interface.

    If you are having physical layer issues with the link light not coming on you should get that sorted out first though.
    An expert is a man who has made all the mistakes which can be made.
  • Computer idiotComputer idiot Member Posts: 46 ■■□□□□□□□□
    From the link:




    Your configuration has the IP assigned to the main interface.

    If you are having physical layer issues with the link light not coming on you should get that sorted out first though.

    All my configs were correct, actually. After some troubleshooting with the cables, it looks like I had a bad one used for the trunk. A particularly irritating problem to find the solution for, since it's easy to think it's a bad configuration somewhere. A dead cable is usually the last thing to check.
  • networker050184networker050184 Mod Posts: 11,962 Mod
    Guess it does work with an IP on the main interface. Never tried it myself.

    Glad you got it working though!
    An expert is a man who has made all the mistakes which can be made.
Sign In or Register to comment.