OSPF Trivia
Just something i found interesting,its possible a variant of this could turn up on the lab.
Why does R5 not have an entry for 1.1.1.1 ???
If you've already come across this in your studies don't give the answer, it will be fun for someone who isn't aware of it.
Topology
R1----R2
R4
R5
R1 doesn't run an IGP.
R2 is in area 1
R4 is an ABR between Area 0 and Area 1
R5 is in Area 0
R2 is an ASBR due to redistributing a static route to 1.1.1.1
R4 can see the external route 1.1.1.1 but R5 cant.
R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.248
duplex auto
speed auto
R2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback10
ip address 10.0.0.129 255.255.255.252
ip ospf network point-to-point
!
interface Loopback11
ip address 10.0.0.133 255.255.255.252
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.9 255.255.255.248
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
redistribute static metric 100 subnets
network 10.0.0.0 0.0.0.255 area 1
!
ip route 1.1.1.1 255.255.255.255 10.0.0.1
R4
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.10 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.17 255.255.255.248
duplex auto
speed auto
!
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
area 0 filter-list prefix test in
network 10.0.0.10 0.0.0.0 area 1
network 10.0.0.17 0.0.0.0 area 0
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list test seq 5 deny 10.0.0.0/29
ip prefix-list test seq 6 deny 10.0.0.128/30
ip prefix-list test seq 7 deny 10.0.0.132/30
ip prefix-list test seq 10 permit 0.0.0.0/0 le 32
!
R5
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.18 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 5.5.5.5
log-adjacency-changes
network 10.0.0.18 0.0.0.0 area 0
R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O E2 1.1.1.1 [110/100] via 10.0.0.9, 00:03:13, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C 10.0.0.8/29 is directly connected, FastEthernet0/0
O 10.0.0.0/29 [110/20] via 10.0.0.9, 00:03:13, FastEthernet0/0
C 10.0.0.16/29 is directly connected, FastEthernet0/1
O 10.0.0.128/30 [110/11] via 10.0.0.9, 00:03:13, FastEthernet0/0
O 10.0.0.132/30 [110/11] via 10.0.0.9, 00:03:13, FastEthernet0/0
R4#
R5#sh ip rou
R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
5.0.0.0/32 is subnetted, 1 subnets
C 5.5.5.5 is directly connected, Loopback0
10.0.0.0/29 is subnetted, 2 subnets
O IA 10.0.0.8 [110/20] via 10.0.0.17, 00:17:41, FastEthernet0/0
C 10.0.0.16 is directly connected, FastEthernet0/0
R5#
Why does R5 not have an entry for 1.1.1.1 ???
If you've already come across this in your studies don't give the answer, it will be fun for someone who isn't aware of it.
Topology
R1----R2
R4
R5
R1 doesn't run an IGP.
R2 is in area 1
R4 is an ABR between Area 0 and Area 1
R5 is in Area 0
R2 is an ASBR due to redistributing a static route to 1.1.1.1
R4 can see the external route 1.1.1.1 but R5 cant.
R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.248
duplex auto
speed auto
R2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Loopback10
ip address 10.0.0.129 255.255.255.252
ip ospf network point-to-point
!
interface Loopback11
ip address 10.0.0.133 255.255.255.252
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.9 255.255.255.248
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
redistribute static metric 100 subnets
network 10.0.0.0 0.0.0.255 area 1
!
ip route 1.1.1.1 255.255.255.255 10.0.0.1
R4
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.10 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.17 255.255.255.248
duplex auto
speed auto
!
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
area 0 filter-list prefix test in
network 10.0.0.10 0.0.0.0 area 1
network 10.0.0.17 0.0.0.0 area 0
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list test seq 5 deny 10.0.0.0/29
ip prefix-list test seq 6 deny 10.0.0.128/30
ip prefix-list test seq 7 deny 10.0.0.132/30
ip prefix-list test seq 10 permit 0.0.0.0/0 le 32
!
R5
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.18 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 5.5.5.5
log-adjacency-changes
network 10.0.0.18 0.0.0.0 area 0
R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O E2 1.1.1.1 [110/100] via 10.0.0.9, 00:03:13, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C 10.0.0.8/29 is directly connected, FastEthernet0/0
O 10.0.0.0/29 [110/20] via 10.0.0.9, 00:03:13, FastEthernet0/0
C 10.0.0.16/29 is directly connected, FastEthernet0/1
O 10.0.0.128/30 [110/11] via 10.0.0.9, 00:03:13, FastEthernet0/0
O 10.0.0.132/30 [110/11] via 10.0.0.9, 00:03:13, FastEthernet0/0
R4#
R5#sh ip rou
R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
5.0.0.0/32 is subnetted, 1 subnets
C 5.5.5.5 is directly connected, Loopback0
10.0.0.0/29 is subnetted, 2 subnets
O IA 10.0.0.8 [110/20] via 10.0.0.17, 00:17:41, FastEthernet0/0
C 10.0.0.16 is directly connected, FastEthernet0/0
R5#
Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
Comments
-
EdTheLad Member Posts: 2,111 ■■■■□□□□□□Ok, since there doesn't seem to be much interest in trivia i'll provide the answer.
R2 will advertise the route with a forwarding address 10.0.0.1, R4 is filtering network 10.0.0.0/29 going to area 0,therefore R5 will not have a route to the forwarding address. R5 will not enter route 1.1.1.1 into its rib as the forwarding address is unreachable.
An even more obscure scenario of this is using a nssa, in this case the forwarding address could be chosen from a random interface.Networking, sometimes i love it, mostly i hate it.Its all about the $$$$ -
tmlerdal Member Posts: 80 ■■□□□□□□□□I was close, but not quite there. THought it had to do with the filtering on R4, but wasn't quite getting it.