can't get address from DHCP...

snickeredsnickered Member Posts: 25 ■□□□□□□□□□
I have a UC520 and have plugged a 7960 into fa0/1/0 but it won't get an address from DHCP. Here's what I have:

UC520#sh run int fa0/1/0
Building configuration...

Current configuration : 110 bytes
interface FastEthernet0/1/0
switchport access vlan 2
switchport voice vlan 3
spanning-tree portfast

UC520#sh run | se dhcp
ip dhcp excluded-address
ip dhcp pool VOICE
option 150 ip

UC520#sh run int fa0/0.3
Building configuration...

Current configuration : 105 bytes
interface FastEthernet0/0.3
encapsulation dot1Q 3 native
ip address

I know the DHCP server is working because I have a 2960 connected to the WAN port of the UC520 and any phone plugged into the 2960 gets an IP address fine. Any ideas?


  • Fish!Fish! Member Posts: 42 ■■□□□□□□□□
    This ought to take care of it:

    no interface FastEthernet0/0.3

    interface vlan3
    ip address
    no shut

    interface FastEthernet0/1/0
    switchport mode access

    IP address needs to be on interface vlan3 not on a subinterface on interface FastEthernet0/0. Also I think you need 'switchport mode access' on the switch port - otherwise it defaults to switchport mode dynamic desirable - a trunk - and the access+voice commands don't take effect until the mode is access.

    EDIT: Oh, wait, I just noticed you have a switch hanging off of int f0/0.

    OK, move the 2960 switch to one of the switch ports on the UC520 and create a trunk.


    Leave the 2960 on f0/0 and do IRB.

    bridging irb
    bridge 1 route ip

    int fa0/0.3
    bridge-group 1
    no ip address

    int vlan3
    bridge-group 1
    no ip address

    int bvi1
    ip address

    Much more yucky, but it works.
  • snickeredsnickered Member Posts: 25 ■□□□□□□□□□
    I don't care what they say about you. You're a good man! I moved the trunk over to fa0/1/8(the "expansion" port) and removed fa0/0.3... worked like a charm. Thanks a lot. I don't even know what IRB is so I won't even attempt that method.
  • APAAPA Member Posts: 959
    your original config would have worked.....

    should have encapsulation dot1q 3 without the native command on the fa port....

    You obviously had that port hooked up to the 2960 as a trunk right??? So the native vlans would have been matching meaning all the 3 traffic would be untagged...... remember the native vlan traffic is always untagged with dot1q unless you tell it to be tagged...

    Hence plugging a phone into the 2960 was working....

    CCNA | CCNA:Security | CCNP | CCIP
Sign In or Register to comment.