DSL Router Config

wbosherwbosher Member Posts: 422
I want to practice configuring NAT on a 2600 series router through my home dsl connection. I have an external dsl modem connected to my router via a ethernet connection and in to the phone jack.

Can someone point me to where I might find some configs to set this up? I Googled for this but got so many different ideas I don't know which ones to trust or try...I trust people on this site. :D

Cheers.

Comments

  • davidspirovalentinedavidspirovalentine Member Posts: 353 ■■■■□□□□□□
    Im guessing you will have to setup your e0 port to obtain a dhcp ip address and then label your inside and outside statements on the respective interfaces:

    int e0
    ip nat outside

    int fa0/0
    ip nat inside

    and then you will have to da an access list to match your inside hosts and permit them nat access

    access-list 1 permit 192.168.0.1 0.0.0.255

    and then finally you have to use the access list and inside statements to allow the source ip to be natted.

    ip nat inside source list 1 interface e0 overload

    I hope this helps, please note, i am no expert at nat...

    Regards,
    David
    Failure is a stepping stone to success...
  • wbosherwbosher Member Posts: 422
    Thanks for that.

    I'm not so much after the NAT config as there seems to be plenty of information on that floating around, I'm wondering if there is anything I need to do on the outside (internet) interface to interact with the Modem and ISP.

    If its just a matter of setting it up to get an IP address using DHCP from the ISP then I can manage that, if there is any other requirements then I'm not sure.

    Cheers.
  • mella060mella060 Member Posts: 198 ■■■□□□□□□□
    Remember that for most cisco routers being used for DSL connections you need to create a dialer interface. Well i had to anyway and that was for a 800 series router. The dialer interface is where you configure things like PAP or CHAP and your ISP username and password.

    The config for the dialer interface looks something like this:

    interface Dialer1
    ip address negotiated
    ip nat outside
    ip mtu 1492
    encapsulation ppp
    no ip mroute-cache
    dialer pool 1
    dialer-group 1
    ppp authentication pap
    ppp pap sent-username xxxxx password xxxxx
  • wbosherwbosher Member Posts: 422
    How do you know if your ISP is using PAP or CHAP? Will I need to call them for this information or can the router detect this?
  • mella060mella060 Member Posts: 198 ■■■□□□□□□□
    Most ISP's these days would most likely use CHAP since PAP sends passwords across the link in clear text. Send them an email or something or give them a call.
Sign In or Register to comment.