OSPF adj

mattsthe2mattsthe2 Member Posts: 304
I cant seem to OPSF adj on my ASA. My neighbor is Cat6509.
I have the Cat6509 with an adj with another router ok.

My neigbor statements are correct.
I see the 6509 sending an OPSF hello packet out onto the VLAN.


If i debug OSPF on ASA i get "OSPF: Input packet ingored"

Help?


I dont know if this matters but im running VRF's on the Cat6509.

Comments

  • mikej412mikej412 Member Posts: 10,090
    Do the timers and subnet masks on the link match?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • mattsthe2mattsthe2 Member Posts: 304
    CAT 6509


    interface Vlan50
    ip vrf forwarding inside
    ip address 172.17.50.7 255.255.255.0
    end

    Cat6509-3750#sh run int vlan 160
    Building configuration...

    Current configuration : 85 bytes
    !
    interface Vlan160
    ip vrf forwarding DMZ
    ip address 172.31.1.7 255.255.255.0
    end

    Cat6509-3750#sh run | be router ospf
    router ospf 1 vrf inside
    router-id 172.17.50.7
    log-adjacency-changes
    network 172.17.50.0 0.0.0.255 area 0
    !
    router ospf 2 vrf DMZ
    router-id 172.31.1.7
    log-adjacency-changes
    network 172.31.1.0 0.0.0.255 area 0
    !
    router ospf 3 vrf outside
    router-id 172.31.99.2
    log-adjacency-changes
    network 172.31.99.0 0.0.0.255 area 0


    Cat6509-3750#sh ip ospf 1
    Routing Process "ospf 1" with ID 172.17.50.7
    Domain ID type 0x0005, value 0.0.0.1
    Start time: 00:00:40.768, Time elapsed: 01:43:37.318
    Supports only single TOS(TOS0) routes
    Supports opaque LSA
    Supports Link-local Signaling (LLS)
    Supports area transit capability
    Connected to MPLS VPN Superbackbone, VRF inside
    It is an area border router
    Router is not originating router-LSAs with maximum metric
    Initial SPF schedule delay 5000 msecs
    Minimum hold time between two consecutive SPFs 10000 msecs
    Maximum wait time between two consecutive SPFs 10000 msecs
    Incremental-SPF disabled
    Minimum LSA interval 5 secs
    Minimum LSA arrival 1000 msecs
    LSA group pacing timer 240 secs
    Interface flood pacing timer 33 msecs
    Retransmission pacing timer 66 msecs
    Number of external LSA 0. Checksum Sum 0x000000
    Number of opaque AS LSA 0. Checksum Sum 0x000000
    Number of DCbitless external and opaque AS LSA 0
    Number of DoNotAge external and opaque AS LSA 0
    Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    Number of areas transit capable is 0
    External flood list length 0
    IETF NSF helper support enabled
    Cisco NSF helper support enabled
    Reference bandwidth unit is 100 mbps
    Area BACKBONE(0) (Inactive)
    Number of interfaces in this area is 1
    Area has no authentication
    SPF algorithm last executed 00:03:06.681 ago
    SPF algorithm executed 1 times
    Area ranges are
    Number of LSA 1. Checksum Sum 0x00DE74
    Number of opaque link LSA 0. Checksum Sum 0x000000
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0

    ASA

    ASA-5520# sh run int gi0/1
    !
    interface GigabitEthernet0/1
    description *** LAN ***
    nameif inside
    security-level 100
    ip address 172.17.50.4 255.255.255.0 standby 172.17.50.5
    ospf cost 10
    ASA-5520# sh run int gi0/3
    !
    interface GigabitEthernet0/3
    description *** DMZ ***
    nameif DMZ
    security-level 50
    ip address 172.31.1.250 255.255.255.0 standby 172.31.1.251
    ospf cost 10
    ASA-5520#
    ASA-5520#
    ASA-5520# sh run router ospf
    !
    router ospf 1
    router-id 172.17.50.5
    network 172.17.50.0 255.255.255.0 area 0
    network 172.31.1.0 255.255.255.0 area 0
    log-adj-changes
    redistribute static
    !
    ASA-5520# sh ip osp
    ASA-5520# sh os
    ASA-5520# sh ospf

    Routing Process "ospf 1" with ID 172.17.50.5 and Domain ID 0.0.0.1
    Supports only single TOS(TOS0) routes
    Does not support opaque LSA
    It is an autonomous system boundary router
    Redistributing External Routes from,
    static
    SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
    Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
    Number of external LSA 0. Checksum Sum 0x 0
    Number of opaque AS LSA 0. Checksum Sum 0x 0
    Number of DCbitless external and opaque AS LSA 0
    Number of DoNotAge external and opaque AS LSA 0
    Number of areas in this router is 1. 1 normal 0 stub 0 nssa
    External flood list length 0
    Area BACKBONE(0) (Inactive)
    Number of interfaces in this area is 2
    Area has no authentication
    SPF algorithm executed 0 times
    Area ranges are
    Number of LSA 1. Checksum Sum 0x 99bf
    Number of opaque link LSA 0. Checksum Sum 0x 0
    Number of DCbitless LSA 0
    Number of indication LSA 0
    Number of DoNotAge LSA 0
    Flood list length 0
  • mattsthe2mattsthe2 Member Posts: 304
    Issues resolved...

    I had failover setup but the other node was not apart of the cluster or active.

    ospf is thinking that its in a standby state, and is basically blocking the ospf.

    After i did "no failover" on the ASA the adj formed.

    Mike - you would have never had known this with the info i provided but thank you for replying.
Sign In or Register to comment.