OSPF case study... nbma between R3-R4..causing adjacency issues

hoogen82hoogen82 Member Posts: 272
For a good measure I checked the link ip address between 10.0.2.5 and 10.0.2.6... This is a requirement as stated in OSPF case study in JNCIP book. To make the link between R3-R4 to have a DR election... So i made it an nbma interface... which is causing the problem...

I verified the hello packets by the interface detail command... it does show up as 30 and 120 (h/D)... so no issues there...

Did google... but nothing on what I might be doing wrong....
[email protected]#
*** ospf ***
Sep 9 17:29:42.537312 OSPF sent Hello -> 10.0.2.6 (t1-1/0/0.100, IFL 0x47)
Sep 9 17:29:42.538006 OSPF sent Hello 10.0.2.5 -> 10.0.2.6 (t1-1/0/0.100, IFL 0x47)
Sep 9 17:29:45.656935 OSPF rcvd Hello 10.0.2.6 -> 10.0.2.5 (t1-1/0/0.100, IFL 0x47)
Sep 9 17:29:45.657005 OSPF packet ignored: netmask 255.255.255.252 mismatch from 10.0.2.6
Sep 9 17:29:46.556973 OSPF rcvd Hello 10.0.2.6 -> 10.0.2.5 (t1-1/0/0.100, IFL 0x47)
Sep 9 17:29:46.557059 OSPF packet ignored: netmask 255.255.255.252 mismatch from 10.0.2.6
Sep 9 17:29:49.336728 OSPF 10.0.2.6 DBD cleanup complete
Sep 9 17:29:49.336765 OSPF sent Hello -> 10.0.2.6 (t1-1/0/0.100, IFL 0x47)
run monitor stop

[edit]
[email protected]#
IS-IS Sleeps.
BGP peers are quiet.
Something must be wrong.

Comments

  • hoogen82hoogen82 Member Posts: 272
    A more detailed info...

    Hi All,


    For a good measure I checked the link ip address between 10.0.2.5 and 10.0.2.6 there is no netmask issues.... This is a requirement as stated in OSPF case study in JNCIP book. To make the link between R3-R4 to have a DR election... So i made it an nbma interface... which is now causing the adjacency to break.....

    I verified the hello packets by the interface detail command... it does show up as 30 and 120 (h/D)... so no issues there...

    Any help is greatly appreciated...


    Interface configuration

    R3
    t1-1/0/0 {
    hold-time up 30 down 30;
    encapsulation frame-relay;
    lmi {
    n392dte 2;
    n393dte 3;
    t391dte 15;
    lmi-type itu;
    }
    unit 100 {
    bandwidth 155m;
    dlci 100;
    family inet {
    address 10.0.2.5/30;
    }
    }
    }
    #######
    area 0.0.0.0 {
    interface t1-1/0/0.100 {
    interface-type nbma;
    neighbor 10.0.2.6 eligible;
    }


    R4

    t1-1/0/0 {
    dce;
    hold-time up 30 down 30;
    encapsulation frame-relay;
    lmi {
    n392dce 2;
    n393dce 3;
    t392dce 25;
    lmi-type itu;
    }
    unit 100 {
    bandwidth 155m;
    dlci 100;
    family inet {
    address 10.0.2.6/30;
    }
    }
    }

    ########

    area 0.0.0.0 {
    interface t1-1/0/0.100 {
    interface-type nbma;
    neighbor 10.0.2.5 eligible;
    }

    Sep 9 17:07:54.604230 OSPF rcvd Hello 10.0.2.5 -> 10.0.2.6 (t1-1/0/0.100, IFL 0x44)
    Sep 9 17:07:54.604237 Version 2, length 44, ID 10.0.3.3, area 0.0.0.0
    Sep 9 17:07:54.604242 checksum 0x0, authtype 0
    Sep 9 17:07:54.604248 mask 255.255.255.252, hello_ivl 30, opts 0x2, prio 128
    Sep 9 17:07:54.604253 dead_ivl 120, DR 0.0.0.0, BDR 0.0.0.0
    Sep 9 17:07:54.604259 OSPF packet ignored: netmask 255.255.255.252 mismatch from 10.0.2.5

    Did google... but nothing on what I might be doing wrong....
    [email protected]#
    *** ospf ***
    Sep 9 17:29:42.537312 OSPF sent Hello -> 10.0.2.6 (t1-1/0/0.100, IFL 0x47)
    Sep 9 17:29:42.538006 OSPF sent Hello 10.0.2.5 -> 10.0.2.6 (t1-1/0/0.100, IFL 0x47)
    Sep 9 17:29:45.656935 OSPF rcvd Hello 10.0.2.6 -> 10.0.2.5 (t1-1/0/0.100, IFL 0x47)
    Sep 9 17:29:45.657005 OSPF packet ignored: netmask 255.255.255.252 mismatch from 10.0.2.6
    Sep 9 17:29:46.556973 OSPF rcvd Hello 10.0.2.6 -> 10.0.2.5 (t1-1/0/0.100, IFL 0x47)
    Sep 9 17:29:46.557059 OSPF packet ignored: netmask 255.255.255.252 mismatch from 10.0.2.6
    Sep 9 17:29:49.336728 OSPF 10.0.2.6 DBD cleanup complete
    Sep 9 17:29:49.336765 OSPF sent Hello -> 10.0.2.6 (t1-1/0/0.100, IFL 0x47)
    run monitor stop

    [edit]
    [email protected]#
    IS-IS Sleeps.
    BGP peers are quiet.
    Something must be wrong.
  • hoogen82hoogen82 Member Posts: 272
    Got that working.... I was inclined to do a multipoint but wasn't sure since it wasn't mentioned... Found a post by Harry which explains the issue.... WOOT... That drained some of my brain cells....

    This is the reply from Harry:::


    I would try adding the multipoint keyword under the interface unit, and
    also add mapping for each remote dlci. The latter is needed due to lack
    of inarp response (if that is still the case).

    unit 0 {
    <<<<<multipoint;
    dlci 100;
    family inet {
    address 10.0.2.5/30{
    <<<<<< multipoint-destination 10.0.2.6 dlci 100;
    }
    }
    }

    At both ends.

    HTHs
    IS-IS Sleeps.
    BGP peers are quiet.
    Something must be wrong.
Sign In or Register to comment.