Route Reflector on physical interfaces

adeel32adeel32 Member Posts: 27 ■□□□□□□□□□
Dear All,

Can anyone point out the mistake as i cannot able to configure RR on physical interfaces. reference diagram on JNCIP book page 387 and problem that i am facing on page 390? i am shraing my routers configuration. R4 and R2

[email protected]# show
## Last changed: 2009-09-28 20:11:41 UTC
version 8.5R1.14;
system {
root-authentication {
encrypted-password "$1$7epVys9V$XhoSvP2NGWW9mTDYq1ORs."; ## SECRET-DATA
}
}
interfaces {
em2 {
unit 0 {
family inet {
address 10.0.2.10/30;
}
family iso;
}
}
em3 {
unit 0 {
family inet {
address 10.0.2.6/30;
}
family iso;
}
}
em4 {
unit 0 {
family inet {
address 10.0.4.9/30;
}
family iso;
}
}
lo0 {
unit 0 {
family inet {
address 10.0.3.4/32;
}
family iso {
address 49.0002.0100.0000.3004.00;
}
}
}
}
routing-options {
static {
route 192.168.40.0/24 reject;
}
autonomous-system 65412;
}
protocols {
bgp {
group cluster-3.3.3.3 {
type internal;
local-address 10.0.3.4;
export ibgp;
cluster 3.3.3.3;
neighbor 10.0.4.13;
neighbor 10.0.4.10;
}
group core {
type internal;
local-address 10.0.3.4;
export ibgp;
neighbor 10.0.3.3;
neighbor 10.0.3.5;
}
}
isis {
interface em2.0 {
level 1 disable;
}
interface em3.0 {
level 2 disable;
}
interface em4.0 {
level 2 disable;
}
interface lo0.0 {
level 1 disable;
}
}
}
policy-options {
policy-statement ibgp {
term 1 {
from {
protocol static;
route-filter 192.168.40.0/24 exact;
}
then accept;
}
}
}



[email protected]# show
## Last changed: 2009-09-28 21:02:25 UTC
version 8.5R1.14;
system {
root-authentication {
encrypted-password "$1$.z0roC0j$lOqK1Yv6wFkBFeAe33cS0."; ## SECRET-DATA
}
}
interfaces {
em0 {
unit 0 {
family inet {
address 10.0.4.6/30;
}
family iso;
}
}
em1 {
unit 0 {
family inet {
address 10.0.4.2/30;
}
family iso;
}
}
em4 {
unit 0 {
family inet {
address 10.0.4.10/30;
}
family iso;
}
}
lo0 {
unit 0 {
family inet {
address 10.0.6.2/32;
}
family iso {
address 49.0002.0100.0000.6002.00;
}
}
}
}
routing-options {
static {
route 192.168.20.0/24 reject;
}
autonomous-system 65412;
}
protocols {
bgp {
group internal {
type internal;
local-address 10.0.6.2;
export ibgp;
neighbor 10.0.4.1;
neighbor 10.0.4.9;
}
}
isis {
interface em0.0 {
level 2 disable;
}
interface em1.0 {
level 2 disable;
}
interface em4.0 {
level 2 disable;
}
interface lo0.0 {
level 2 disable;
}
}
}
policy-options {
policy-statement ibgp {
term 1 {
from {
protocol static;
route-filter 192.168.20.0/24 exact;
}
then accept;
}
}
}

Comments

  • AldurAldur Juniper Moderator Member Posts: 1,460
    I believe that the problem lies with how you are sourcing your BGP sessions.

    Notice how your neighbor statements are for the interface address where as you local-address is your lo0 interface.
    adeel32 wrote: »
    protocols {
    bgp {
    group cluster-3.3.3.3 {
    type internal;
    local-address 10.0.3.4;
    export ibgp;
    cluster 3.3.3.3;
    neighbor 10.0.4.13;
    neighbor 10.0.4.10;
    }

    Same thing here
    adeel32 wrote: »
    protocols {
    bgp {
    group internal {
    type internal;
    local-address 10.0.6.2;
    export ibgp;
    neighbor 10.0.4.1;
    neighbor 10.0.4.9;
    }
    }

    If you are going to source the sessions from your loopback address then your peers better be peering with your loopback address. If you want your peers to peer with you physical interface address then you need to source your session from your physical interface address.

    Word of advice here, you'll never ever ever ever deploy a network that will have BGP sessions peering with the physical interface address of a router. The book points this out to show you that it can be done but it also later says that this is bad form and lacks the redundancy aspects of loopback peerings.

    Soo, get this working untill you understand the concept but don't focus to much on it. Focus more on the loopback peering and you'll be fine.
    "Bribe is such an ugly word. I prefer extortion. The X makes it sound cool."

    -Bender
  • adeel32adeel32 Member Posts: 27 ■□□□□□□□□□
    Thanks for your quick and word of advice. I am agreed that i should peer the session using loopback addresses but just to make my concept i am trying to make peer by using interface addresses.
  • AldurAldur Juniper Moderator Member Posts: 1,460
    oh yea, interface peering definitely a conceptual thing that you'll want to understand.

    Let me know if changing the local address to the interface address helps :)
    "Bribe is such an ugly word. I prefer extortion. The X makes it sound cool."

    -Bender
  • hoogen82hoogen82 Member Posts: 272
    Or else if you need to peer with interfaces.. just remove the local-address...
    IS-IS Sleeps.
    BGP peers are quiet.
    Something must be wrong.
  • AldurAldur Juniper Moderator Member Posts: 1,460
    hoogen82 wrote: »
    Or else if you need to peer with interfaces.. just remove the local-address...

    heh, yip. That's actually probably the better solution since you won't have to apply a different local address for each neighbor.
    "Bribe is such an ugly word. I prefer extortion. The X makes it sound cool."

    -Bender
Sign In or Register to comment.