VRRP Configuration in Olive

adeel32adeel32 Member Posts: 27 ■□□□□□□□□□
Hi All,

I am facing problem in configuration of VRRP in Olive. After configuring VRRP in olive and check by using run show vrrp summary, i got the message as VRRP is not running. Can anyone solve this problem?

Regards
Adeel Ahmed

Comments

  • hoogen82hoogen82 Member Posts: 272
    What I have heard is, VRRP doesn't always work on a olive.. Some people have got it to work but still faced issues with being able to ping the Virtual IP. What I know is Qemu is something that you get the VRRP working with the multicast fix, VMware doesn't work.

    This might help
    Re: [Qemu-devel] multicast and the eepro100 driver

    But the bottom line is interface driver for fxp interfaces doesn't accept mcast
    packets by default on Qemu.
    IS-IS Sleeps.
    BGP peers are quiet.
    Something must be wrong.
  • hoogen82hoogen82 Member Posts: 272
    Post your configurations... Maybe something wrong there?
    IS-IS Sleeps.
    BGP peers are quiet.
    Something must be wrong.
  • adeel32adeel32 Member Posts: 27 ■□□□□□□□□□
    Please find the configuration of VRRP according to book's chapter 2 with the error.

    [email protected]# show interfaces em3
    vlan-tagging;
    unit 520 {
    vlan-id 520;
    family inet {
    address 10.0.5.1/24 {
    vrrp-group 1 {
    virtual-address 10.0.5.253;
    accept-data;
    }
    }
    }
    }
    unit 530 {
    vlan-id 530;
    family inet {
    address 10.0.6.1/24 {
    vrrp-group 2 {
    virtual-address 10.0.6.253;
    accept-data;
    }
    }
    }
    }

    [edit]

    [email protected]# run show vrrp summary
    VRRP is not running



    em3 {
    vlan-tagging;
    unit 520 {
    vlan-id 520;
    family inet {
    address 10.0.5.2/24 {
    vrrp-group 1 {
    virtual-address 10.0.5.253;
    priority 80;
    accept-data;
    }
    }
    }
    }
    unit 530 {
    vlan-id 530;
    family inet {
    address 10.0.6.2/24 {
    vrrp-group 2 {
    virtual-address 10.0.6.253;
    accept-data;
    }
    }
    }
    }
    }
  • hoogen82hoogen82 Member Posts: 272
    Maybe it is just your Olive here... Configuration looks okay... Sorry man.. It might be just your OLIVE...Aldur might know or probably Toufiq... I believe toufiq is also from Pakistan.

    My Configuration

    [email protected]> show configuration interfaces ge-0/0/0
    vlan-tagging;
    unit 0 {
    bandwidth 100m;
    vlan-id 31;
    family inet {
    address 10.0.5.1/24 {
    vrrp-group 1 {
    virtual-address 10.0.5.200;
    authentication-type simple;
    authentication-key "$9$TF6ArlMWxd"; ## SECRET-DATA
    track {
    interface ge-0/0/1.200 {
    priority-cost 30;
    }
    }
    }
    }
    }
    }

    [email protected]>

    [email protected]> show vrrp summary
    Interface Unit Group Type Address Int state VR state
    ge-0/0/0 0 1 lcl 10.0.5.1 up master
    vip 10.0.5.200

    [email protected]> show vrrp brief
    Interface Unit Group Type Address Int state VR state Timer
    ge-0/0/0 0 1 lcl 10.0.5.1 up master A 0.233
    vip 10.0.5.200

    [email protected]> show vrrp detail
    Physical interface: ge-0/0/0, Unit: 0, Vlan-id: 31, Address: 10.0.5.1/24
    Index: 64, SNMP ifIndex: 22, VRRP-Traps: disabled
    Interface state: up, Group: 1, State: master
    Priority: 100, Advertisement interval: 1, Authentication type: simple
    Preempt: yes, Accept-data mode: no, VIP count: 1, VIP: 10.0.5.200
    Advertisement timer: 0.812s, Master router: 10.0.5.1
    Virtual router uptime: 11:55:31, Master router uptime: 11:55:23
    Virtual MAC: 00:00:5e:00:01:01
    Tracking: enabled
    Current priority: 100, Configured priority: 100
    Priority hold-time: disabled
    Interface tracking: enabled, Interface count: 1
    Interface Int state Int speed Incurred priority cost
    ge-0/0/1.200 up 1g 0
    Route tracking: disabled


    [email protected]>

    [email protected]> show configuration interfaces ge-0/0/0
    vlan-tagging;
    unit 0 {
    bandwidth 100m;
    vlan-id 31;
    family inet {
    address 10.0.5.2/24 {
    vrrp-group 1 {
    virtual-address 10.0.5.200;
    priority 80;
    authentication-type simple;
    authentication-key "$9$v/z8xdDjq.5F"; ## SECRET-DATA
    }
    }
    }
    }

    [email protected]>

    [email protected]> show vrrp detail
    Physical interface: ge-0/0/0, Unit: 0, Vlan-id: 31, Address: 10.0.5.2/24
    Index: 64, SNMP ifIndex: 116, VRRP-Traps: disabled
    Interface state: up, Group: 1, State: backup
    Priority: 80, Advertisement interval: 1, Authentication type: simple
    Preempt: yes, Accept-data mode: no, VIP count: 1, VIP: 10.0.5.200
    Dead timer: 3.416s, Master priority: 100, Master router: 10.0.5.1
    Virtual router uptime: 11:52:05
    Tracking: disabled


    [email protected]> show vrrp summary
    Interface Unit Group Type Address Int state VR state
    ge-0/0/0 0 1 lcl 10.0.5.2 up backup
    vip 10.0.5.200

    [email protected]> show vrrp brief
    Interface Unit Group Type Address Int state VR state Timer
    ge-0/0/0 0 1 lcl 10.0.5.2 up backup D 3.226
    vip 10.0.5.200
    mas 10.0.5.1

    [email protected]>
    IS-IS Sleeps.
    BGP peers are quiet.
    Something must be wrong.
  • adeel32adeel32 Member Posts: 27 ■□□□□□□□□□
    Thanks for your reply. At-least my configurations have been verified. Toufiq is preparing for JNCIP exam with me. We both have same issue. We are now trying for remote lab.

    Regards
    Adeel Ahmed
  • hoogen82hoogen82 Member Posts: 272
    When are you guys taking the exam... My best wishes to both of you...
    IS-IS Sleeps.
    BGP peers are quiet.
    Something must be wrong.
  • adeel32adeel32 Member Posts: 27 ■□□□□□□□□□
    on 30th December 2009 inshallah. thanks for your wishes
  • AldurAldur Juniper Moderator Member Posts: 1,460
    I was thinking that this was an olive issue as well icon_sad.gif

    More specifically this seems to be an VM olive issue as opposed to a hardware olive issue. I never had any problems getting vrrp to run on my hardware olives back in the day that I was prepping for the IP.
    "Bribe is such an ugly word. I prefer extortion. The X makes it sound cool."

    -Bender
  • phroggyphroggy Member Posts: 2 ■□□□□□□□□□
    Yep, its a vmware olive issue.

    I have many hardware olives, running various codes and haven't not had this problem.
  • adeel32adeel32 Member Posts: 27 ■□□□□□□□□□
    I am now using Qemu for running VRRP and it is running on it but can anyone help me out to guide that how to pause the routers in Qemu as we can do in VMware.

    In Qemu i am separately running command line for each router and i have to quit which makes the routers to shut down completely, I want to pause it so that i can use again from where i have left without loading the routers again.

    Note: I can give access of my laptop for its guidance.
  • h3ndr1sth3ndr1st Member Posts: 1 ■□□□□□□□□□
    adeel32 wrote: »
    I am now using Qemu for running VRRP and it is running on it but can anyone help me out to guide that how to pause the routers in Qemu as we can do in VMware.

    In Qemu i am separately running command line for each router and i have to quit which makes the routers to shut down completely, I want to pause it so that i can use again from where i have left without loading the routers again.

    Note: I can give access of my laptop for its guidance.

    Hi adeel32 ,

    I have running VRRP in olive using qemu but after I commit the configuration , suddenly the qemu is crash .

    Can I have the information from You , which version you using qemu and junos version .
    I am using qemu 0.9 with jqemu and kernel kqemu 0.13 , and junos version 8.5 R4.3

    Thanks a lot
  • michelvankesselmichelvankessel Member Posts: 1 ■□□□□□□□□□
    Dear Hoogen82,

    Could you explain to me how you get those ge-x/y/z interfaces in VMware/Olive?

    That will resolve the whole problem

    regards

    Michel
    hoogen82 wrote: »
    Maybe it is just your Olive here... Configuration looks okay... Sorry man.. It might be just your OLIVE...Aldur might know or probably Toufiq... I believe toufiq is also from Pakistan.

    My Configuration

    [email protected]> show configuration interfaces ge-0/0/0
    vlan-tagging;
    unit 0 {
    bandwidth 100m;
    vlan-id 31;
    family inet {
    address 10.0.5.1/24 {
    vrrp-group 1 {
    virtual-address 10.0.5.200;
    authentication-type simple;
    authentication-key "$9$TF6ArlMWxd"; ## SECRET-DATA
    track {
    interface ge-0/0/1.200 {
    priority-cost 30;
    }
    }
    }
    }
    }
    }

    [email protected]>

    [email protected]> show vrrp summary
    Interface Unit Group Type Address Int state VR state
    ge-0/0/0 0 1 lcl 10.0.5.1 up master
    vip 10.0.5.200

    [email protected]> show vrrp brief
    Interface Unit Group Type Address Int state VR state Timer
    ge-0/0/0 0 1 lcl 10.0.5.1 up master A 0.233
    vip 10.0.5.200

    [email protected]> show vrrp detail
    Physical interface: ge-0/0/0, Unit: 0, Vlan-id: 31, Address: 10.0.5.1/24
    Index: 64, SNMP ifIndex: 22, VRRP-Traps: disabled
    Interface state: up, Group: 1, State: master
    Priority: 100, Advertisement interval: 1, Authentication type: simple
    Preempt: yes, Accept-data mode: no, VIP count: 1, VIP: 10.0.5.200
    Advertisement timer: 0.812s, Master router: 10.0.5.1
    Virtual router uptime: 11:55:31, Master router uptime: 11:55:23
    Virtual MAC: 00:00:5e:00:01:01
    Tracking: enabled
    Current priority: 100, Configured priority: 100
    Priority hold-time: disabled
    Interface tracking: enabled, Interface count: 1
    Interface Int state Int speed Incurred priority cost
    ge-0/0/1.200 up 1g 0
    Route tracking: disabled


    [email protected]>

    [email protected]> show configuration interfaces ge-0/0/0
    vlan-tagging;
    unit 0 {
    bandwidth 100m;
    vlan-id 31;
    family inet {
    address 10.0.5.2/24 {
    vrrp-group 1 {
    virtual-address 10.0.5.200;
    priority 80;
    authentication-type simple;
    authentication-key "$9$v/z8xdDjq.5F"; ## SECRET-DATA
    }
    }
    }
    }

    [email protected]>

    [email protected]> show vrrp detail
    Physical interface: ge-0/0/0, Unit: 0, Vlan-id: 31, Address: 10.0.5.2/24
    Index: 64, SNMP ifIndex: 116, VRRP-Traps: disabled
    Interface state: up, Group: 1, State: backup
    Priority: 80, Advertisement interval: 1, Authentication type: simple
    Preempt: yes, Accept-data mode: no, VIP count: 1, VIP: 10.0.5.200
    Dead timer: 3.416s, Master priority: 100, Master router: 10.0.5.1
    Virtual router uptime: 11:52:05
    Tracking: disabled


    [email protected]> show vrrp summary
    Interface Unit Group Type Address Int state VR state
    ge-0/0/0 0 1 lcl 10.0.5.2 up backup
    vip 10.0.5.200

    [email protected]> show vrrp brief
    Interface Unit Group Type Address Int state VR state Timer
    ge-0/0/0 0 1 lcl 10.0.5.2 up backup D 3.226
    vip 10.0.5.200
    mas 10.0.5.1

    [email protected]>
  • hoogen82hoogen82 Member Posts: 272
    Well in Olive you can have fxp ports only... It's a virtual router with virtual interfaces...
    IS-IS Sleeps.
    BGP peers are quiet.
    Something must be wrong.
  • AldurAldur Juniper Moderator Member Posts: 1,460
    hoogen82 wrote: »
    Well in Olive you can have fxp ports only... It's a virtual router with virtual interfaces...

    Or em interfaces for VMware olives ;)

    But to Hoogen's point, you won't be able to get any w-x/y/z interfaces with any type of olives.
    "Bribe is such an ugly word. I prefer extortion. The X makes it sound cool."

    -Bender
  • hoogen82hoogen82 Member Posts: 272
    Err.. yeah.. Not sure what I was thinking there... Aldur.. Thank You for correcting that...
    IS-IS Sleeps.
    BGP peers are quiet.
    Something must be wrong.
  • AldurAldur Juniper Moderator Member Posts: 1,460
    hoogen82 wrote: »
    Err.. yeah.. Not sure what I was thinking there... Aldur.. Thank You for correcting that...

    hehe, I just couldn't resist ;)

    But still what you said holds true for em or fxp interfaces with olives.
    "Bribe is such an ugly word. I prefer extortion. The X makes it sound cool."

    -Bender
Sign In or Register to comment.