Rebuild OWA Virtual Directories for SBS2008

CMageeCMagee Posts: 1Member ■□□□□□□□□□
I've corrupted my OWA 2007 Virtual Directories after the latest roll up.

I need to restore these, working on a Win SBS2008 Server.

Can't uninstall IIS as it runsa a lot of other tools that are fine.

Only issue is with OWA so could do with some help please guys.

RWW works to connect me to the company web etc just not outlook.

Keep getting Service Unavailable, HTTP Error 503. The service is unavailable on a white background.

Have rolled up to Exch 2007 and then Roll Up 1 to try to resolve but no joy yet. Exchange Best Practise Analyser & SBS 2008 BPA don't see anything wrong but it's still broken.

Log files don't give any more info that I can find so I'm convinced it's the Virtual Directories.

Looking to be inspired guys.

Cheers.

Comments

  • ClaymooreClaymoore Posts: 1,637Member
    You would need to use a combination of the remove-owavirtualdirectory and new-owavirtualdirectory cmdlets to remove and rebuild the owa virtual directory.

    Remove-OwaVirtualDirectory: Exchange 2007 Help
    New-OwaVirtualDirectory: Exchange 2007 Help
  • wedge1988wedge1988 Posts: 434Member
    In exchange 2003, if you deleted the websites in IIS that relate to OWA, think there are 4, then restarted the information store service (think it was this one) then the OWA directory would be re-setup for you.

    I had to do this a few times.
    ~ wedge1988 ~ IdioT Certified~
    MCSE:2003 ~ MCITP:EA ~ CCNP:R&S ~ CCNA:R&S ~ CCNA:Voice ~ Office 2000 MASTER ~ A+ ~ N+ ~ C&G:IT Diploma ~ Ofqual Entry Japanese
  • HeroPsychoHeroPsycho Posts: 1,940Inactive Imported Users
    wedge1988 wrote: »
    In exchange 2003, if you deleted the websites in IIS that relate to OWA, think there are 4, then restarted the information store service (think it was this one) then the OWA directory would be re-setup for you.

    I had to do this a few times.

    Doesn't apply to Exchange 2007/SBS2008.
    Good luck to all!
Sign In or Register to comment.