OSPF Packet Tracer issue

brewoz404brewoz404 Posts: 3Member ■□□□□□□□□□
Need help! I'm having an issue with OSPF with packet tracer. I have enabled ospf on all 3 routers, but no updates are being sent and if I do a sh ip route, no ospf routes are listed. Also, sh ip ospf neighbor shows nothing as well. All 3 routers are conf for area 0. Has anyone run into issues with ospf and packet tracker. Thanks for the help! Here's output from the sh ip pro and sh ip int b from R1:

Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 192.168.1.1
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
192.168.1.0 0.0.0.0 area 0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 110)

Router#sh ip int b
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 192.168.1.1 YES manual up up

Serial0/0 68.110.171.98 YES manual up up

FastEthernet1/0 unassigned YES manual up down

FastEthernet1/1 unassigned YES manual up down


Output from R2:

Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 192.168.20.1
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
192.168.0.0 0.0.255.255 area 0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 110)

R2#sh ip int b
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 192.168.1.2 YES manual up up

FastEthernet0/0.10 192.168.10.1 YES manual up up

FastEthernet0/0.20 192.168.20.1 YES manual up up

Serial1/0 192.168.2.1 YES manual up up

Serial1/1 unassigned YES manual down down

Serial1/2 unassigned YES manual down down

Serial1/3 unassigned YES manual down down


Output from R3:

R3#sh ip pro
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 192.168.3.1
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
192.168.0.0 0.0.0.255 area 0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 110)

R3#sh ip int b
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 192.168.3.1 YES manual up up

FastEthernet0/1 unassigned YES manual up down

Serial0/0 unassigned YES manual down down

Serial0/1 unassigned YES manual down down

Serial1/0 192.168.2.2 YES manual up up

Serial1/1 unassigned YES manual down down

Serial1/2 unassigned YES manual down down

Serial1/3 unassigned YES manual down down

Comments

  • networker050184networker050184 Posts: 11,962Mod Mod
    I believe you have your network statements messed up. Give us the relevant running config or try a show ip ospf interface to make sure your network statements are encompassing the correct interfaces.
    An expert is a man who has made all the mistakes which can be made.
  • SelfmadeSelfmade Posts: 268Member
    looks like the 192.168.1.0 network on router 1 needs a correct wildcard mask of 0.0.0.255 area 0

    same thing for router 2, because you're using a class C address, not a class B

    you have your wildcard masks wrong, that's the problem there chief

    here's the easy way to get your wildcard masks correct

    let's say your wildcard mask is 255.255.255.224

    to figure it out

    255.255.255.255
    - 255.255.255.224
    0.0.0.31 would be your wildcard mask

    that's the easy way to ensure you get the correct wildcard masks

    it works for all wildcard masks you have to calculate, just do 255.255.255.255 minus whatever the subnet mask is for the network and you have your wildcard mask
    It's not important to add reptutation points to others, but to be nice and spread good karma everywhere you go.
  • brewoz404brewoz404 Posts: 3Member ■□□□□□□□□□
    Thanks for the tip, had the network portion of the ospf command wrong on R3, once that was corrected, R2 and R3 exchanged updates. Still can't get R1 to work thought, here is the sh running-conf of R1:

    Building configuration...
    Current configuration : 696 bytes
    !
    version 12.2
    service password-encryption
    !
    hostname Router
    !
    !
    enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
    !
    !
    !
    !
    ip ssh version 1
    no ip domain-lookup
    !
    !
    interface FastEthernet0/0
    description CONNECTION TO SWITCH1
    ip address 192.168.1.1 255.255.255.0
    duplex full
    speed 100
    !
    interface Serial0/0
    ip address 68.110.171.98 255.255.255.224
    !
    interface FastEthernet1/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet1/1
    no ip address
    duplex auto
    speed auto
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.1.0 0.0.0.0 area 0
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 68.110.171.97
    !
    !
    !
    !
    !
    line con 0
    password 7 0822455D0A16
    login
    line vty 0 4
    login
    !
    !
    end

    Heres the conf for R2 which it's linked to:
    Building configuration...
    Current configuration : 846 bytes
    !
    version 12.2
    service password-encryption
    !
    hostname R2
    !
    !
    enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
    !
    !
    !
    !
    ip ssh version 1
    no ip domain-lookup
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.2 255.255.255.0
    duplex full
    speed 100
    !
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.10.1 255.255.255.0
    !
    interface FastEthernet0/0.20
    encapsulation dot1Q 20
    ip address 192.168.20.1 255.255.255.0
    !
    interface Serial1/0
    ip address 192.168.2.1 255.255.255.0
    clock rate 2000000
    !
    interface Serial1/1
    no ip address
    !
    interface Serial1/2
    no ip address
    !
    interface Serial1/3
    no ip address
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.0.0 0.0.255.255 area 0
    !
    ip classless
    !
    !
    !
    !
    !
    line con 0
    password 7 0822455D0A16
    logging synchronous
    login
    line vty 0 4
    password 7 0822455D0A16
    login
    !
    !
    end
  • brewoz404brewoz404 Posts: 3Member ■□□□□□□□□□
    Thanks for the help guys! That was it!! Incorrect network statements on R1 and R3. Changed on R1 to network 192.168.1.1 0.0.0.0 area 0 and R3 network 192.168.0.0 0.0.255.255 area 0. Once those changes were made, ospf worked!! icon_cheers.gif THANKS AGAIN!
  • SelfmadeSelfmade Posts: 268Member
    i'm going to PM you my email address, if you can send me the Packet Tracer file within the next 2 hours before I leave for work (if i go to work) then i can help you figure it out

    i need a big picture here, your output is only one part of the picture
    It's not important to add reptutation points to others, but to be nice and spread good karma everywhere you go.
  • SelfmadeSelfmade Posts: 268Member
    well glad you got it working lol

    OSPF is all about getting your wildcard masks and network addresses correct

    once you master that, the rest is easy
    It's not important to add reptutation points to others, but to be nice and spread good karma everywhere you go.
Sign In or Register to comment.