mc3810 - E1 pri ?

woo111woo111 Member Posts: 2 ■□□□□□□□□□
Hi Guys, i have a mc3810. But unable to configure the PRI interface. want to use it as a PSTN simulator.

i keep getting
%ISDN is not supported in this controller.
%ISDN is not supported in this controller.

Am i able to configure ISDNVoice on the onboard E1 port ? or is it just really a 2meg pipe, Im running an old IOS, as i dont have 64megs of ram, and not sure if the bootrom onthis would support 64meg anyway.

Any tips/Pointers would be helpful.

IOS (tm) MC3810 Software (MC3810-A2IK9S-M), Version 12.2(29b), RELEASE SOFTWARE (fc1)

ROM: System Bootstrap, Version 11.3(1)MA1, MAINTENANCE INTERIM SOFTWARE
ROM: MC3810 Software (MC3810-WBOOT-M), Version 11.3(1)MA1, MAINTENANCE INTERIM SOFTWARE

cisco MC3810 (MPC860) processor (revision 06.07) with 28672K/4096K bytes of memory.
Processor board ID
PPC860 PowerQUICC, partnum 0x0000, version A03(0x0013)
Channelized E1, Version 1.0.
Bridging software.
X.25 software, Version 3.0.0.
Primary Rate ISDN software, Version 1.1.
MC3810 SCB board (v05.A0)
1 Multiflex E1(slot 3) RJ45 interface(v05.A0)
1 Six-Slot Analog Voice Module (v03.K0)
1 Analog FXS voice interface (v03.K0) port 1/3
1 3-DSP(slot2) Voice Compression Module(v01.A0)
1 Ethernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
2 Serial(sync/async) network interface(s)
1 Channelized E1/PRI port(s)
256K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (AMD29F016)

Configuration register is 0x2102

Comments

  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    I get the same thing - CAS mode works fine though - My guess is it's a limitation of the hardware:

    MC3810(config-controller)#pri-group timeslots 1-31
    %ISDN is not supported in this controller.
    %ISDN is not supported in this controller.

    MC3810(config)#controller E1 0
    MC3810(config-controller)#mode ?
    atm Configure ATM mode
    cas Configure CAS (Channel Associated Signal) mode

    MC3810(config)#controller T1 1
    MC3810(config-controller)#mode ?
    cas Configure CAS (Channel Associated Signal) mode
    ccs Configure CCS (Common Channel Signal) mode

    MC3810#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) MC3810 Software (MC3810-A2JK9SV5-M), Version 12.3(18 ), RELEASE SOFTWARE (fc3)
    Technical Support: Cisco - Shortcut
    Copyright (c) 1986-2006 by cisco Systems, Inc.
    Compiled Wed 15-Mar-06 21:46 by dchih
    Image text-base: 0x00023000, data-base: 0x019F6C60

    ROM: System Bootstrap, Version 12.0(6r)T4, RELEASE SOFTWARE (fc1)
    ROM: MC3810 Software (MC3810-WBOOT-M), Version 12.0(1)XA4, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

    MC3810 uptime is 26 minutes
    System returned to ROM by power-on
    System image file is "flash:mc3810-a2jk9sv5-mz.123-18.bin"


    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.

    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    Export Compliance Product Report Application

    If you require further assistance please contact us by sending email to
    [email protected].

    cisco MC3810 (MPC860) processor (revision 16.00) with 61440K/4096K bytes of memory.
    Processor board ID 14762547
    PPC860 PowerQUICC, partnum 0x0000, version C01(0x0031)
    Channelized E1, Version 1.0.
    Bridging software.
    X.25 software, Version 3.0.0.
    SuperLAT software (copyright 1990 by Meridian Technology Corp).
    TN3270 Emulation software.
    Primary Rate ISDN software, Version 1.1.
    MC3810 SCB board (v16.A0)
    1 Multiflex E1(slot 3) RJ11(v05.A0)
    1 Multiflex T1(slot 4) RJ45 interface(v02.C0)
    1 6-DSP(slot2) Voice Compression Module(v02.A0)
    1 6-DSP(slot5) Voice Compression Module(v02.A0)
    1 Ethernet/IEEE 802.3 interface(s)
    1 Serial network interface(s)
    2 Serial(sync/async) network interface(s)
    1 Channelized E1/PRI port(s)
    1 Channelized T1/PRI port(s)
    256K bytes of non-volatile configuration memory.
    16384K bytes of processor board System flash (AMD29F016)

    Configuration register is 0x2102

    MC3810#sh run
    Building configuration...

    Current configuration : 991 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname MC3810
    !
    boot-start-marker
    boot-end-marker
    !
    !
    network-clock base-rate 56k
    no aaa new-model
    ip subnet-zero
    !
    !
    !
    isdn switch-type primary-ni
    !
    !
    !
    !
    !
    !
    !
    !
    !
    no voice confirmation-tone
    !
    !
    !
    !
    !
    controller E1 0
    mode cas
    ds0-group 0 timeslots 1-15,17-31 type e&m-wink-start
    !
    controller T1 1
    framing esf
    linecode b8zs
    pri-group timeslots 1-24
    !
    !
    !
    !
    !
    interface Ethernet0
    ip address 10.10.10.1 255.255.255.0
    !
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface Serial1:23
    no ip address
    no logging event link-status
    isdn switch-type primary-ni
    isdn incoming-voice voice
    no cdp enable
    !
    interface FR-ATM20
    no ip address
    shutdown
    !
    ip classless
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    voice-port 0:0
    !
    voice-port 1:23
    !
    !
    !
    !
    line con 0
    line aux 0
    line 2 3
    line vty 0 4
    login
    !
    End

    <<<<<<<< Config on a 2821 >>>>>>>>

    c2821_PSTN(config)#controller E1 0/2/0
    c2821_PSTN(config-controller)#mode ?
    cas Configure CAS (Channel Associated Signal) mode
    ccs Configure CCS (Common Channel Signal) mode

    c2821_PSTN(config-controller)#pri-group timeslots 1-8
    c2821_PSTN(config-controller)#
    *Apr 17 19:31:24.207: %LINK-3-UPDOWN: Interface ISDN-VOICE 0/2/0:15(1), changed state to up
    *Apr 17 19:31:24.207: %LINK-3-UPDOWN: Interface ISDN-VOICE 0/2/0:15(2), changed state to up
    *Apr 17 19:31:24.207: %LINK-3-UPDOWN: Interface ISDN-VOICE 0/2/0:15(3), changed state to up
    *Apr 17 19:31:24.207: %LINK-3-UPDOWN: Interface ISDN-VOICE 0/2/0:15(4), changed state to up
    *Apr 17 19:31:24.207: %LINK-3-UPDOWN: Interface ISDN-VOICE 0/2/0:15(5), changed state to up
    *Apr 17 19:31:24.207: %LINK-3-UPDOWN: Interface ISDN-VOICE 0/2/0:15(6), changed state to up
    *Apr 17 19:31:24.207: %LINK-3-UPDOWN: Interface ISDN-VOICE 0/2/0:15(7), changed state to up
    *Apr 17 19:31:24.207: %LINK-3-UPDOWN: Interface ISDN-VOICE 0/2/0:15(8 ), changed state to up
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
  • woo111woo111 Member Posts: 2 ■□□□□□□□□□
    Hmm... well i pulled out the analogue board, and stuck the E1 card in there. after removing the 6port faceplate
    and what do you know, it allows me to select CCS now.... Im guessing controller 0 doesnt support ISDN/Qsig etc...

    Hmm Doesnt look like my bootroom will support 64megs if i compare it to yours, and the board also takes the older 72pin ram. May try and find a 64meg chip and see if it works or not. May also see if i can stuck in another E1 cards, since there is another slot there. Not sure if that is supported though. Seems to take most of the isdn commands and is emulating a telco now.

    Haven't got my E1 card for my 2801 yet, to verify it works completely. i'll post back on my results. Would be good if i could get the 3810 to do the 2 E1's then wont need to worry about doing vofr , since i cant run an image to do voip.
Sign In or Register to comment.