Redistributing a Static Route

boostinbadgerboostinbadger Posts: 256Member
I have a topology set up like the one in the CCNA CBT Nuggets.

WWW---R1---SW1---R2---R3

RIP is running properly on all interfaces. I ran "router rip" on R1 and typed "redistribute static" after I configured a default static route. R2 and R3 are not showing the default route when issued the "show ip route" command.

Comments

  • SelfmadeSelfmade Posts: 268Member
    default-information originate is what you want to do, i think
    It's not important to add reptutation points to others, but to be nice and spread good karma everywhere you go.
  • abefromanabefroman Posts: 278Banned
    I understand this is not on the CCNA.
    Next certs:
    CCNA 99.9999999999999999999999999999999% Ready

    There are /31 types of people in this world, those who understand subnetting, and those who don't
  • boostinbadgerboostinbadger Posts: 256Member
    It is not on the CCNA according to Jeremy on CBT Nuggets, but cool nonetheless.
  • notgoing2failnotgoing2fail Posts: 1,138Member
    That's not entirely true.....Jeremy doesn't know all the pool questions....I can tell you no you can't -- MODERATED
  • alan2308alan2308 Senior Member Ann Arbor, MIPosts: 1,854Member ■■■■■■■■□□
    This is really interesting. I know that we covered "redistribute static" and "default-information originate" under RIP in the CNA, but I cant find it in either Todd Lammle or Wendell Odom's books.
  • notgoing2failnotgoing2fail Posts: 1,138Member
    That's not entirely true.....Jeremy doesn't know all the pool questions....I can tell you no you can't -- MODERATED


    LOL sorry my bad, after I posted that I was thinking.....hmm...maybe that was too much info....

    Again my apologies.... icon_rolleyes.gif
  • boostinbadgerboostinbadger Posts: 256Member
    I entered "default-information originate" to no avail.
  • alan2308alan2308 Senior Member Ann Arbor, MIPosts: 1,854Member ■■■■■■■■□□
    I entered "default-information originate" to no avail.

    Is the static route showing correctly in the routing table for R1?

    S* 0.0.0.0/0 [1/0] via 192.168.1.1
  • boostinbadgerboostinbadger Posts: 256Member
    Yes it is.

    CBTR1_2520#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    C 192.168.1.0/24 is directly connected, Ethernet0
    R 192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:06, Ethernet0
    R 192.168.3.0/24 [120/2] via 192.168.1.2, 00:00:06, Ethernet0
    S* 0.0.0.0/0 is directly connected, Ethernet0
  • alan2308alan2308 Senior Member Ann Arbor, MIPosts: 1,854Member ■■■■■■■■□□
    Yes it is.

    CBTR1_2520#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    C 192.168.1.0/24 is directly connected, Ethernet0
    R 192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:06, Ethernet0
    R 192.168.3.0/24 [120/2] via 192.168.1.2, 00:00:06, Ethernet0
    S* 0.0.0.0/0 is directly connected, Ethernet0

    Then there is no reason that it shouldn't be showing up in the routing tables for the other routers since RIP is obviously running correctly. Its just a guess at this point, but try "no redistribute static" also.

    Are you doing this with real gear or a simulator?
  • boostinbadgerboostinbadger Posts: 256Member
    I am using real 2520s.

    I did a "no redistribute static" waited for the next RIP updates, still not showing in route table.
  • networker050184networker050184 Posts: 11,962Mod Mod
    Have you set a default metric?
    An expert is a man who has made all the mistakes which can be made.
  • APAAPA Posts: 959Member
    Its because of 'split-horizon'.... your default route is reachable over the same interface that your RIP neighbors are therefore by default it won't advertise the static route out the same interface that it thinks it is reachable via.... this can be seen when you enter 'debug ip rip' on the RIP neighbors....

    You should see that the announcement from R1 0.0.0.0 0.0.0.0 is immediately marked as inaccessible because it is given the dead metric of 16.....

    So you have two options...... either disable split-horizon on the interface connecting R1 to the other RIP neighbors via 'no ip split-horizon'

    You should then see the default route being correctly advertised... either with a metric of '1' for default or whatever seed metric your specified.....

    otherwise.....

    Remove 'redistribute static' ensure you only have default-information originate applied....

    Then clear the route table instead of waiting for the default RIP advertisement timer 'clear ip route *'

    You should see the default route now being learnt........ as split-horizon won't break this announcement.....

    With RIPv1(assuming you've enabled 1 and now v2) there really isn't much to the config.... as your static default route is in the route-table correctly all you need is 'default-information originate' under the RIP configuration on R1 so that it will distribute the default to its RIP neighbors, not necessary for the 'redistribute static' statement in this scenario.

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
  • alan2308alan2308 Senior Member Ann Arbor, MIPosts: 1,854Member ■■■■■■■■□□
    Also, on your default route, you have it pointed at the ethernet port. If it's pointing towards a broadcast network (ie, Ethernet), it has to point at the next hop IP address (the device simulating WWW in your lab).
  • boostinbadgerboostinbadger Posts: 256Member
    It was split-horizon. I didn't disable it, just configured s0 as 192.168.4.1, set the clock rate and configured s0 on my AS to 192.168.4.2 to act like an ISP. I then did an ip route 0.0.0.0 0.0.0.0 192.168.4.2. Now R2 and R3 show a default route learned by RIP.

    I knew about split horizon, but forgot about the interfaces on that particular router. There are two e0, one AUI and one 10bT. You can only use one. I had it configured thinking both were usable.

    All these dumb mistakes sure do make me learn a lot more :)
Sign In or Register to comment.