Self Teaching CCNA - sorta

bogidubogidu Member Posts: 10 ■□□□□□□□□□
Greetings all!

I finally took the plunge and started working through all the materials to actually become certifiable and I'm just deep enough into the stuff to have my first (of many?) issues.

I've laid out my testbed as follows:

1) Wireless bridge - 192.168.1.2
2) Mac G4 - 192.168.1.104 (connected to switch 1)
3) Switch 1 - 192.168.1.130
4) Router 1 - 192.168.1.5 (ethernet)
5) Router 1 - 192.168.2.15 (serial 0)
6) Router 2 - 192.168.2.16 (serial 0)
7) Router 2 - 192.168.3.5 (ethernet)
8 ) Switch 2 - 192.168.3.130
9) Laptop 1 - 192.168.3.10

I've enabled rip and the results of the config on router 1 are listed below:

WAN#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, Ethernet0
C 192.168.2.0/24 is directly connected, Serial0
R 192.168.3.0/24 [120/1] via 192.168.2.16, 00:00:11, Serial0

Router 2 is virtually identical except that the R is on 192.168.1.0/24 (which makes sense).

So now for the actual question. The mac works fine and can access the internet via the wireless bridge. The Laptop located on the 192.168.3.0 subnet is unable to ping anything other than the 192.168.3.5 address. From a console connection on router 2 I am able to ping as far as the 192.168.1.5, but cannot reach the switch, wireless bridge, or the Mac. Any thoughts would be appreciated.

Bill

Comments

  • spartangtrspartangtr Member Posts: 111
    Have you tried running a tracert to see where the packets are dropping? If I read that correctly they are dropping right at R2, so start looking there. Do you have a diagram or a simple drawing of how this is setup? Maybe post a config of R2?
  • chmorinchmorin Member Posts: 1,446 ■■■■■□□□□□
    For giggles remove the wireless bridge from the situation and tell me if that changes anything as far as the mac to laptop connectivity. Tell me how far the mac can ping to the laptop. Also show the running config on both routers.
    Currently Pursuing
    WGU (BS in IT Network Administration) - 52%| CCIE:Voice Written - 0% (0/200 Hours)
    mikej412 wrote:
    Cisco Networking isn't just a job, it's a Lifestyle.
  • bogidubogidu Member Posts: 10 ■□□□□□□□□□
    spartangtr wrote: »
    Have you tried running a tracert to see where the packets are dropping? If I read that correctly they are dropping right at R2, so start looking there. Do you have a diagram or a simple drawing of how this is setup? Maybe post a config of R2?

    The tracert was unable to reach the S0 on R2 (192.168.2.16) from the laptop. My understanding is that enabling rip and setting the networks would route across the subnets?

    I'll put together a diagram.

    Thanks.

    Bill
  • bogidubogidu Member Posts: 10 ■□□□□□□□□□
    chmorin wrote: »
    For giggles remove the wireless bridge from the situation and tell me if that changes anything as far as the mac to laptop connectivity. Tell me how far the mac can ping to the laptop. Also show the running config on both routers.

    The bridge is on the far end of the network.

    bridge --> switch1 --> Router1 --> Router2 --> Switch2 --> Laptop1

    the mac is hanging off of switch1.

    I disconnected it and tested and it made no difference.
  • bogidubogidu Member Posts: 10 ■□□□□□□□□□
    spartangtr wrote: »
    Have you tried running a tracert to see where the packets are dropping? If I read that correctly they are dropping right at R2, so start looking there. Do you have a diagram or a simple drawing of how this is setup? Maybe post a config of R2?

    Ok, I was posting the config for R2 and realized that I was missing the network route to 192.168.1.0 (and on R1 I was missing the route to 3.0). I added those, however I'm still unable to ping from 192.168.3.10. I see the eth0 on R2 but nothing beyond.

    R2 Config:

    LAN#show run
    Building configuration...

    Current configuration : 633 bytes
    !
    version 12.1
    no service single-slot-reload-enable
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname LAN
    !
    enable password
    !
    !
    !
    !
    !
    ip subnet-zero
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.3.5 255.255.255.0
    !
    interface Serial0
    description Connection to WAN Router
    ip address 192.168.2.16 255.255.255.0
    no fair-queue
    !
    interface Serial1
    no ip address
    shutdown
    !
    router rip
    network 192.168.1.0
    network 192.168.2.0
    network 192.168.3.0
    !
    ip classless
    ip http server
    !
    !
    line con 0
    password
    login
    line aux 0
    line vty 0 4
    password
    login
    !
    end

    LAN#

    R1 Config looks virtually the same except the necessary info for setting S0 for dce and ip addressing.
  • phoeneousphoeneous Go ping yourself... Member Posts: 2,333 ■■■■■■■□□□
    bogidu wrote: »
    Ok, I was posting the config for R2 and realized that I was missing the network route to 192.168.1.0 (and on R1 I was missing the route to 3.0). I added those, however I'm still unable to ping from 192.168.3.10. I see the eth0 on R2 but nothing beyond.

    That's not how RIP works. You use the network command to establish which interfaces take part in the RIP process. R1 should have network 192.168.1.0 and 192.168.2.0 because of the ip's that you've set on the ethernet and serial interfaces respectively. Likewise for R2 which should have 192.168.2.0 and 192.168.3.0.

    The reason why you can't hit 192.168.1.0 from R2 is because you're telling it that to reach that network it can use itself which isn't true because none of the interfaces on R2 are on the 192.168.1.0 network.

    Two suggestions:

    1. Learn what a default route is e.g. 0.0.0.0 0.0.0.0 s0
    2. Use service password-encryption to hash the passwords in your config
  • NetwurkNetwurk Member Posts: 1,155 ■■■■■□□□□□
    Does the laptop have your router (192.168.3.5) set as its default gateway?
  • bogidubogidu Member Posts: 10 ■□□□□□□□□□
    phoeneous wrote: »
    That's not how RIP works. You use the network command to establish which interfaces take part in the RIP process. R1 should have network 192.168.1.0 and 192.168.2.0 because of the ip's that you've set on the ethernet and serial interfaces respectively. Likewise for R2 which should have 192.168.2.0 and 192.168.3.0.

    The reason why you can't hit 192.168.1.0 from R2 is because you're telling it that to reach that network it can use itself which isn't true because none of the interfaces on R2 are on the 192.168.1.0 network.

    Two suggestions:

    1. Learn what a default route is e.g. 0.0.0.0 0.0.0.0 s0
    2. Use service password-encryption to hash the passwords in your config

    Ah, ok. Thank you for the explanation.

    I originally had my passwords encrypted until I wiped the routers yesterday.

    Bill
  • bogidubogidu Member Posts: 10 ■□□□□□□□□□
    Netwurk wrote: »
    Does the laptop have your router (192.168.3.5) set as its default gateway?

    oop, nope, had it set at 3.1 for an earlier configuration. That allowed me to get through to R1 to Switch1, but not beyond to the wireless bridge or internet. I'd say there was an issue there, but I'm currently using the mac connected to switch1 to write this post.
  • bogidubogidu Member Posts: 10 ■□□□□□□□□□
    I'll close out my own thread in case anyone needs the information. I figured out the solution.

    In the end my issue was the subnet mask. I had not learned subnetting well enough yet.

    My final configuration was to use a single router with two ethernet ports and create two subnets in the 192.168.1.0 range with a mask of 255.255.255.128. As soon as I setup the router ports I could access the WAN side from the LAN side.

    I'm assuming that armed with this new knowledge I could do the same with two routers except that I'd add a third subnet with only two hosts (properly masked of course) to connect the two routers.

    I was trying to make it work like I thought it should rather than how it actually functions.

    Thanks all for the input, I picked up quite a few other gems along the learning road.

    Bill
Sign In or Register to comment.