Install Exchange 2007 into a Child Domain Help.

flames1000flames1000 Posts: 49Member ■■□□□□□□□□
Ok, I will try to be as clear as possible. I need to install a exchange 2007 sp3 server into our child domain. The root domain has exchange 2007 sp2 installed and there is no exchange 2003 servers anywhere.

ROOT - Windows 2003 and Exchange 2007 SP2
CHILD - Windows 2008 R2 Enterprise and Exchange 2007 SP3

This is the first time i have installed a exchange server into a child domain. Is there anything that needs to be prepped in the root first as its only sp2? The admin there is going to install sp3 there and see if things help. In the root domain, the schema was extended to windows 2008 r2 and for exchange, setup/preparealldoamins was done sucessfully.

In the child domain, im installing exchange as a enterprise and schema admin with a user account in the root domain. What switches do i still run in the child domain? I have tried setup prepareAD /organizationName: Company Name and i get this error:
[ERROR] The specified value 'company,name' is not a valid organization name. Please specify a valid organization name. I did not put a comma in between the company name, just company name?

Do i just run setup /prepareAD AND Setup /preparedomain from the child? What is run from the root? There is not alot of documentation out for what is happening. This mail server in the child domain will be joining the mailserver in the root domain so im a little stuch and thought i would ask some exchange gurus.

Any help would be really appreciated as i need to get this up and running very soon.

thanks

Flames

Comments

  • jeanathanjeanathan Posts: 163Member
    PrepareAD runs PrepareForest and PrepareDomain and a few other things. All you need is /preparedomain, but if the other admin has run preparealldomains then the child should be ready.

    You should run from a DC in the child domain.

    There can only be one exchange organization per forest so the on:mycompany is the same as when you setup exchange in the forest for the first time?

    Organization Topologies: Exchange 2007 Help

    When in doubt technet, msexchange.org, howexchangeworks.com are your friend.
    flames1000 wrote: »
    Ok, I will try to be as clear as possible. I need to install a exchange 2007 sp3 server into our child domain. The root domain has exchange 2007 sp2 installed and there is no exchange 2003 servers anywhere.

    ROOT - Windows 2003 and Exchange 2007 SP2
    CHILD - Windows 2008 R2 Enterprise and Exchange 2007 SP3

    This is the first time i have installed a exchange server into a child domain. Is there anything that needs to be prepped in the root first as its only sp2? The admin there is going to install sp3 there and see if things help. In the root domain, the schema was extended to windows 2008 r2 and for exchange, setup/preparealldoamins was done sucessfully.

    In the child domain, im installing exchange as a enterprise and schema admin with a user account in the root domain. What switches do i still run in the child domain? I have tried setup prepareAD /organizationName: Company Name and i get this error:
    [ERROR] The specified value 'company,name' is not a valid organization name. Please specify a valid organization name. I did not put a comma in between the company name, just company name?

    Do i just run setup /prepareAD AND Setup /preparedomain from the child? What is run from the root? There is not alot of documentation out for what is happening. This mail server in the child domain will be joining the mailserver in the root domain so im a little stuch and thought i would ask some exchange gurus.

    Any help would be really appreciated as i need to get this up and running very soon.

    thanks

    Flames
    Struggling through the re-certification process after 2 years of no OJT for the CCNP.
  • flames1000flames1000 Posts: 49Member ■■□□□□□□□□
    Thanks jeanathan,

    I ran prepare/ad and preparealldomains in the root and let the replication go through, so i should be good to go now right? This was done a few days ago. Nothing was done in the child.

    flames
  • jeanathanjeanathan Posts: 163Member
    flames1000 wrote: »
    Thanks jeanathan,

    I ran prepare/ad and preparealldomains in the root and let the replication go through, so i should be good to go now right? This was done a few days ago. Nothing was done in the child.

    flames

    You should be ready to progress to the installing prereq software and services phase on the exchange server box. If in doubt you can use ASDIEdit.msc (Don't make changes when using this tool!) it is like regedit for AD. And from there you can connect to the child domain and verify the exchange objects exisit in that domain.

    More here: preparedomain Bhargav's IT Playground

    Just a word of caution: I have only been doing Exchange for about two months now so I am still a bit of an amature and as such I would take my advice with caution.
    Struggling through the re-certification process after 2 years of no OJT for the CCNP.
Sign In or Register to comment.