Options

Help setting up SSH on 2950 switch

Greenmet29Greenmet29 Member Posts: 240
Hi all.. I'm new to these forums... i've been studying for my ccent for a few months now, pretty much on my own. This is the 2nd time i've gone through Wendell Odem's book, and for some reason my SSH isn't working this time around. It worked flawlessly the first time... so i'm really stumped... can someone look at my running config and tell me what is wrong?

Switch#sh run
Building configuration...

Current configuration : 1340 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
username walle password 0 cisco
ip subnet-zero
!
ip domain-name abcd.com
ip ssh time-out 120
ip ssh authentication-retries 3
ip ssh version 2
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
...
...
...
interface FastEthernet0/24
!
interface Vlan1
ip address 172.30.2.180 255.255.255.0
no ip route-cache
!
ip default-gateway 172.30.2.1
ip http server
!
line con 0
password cisco
login
line vty 0 4
password vty
login
transport input telnet ssh
line vty 5 15
login
!
!
end


I am running c2950-i6k2l2q4-mz.121-22.EA11.bin.

I have reset the switch to factory defaults twice now, changed the port that I am connected to, etc, and can't figure out the problem.

When I open teraterm, and ssh to 172.30.2.180, (from 172.30.2.181), it opens the ssh port, with the show ssh outputting:

sh ssh
Connection Version Mode Encryption Hmac State Username
0 2.0 IN 3des-cbc hmac-sha1 Keys exchanged -
0 2.0 OUT 3des-cbc hmac-sha1 Keys exchanged -
%No SSHv1 server connections running.
Switch#

I put in my User/pass and it says "authentication failed, please try again".

It grays out my username so that I can't type it again and keeps asking for my password.

Thanks in advance for any help you can give!

Comments

  • Options
    bermovickbermovick Member Posts: 1,135 ■■■■□□□□□□
    I'm not familiar with teraterm, but this line:
    %No SSHv1 server connections running.
    

    seems to suggest teraterm is trying to make an SSHv1 connection, while you have
    ip ssh version 2
    

    on the switch. I'd look into making teraterm use SSHv2
    Latest Completed: CISSP

    Current goal: Dunno
  • Options
    Greenmet29Greenmet29 Member Posts: 240
    I thought that might be it also, but if I am not connected, it shows:

    Switch#sh ssh
    %No SSHv2 server connections running.
    %No SSHv1 server connections running.

    So I think it just shows both versions on the show ssh... And i've double and triple checked that it is trying to connect with ssh2. I've even uninstalled and reinstalled teraterm, and tried a different version.
  • Options
    rogue2shadowrogue2shadow Member Posts: 1,501 ■■■■■■■■□□
    Add login local to your configuration.
    Router(config)# line vty 0 4
    Router(config-line)# login local
    

    Try switching telnet and ssh in transport input as well.
    Router(config)# line vty 0 4
    Router(config-line)# transport input [B]ssh[/B] telnet
    
  • Options
    Greenmet29Greenmet29 Member Posts: 240
    ahh!! That was it! I've been writing web pages and programs in vb and C# for a few years, and when theres something I can't figure out, it always seems like it's something easy. THANKS!!!
  • Options
    rogue2shadowrogue2shadow Member Posts: 1,501 ■■■■■■■■□□
    Greenmet29 wrote: »
    ahh!! That was it! I've been writing web pages and programs in vb and C# for a few years, and when theres something I can't figure out, it always seems like it's something easy. THANKS!!!

    Np man. I just took CCNA this summer and I'm already getting rusty due to Linux studies hahah.
Sign In or Register to comment.