PRI issues

Well, I have hit a snag in studies. All was going well until I got to Chapt 6 CVOICE and was trying to confirm ops based on example config in the book.

I have a 2811 and 1760V connected back to back with VWIC-1MFT-T1s configs as follows:
2811
network-clock-participate wic 3 
!
!
!
isdn switch-type primary-ni
!
controller T1 0/3/0
 framing esf
 clock source internal  ! providing clocking to 1760V
 linecode b8zs
 pri-group timeslots 1-12,24
!
!
interface Serial0/3/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
voice-port 0/3/0:23
!
1760V
!
!
tdm clock T1 0/0 both export line
!
!output cut
!
!
controller T1 0/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-12,24
!
interface Serial0/0:23
 no ip address
 encapsulation hdlc
 no logging event link-status
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
!
!
voice-port 0/0:23
!

sh ver, sh controllers T1, and sh isdn status for 2811
2811#sh ver
Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)
 
2811#sh controllers t1
T1 0/3/0 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  No alarms detected.
  alarm-trigger is not set
  Soaking time: 3, Clearance time: 10
  AIS State:Clear  LOS State:Clear  LOF State:Clear 
  Version info Firmware: 20070320, FPGA: 20, spm_count = 0
  Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (391 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 13 15 minute intervals):
     1041 Line Code Violations, 22431 Path Code Violations,
     3737 Slip Secs, 0 Fr Loss Secs, 6 Line Err Secs, 2 Degraded Mins,
     3735 Errored Secs, 0 Bursty Err Secs, 16 Severely Err Secs, 2506 Unavail Secs
2811#
          
2811#sh isdn stat
Global ISDN Switchtype = primary-ni
ISDN Serial0/3/0:23 interface
        dsl 3, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
        [COLOR=yellow][COLOR=red]ACTIVE[/COLOR]
[/COLOR]    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = [COLOR=red]AWAITING_ESTABLISHMENT
[/COLOR]    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 3 CCBs = 0
    The Free Channel Mask:  0x80000FFF
    Number of L2 Discards = 0, L2 Session ID = 245
    Total Allocated ISDN CCBs = 0
2811#

sh ver, sh controllers T1, and sh isdn status for 1760V
1760V#sh ver
Cisco IOS Software, C1700 Software (C1700-ADVENTERPRISEK9-M), Version 12.4(15)T11, RELEASE SOFTWARE (fc2)
 
1760V#sh controllers t1
T1 0/0 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  No alarms detected.
  alarm-trigger is not set
  Soaking time: 3, Clearance time: 10
  AIS State:Clear  LOS State:Clear  LOF State:Clear 
  Version info Firmware: 20090113, FPGA: 20, spm_count = 0
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (28 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 9 15 minute intervals):
     456 Line Code Violations, 5179 Path Code Violations,
     1372 Slip Secs, 0 Fr Loss Secs, 4 Line Err Secs, 1 Degraded Mins,
     1370 Errored Secs, 1 Bursty Err Secs, 4 Severely Err Secs, 1886 Unavail Secs
1760V#
 
1760V#sh isdn stat
Global ISDN Switchtype = primary-ni
ISDN Serial0/0:23 interface
        dsl 0, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
        [COLOR=red]ACTIVE
[/COLOR]    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = [COLOR=red]TEI_ASSIGNED
[/COLOR]    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x80000FFF
    Number of L2 Discards = 0, L2 Session ID = 155
    Total Allocated ISDN CCBs = 0
1760V#
The layer 2 status will flip flop back and forth between awaiting_estab and TEI assigned.

If I plug either device into the NxT1 port on my adtran 550 i get the following:
Global ISDN Switchtype = primary-ni
ISDN Serial0/3/0:23 interface
        dsl 3, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = [COLOR=red]MULTIPLE_FRAME_ESTABLISHED[/COLOR]

What am I missing?icon_cry.gif What is the Adtran providing that the 2911's VWIC-1MFT-T1 is not? or what is the issue with the 1760's config? Must be something simple I am missing!icon_redface.gif

As a note: My Comptroller (WIFE) gave me permission to order up some additional equipment as a reward for passing CCNA and my Adtran Atlas 550 is going away. one of the new routers is a 3745 with a pair of VWIC-2MFT-T1s that I plan to use to replace the Adtran (Quad-T1 module was way out of my budget range) so I am trying to get things set up before everything arrives.
John
Current Progress:
Studying:
CCNA Security - 60%, CCNA Wireless - 80%, ROUTE - 10% (Way behind due to major Wireless Project)
Exams Passed:
CCNA - 640-802 - 17 Jan 2011 -- CVOICE v6 - 642-436 - 28 Feb 2011
2011 Goals
CCNP/CCNP:Voice

Comments

  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    In the lab we need to set one side to emulate network, and the other user (default).

    Try adding the following to one of the serial interfaces: "isdn protocol-emulate network"

    Good end-to-end example here:

    http://www.techexams.net/forums/ccvp/62190-back-back-t1-e1-configuration.html
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
  • hermeszdatahermeszdata Member Posts: 225
    pitviper wrote: »
    In the lab we need to set one side to emulate network, and the other user (default).

    Try adding the following to one of the serial interfaces: "isdn protocol-emulate network"

    Good end-to-end example here:

    http://www.techexams.net/forums/ccvp/62190-back-back-t1-e1-configuration.html

    icon_cheers.gif
    Thanks Pit... I had looked at that doc several times and missed that line. Hate it that I wasted several days un-necessarily. Trying to bust butt and test on 22 Feb.

    The rest of my goodies should be here on 2 Feb. Shoul dbe able to do a rough build on the configs between now and then.
    John
    Current Progress:
    Studying:
    CCNA Security - 60%, CCNA Wireless - 80%, ROUTE - 10% (Way behind due to major Wireless Project)
    Exams Passed:
    CCNA - 640-802 - 17 Jan 2011 -- CVOICE v6 - 642-436 - 28 Feb 2011
    2011 Goals
    CCNP/CCNP:Voice
  • pitviperpitviper CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT Member Posts: 1,376 ■■■■■■■□□□
    Hehehe, the things that we waste several days on we don’t typically forget (ever)!

    I’m a big fan of using an all Cisco PSTN cloud (single router or multiple). CCBootcamp has a really nice single router PSTN/WAN config. I can’t seem to find the files on the site anymore but you can check it out here for funzies:

    https://learningnetwork.cisco.com/thread/10949?tstart=0

    Good luck on the test!
    CCNP:Collaboration, CCNP:R&S, CCNA:S, CCNA:V, CCNA, CCENT
  • GuyManDudeGuyManDude Member Posts: 23 ■□□□□□□□□□
    Here is the full CCbootcamp PSTN router config.

    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname PSTN-WAN
    !
    boot-start-marker
    boot-end-marker
    !
    card type e1 0 1
    logging message-counter syslog
    enable password cisco
    !
    no aaa new-model
    memory-size iomem 10
    clock timezone PST -8
    clock summer-time PST recurring
    network-clock-participate wic 0
    network-clock-participate wic 1
    !
    ip source-route
    !
    !
    ip cef
    ip dhcp excluded-address 10.1.200.1 10.1.200.230
    ip dhcp excluded-address 10.1.200.239 10.1.200.254
    !
    ip dhcp pool PSTN
    network 10.1.200.0 255.255.255.0
    default-router 10.1.200.229
    option 150 ip 10.1.200.229
    !
    !
    no ip domain lookup
    multilink bundle-name authenticated
    !
    frame-relay switching
    isdn switch-type primary-net5
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice translation-rule 1
    rule 1 /\(^011\)\(.*\)/ /\2/
    rule 2 /\(^1\)\(.*\)/ /\2/
    rule 3 /\(^0\)\([^0].*\)/ /\2/
    rule 4 /\(^001\)\(.*\)/ /\2/
    !
    voice translation-rule 2
    rule 1 /^408/ /1&/ type any international
    rule 2 /^4420\(.*\)/ /\1/ type any subscriber
    rule 3 /^44\(.*\)/ /\1/ type any national
    rule 4 /^212/ /1&/ type any international
    !
    voice translation-rule 3
    rule 1 /^212\(.*\)/ /\1/ type any subscriber
    rule 2 /^408/ /&/ type any national
    rule 3 /^44/ /&/ type any international
    !
    voice translation-rule 4
    rule 1 /^408\(.*\)/ /\1/ type any subscriber
    rule 2 /^212/ /&/ type any national
    rule 3 /^44/ /&/ type any international
    !
    !
    voice translation-profile BR1
    translate calling 3
    !
    voice translation-profile BR2
    translate calling 2
    !
    voice translation-profile HQ
    translate calling 4
    !
    voice translation-profile PSTN
    translate called 1
    !
    !
    voice-card 0
    no dspfarm
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    controller T1 0/0/0
    framing esf
    clock source internal
    linecode b8zs
    pri-group timeslots 1-3,24
    !
    controller T1 0/0/1
    framing esf
    clock source internal
    linecode b8zs
    pri-group timeslots 1-3,24
    !
    controller E1 0/1/0
    clock source internal
    pri-group timeslots 1-3,16
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 10.1.200.229 255.255.255.0
    duplex auto
    speed auto
    no shutdown
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0/0:23
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn protocol-emulate network
    isdn incoming-voice voice
    no cdp enable
    !
    interface Serial0/0/1:23
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn protocol-emulate network
    isdn incoming-voice voice
    no cdp enable
    !
    interface Serial0/1/0:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn protocol-emulate network
    isdn incoming-voice voice
    no cdp enable
    !
    interface Serial1/0
    description FR to HQ
    no ip address
    encapsulation frame-relay IETF
    no fair-queue
    clock rate 128000
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 201 interface Serial1/1 101
    frame-relay route 202 interface Serial1/2 102
    no shutdown
    !
    interface Serial1/1
    description FR to BR1
    no ip address
    encapsulation frame-relay IETF
    no fair-queue
    clock rate 128000
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 101 interface Serial1/0 201
    no shutdown
    !
    interface Serial1/2
    description FR to BR2
    no ip address
    encapsulation frame-relay IETF
    clock rate 128000
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 102 interface Serial1/0 202
    no shutdown
    !
    interface Serial1/3
    no ip address
    shutdown
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 10.1.200.1
    !
    !
    no ip http server
    !
    !
    !
    tftp-server flash:P00308000500.bin
    tftp-server flash:P00308000500.loads
    tftp-server flash:P00308000500.sb2
    tftp-server flash:P00308000500.sbn
    !
    control-plane
    !
    !
    !
    voice-port 0/0/0:23
    translation-profile incoming PSTN
    translation-profile outgoing HQ
    !
    voice-port 0/1/0:15
    translation-profile incoming PSTN
    translation-profile outgoing BR2
    !
    voice-port 0/0/1:23
    translation-profile incoming PSTN
    translation-profile outgoing BR1
    !
    !
    !
    !
    !
    dial-peer voice 1 pots
    incoming called-number .
    direct-inward-dial
    !
    dial-peer voice 10 pots
    destination-pattern 702946....
    port 0/0/0:23
    forward-digits all
    !
    dial-peer voice 11 pots
    destination-pattern 801333....
    port 0/0/1:23
    forward-digits all
    !
    dial-peer voice 12 pots
    destination-pattern 44207630....
    port 0/1/0:15
    forward-digits all
    !
    dial-peer voice 13 pots
    destination-pattern 702333....
    port 0/0/1:23
    forward-digits all
    !
    dial-peer voice 100 pots
    destination-pattern 408333....
    port 0/0/1:23
    forward-digits all

    dial-peer voice 101 pots
    destination-pattern 212333....
    port 0/0/1:23
    forward-digits all
    !
    dial-peer voice 102 pots
    destination-pattern 44204444....
    port 0/1/0:15
    forward-digits all
    !
    !

    !
    !

    !
    gatekeeper
    shutdown
    !
    !
    telephony-service
    load 7960-7940 P00308000500
    max-ephones 5
    max-dn 10
    ip source-address 10.1.200.229 port 2000
    system message CCBootcamp CCIE Voice#
    max-conferences 8 gain -6
    transfer-system full-consult
    create cnf-files version-stamp 7960 Jun 07 2010 08:29:49
    !
    !
    ephone-dn 1
    number 911 secondary 999
    label 911+999
    description PSTN Phone
    !
    !
    ephone-dn 2
    number 7029465000 secondary 9465000
    label HQ-Local-7029465000
    !
    !
    ephone-dn 3
    number 8013335000 secondary 3335000
    label BR1-Local-8013335000
    !
    !
    ephone-dn 4
    number 442076305000 secondary 76305000
    label BR2-LD-442076305000
    !
    !
    ephone-dn 5
    number 9007775000
    label 1900#-9007775000
    !
    !
    ephone-dn 6
    number 8004445000
    label 1800#-8007775000
    !
    !
    ephone 1
    mac-address 001F.CA34.DB4C
    type 7960
    button 1:1 2:2 3:3 4:4
    button 5:5 6:6
    !
    !
    !
    ephone 2
    mac-address 0022.1234.5678
    type 7960
    button 1:1 2:2 3:3 4:4
    button 5:5 6:6
  • hermeszdatahermeszdata Member Posts: 225
    Thanks, I found that a while back.

    Here is my lab equip setup:

    3745 AdvEntK9 v12.4(6)t2 - Acts as Frame-Relay Switch, Access Server and PSTN Simulator.
    NM-16A, NM-HD2VE (2xVWIV-2MFT-T1), NM_2V(VIC-2FXS/2FXO) NM-4A/S, 3x WIC-1DSU-T1v2

    2821 AdvEnt v15.1 - HQ Router
    VWIC-1MFT-T1, WIC-1T, waiting for VIC2-2FXS and VIC2-2FXO

    2811 AdvEnt 12.4(15)T11 - Branch 1
    NM-HD-2V (VIC2-2FXS, VIC2-4FXO), VWIC-1MFT-T1, WIC-1T, HWICD-9ESW-PWR

    2621XM AdvEnt 12.4(15)T11 - Branch 2
    Setup 1 - WIC-1T, WIC-1DUS-T1, NM-2V (VIC-2FXS, VIC-2FXO)
    Setup 2 - WIC-1T, WIC-1DUS-T1, NM-HD-2VE (VWIC-1MFT-T1, Waiting for VIC-4FXS)

    1760 AdvEnt 12.4(15)T11
    WIC-1T, VWIC-1MFT-T1, VIC-2FXS, VIC-2FXO

    CUCM7 on an HP DL380-G4

    2x MagicJack LOL

    1x3550-48-SMI
    1x3550-24-SMI-PWR
    2x3500-24-XL-PWR
    3x7910
    2x7960G (shared with home/office VoIP)
    2x7940G (Picking up today)
    3xShitty Phones (analog) looking for one more.

    Also have a couple of US Robotics modems to play with, maybe FAX/Out of Band Remote access, and my AIO printer/FAX.
    John
    Current Progress:
    Studying:
    CCNA Security - 60%, CCNA Wireless - 80%, ROUTE - 10% (Way behind due to major Wireless Project)
    Exams Passed:
    CCNA - 640-802 - 17 Jan 2011 -- CVOICE v6 - 642-436 - 28 Feb 2011
    2011 Goals
    CCNP/CCNP:Voice
  • tokhsstokhss Member Posts: 473
    I like the magic jack setup.. how well is that working out for u.. I might buy one myself for this setup.
  • hermeszdatahermeszdata Member Posts: 225
    tokhss wrote: »
    I like the magic jack setup.. how well is that working out for u.. I might buy one myself for this setup.

    My wife is the primary Land Line user with most of her calls being international (her family is from/in Europe and friends in Canada and Central America.) Unfortunately, MJ apparently set up a "toll Fraud" scheme that will not allow the use of international calling cards of pre-paid LD services so she makes those calls from her cell phone. LOL

    Other than that ... and an annoying tone (like someone pressed the keypad) heard by the caller, I have no issues. there can only be one MJ installed on any PC and one must make sure that the PC is booted up and logged on at all times.
    John
    Current Progress:
    Studying:
    CCNA Security - 60%, CCNA Wireless - 80%, ROUTE - 10% (Way behind due to major Wireless Project)
    Exams Passed:
    CCNA - 640-802 - 17 Jan 2011 -- CVOICE v6 - 642-436 - 28 Feb 2011
    2011 Goals
    CCNP/CCNP:Voice
  • geezer301geezer301 Member Posts: 25 ■□□□□□□□□□
    What would be the minimum hardware type that can use the CCbootcamp PSTN router config ? Thanks.
  • hermeszdatahermeszdata Member Posts: 225
    geezer301 wrote: »
    What would be the minimum hardware type that can use the CCbootcamp PSTN router config ? Thanks.

    you could probably get by with a 1760V (max mem and 12.4(15)* IOS) and a pair of VWIC-2mft-t1s if you select your PVDMs properly. The problem is the VWIC-2MFT-T1s cost 2-3 times what the 1760's cost me.
    John
    Current Progress:
    Studying:
    CCNA Security - 60%, CCNA Wireless - 80%, ROUTE - 10% (Way behind due to major Wireless Project)
    Exams Passed:
    CCNA - 640-802 - 17 Jan 2011 -- CVOICE v6 - 642-436 - 28 Feb 2011
    2011 Goals
    CCNP/CCNP:Voice
  • GuyManDudeGuyManDude Member Posts: 23 ■□□□□□□□□□
    Go for a 2811 router. The router will cost more but it has 4 vwic slots so you can buy 3 single port T1/E1 cards which are much cheaper than dual port cards. Plus the 2811 can handle more DSP's, more flash/dram and other modules like the 4 port ethernet switch or the NM-CUE if you decide to grow your lab later etc.
  • tokhsstokhss Member Posts: 473
    ok cool, thanks

    the MG is connected to your fxo ports right? I have no hard line b/c its a waste for me..
  • geezer301geezer301 Member Posts: 25 ■□□□□□□□□□
    Hermeszdata,

    Are you using AIM-VOICE-30 to provide DSP for your "NM-HD2VE (2xVWIV-2MFT-T1)" ?
  • hermeszdatahermeszdata Member Posts: 225
    geezer301 wrote: »
    Hermeszdata,

    Are you using AIM-VOICE-30 to provide DSP for your "NM-HD2VE (2xVWIV-2MFT-T1)" ?

    the nm-hd2ve has built in dsp
    John
    Current Progress:
    Studying:
    CCNA Security - 60%, CCNA Wireless - 80%, ROUTE - 10% (Way behind due to major Wireless Project)
    Exams Passed:
    CCNA - 640-802 - 17 Jan 2011 -- CVOICE v6 - 642-436 - 28 Feb 2011
    2011 Goals
    CCNP/CCNP:Voice
Sign In or Register to comment.