Frame-Relay Problems/ NAT

jack84iejack84ie Posts: 62Member ■■□□□□□□□□
Hi, trying to get his Network Working, but Frame-Relay just does not want to Work...

It is in Packet Tracer in Cloud0
Serial0 set DLCI 201 R4 - R6 DLCI 201 R4 - R5
Serial1 set DLCI 103 R5 - R4
Serial 2 set DLCI 201 R6 - R4

then into Frame-relay connections
From Port Sublink To port Sublink
Serial0 R4-R5 Serial1 R5-R4
Serial0 R4-R6 Serial2 R6-R4

done Ip map on R1

but if i do an ip map on R5 or R6 it stats ip address already map
R4 shows Frame-relay shows both map address
R5 shows Frame-relay map address Down
R6 shows no Frame-relay map address

With NAT i have a public IP of 195.100.190.0/24 R1 can ping Loopback 0 on ISP Router

but trying to do a ip route 192.199.190.0 255.255.255.0 S0/0/0
it comes up invaide interface type and number..
evening if i do a 192.199.190.240 255.255.255.240

I am Trying to get ISP to ping the Public Address and have R1 translate between Public and private

R1
hostname R1
!
!
!
!
!
!
!
!
username R1 password 0 cisco
username R2 password 0 cisco
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 199.1.1.38 255.255.255.252
 ip nat inside
!
interface Serial0/0/1
 ip address 172.190.0.14 255.255.255.252
 ip nat outside
!
interface Serial0/1/0
 ip address 172.190.0.1 255.255.255.252
 encapsulation ppp
 ppp authentication chap
 ip nat outside
!
interface Serial0/1/1
 ip address 172.190.0.5 255.255.255.252
 ip nat outside
 clock rate 64000
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 network 172.190.0.0 0.0.0.3 area 0
 network 172.190.0.4 0.0.0.3 area 0
 network 172.190.0.12 0.0.0.3 area 0
 default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 199.1.1.37 
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

ISP
hostname ISP
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
 ip address 126.0.0.1 255.0.0.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 199.1.1.37 255.255.255.252
 clock rate 64000
!
interface Serial0/0/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
!
!
banner motd ^C
ONLY STAFF WITH PASS KEY ^C
!
!
!
!
line con 0
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
!
!
end

Comments

  • yapchinhoong2010yapchinhoong2010 Posts: 14Member ■□□□□□□□□□
    are you able to post the PT file? Will be much faster to work on it.icon_cool.gif
  • JollycorkJollycork Posts: 149Member
    what are you Natting? outside in or inside out? or both?

    what type of NAT? one to one, one to many?

    how does the outside address get an inside address?

    how does the inside address get an outside address?

    hint: you are missing some CLI statements that NAT the outside address
    to an inside address and vice versa


    side note: another question to ask: can you NAT multiple [WAN] subinterfaces to a single [LAN] subinterface?
    if so, how does the router know to do that?
Sign In or Register to comment.