EIGRP network 0.0.0.0 command question

localpreflocalpref Registered Users Posts: 5 ■□□□□□□□□□
I am trying to verify the follow text via a lab. This comes from a Cisco book

The other option is to use the network 0.0.0.0 EIGRP subcommand. Oddly enough, this command does not actually match interface IP addresses of interfaces, but is a special case in which IOS thinks “if my routing table has a default route in it, put a default route (0.0.0.0/0) into the EIGRP table.”
(If the route leaves the routing table, then the router will notify neighbors that the route has failed.)

My lab seems to show the exact oppsite happening it seems to match on all interfaces and not send out the default route.

Config from router I want to originate the default route from. Notice there is not a network statement for the 50.50.50.0/24 network.

router eigrp 90
network 10.1.0.0 0.0.255.255
network 172.30.0.0
network 192.168.1.0
network 0.0.0.0
no auto-summary

ip route 0.0.0.0 0.0.0.0 192.168.1.1

show command to show the default route is valid

BB#show ip route
Gateway of last resort is 192.168.1.1 to network 0.0.0.0

50.0.0.0/24 is subnetted, 1 subnets
C 50.50.50.0 is directly connected, Loopback50
S* 0.0.0.0/0 [1/0] via 192.168.1.1


routing table from a neighbor. notice he sees the 50.50.50.0/24 network and no default route. From the above statments in the book the oppsite should be happening.

R3#show ip route
Gateway of last resort is not set
50.0.0.0/24 is subnetted, 1 subnets
D 50.50.50.0 [90/10639872] via 10.1.34.1, 00:11:01, Serial0/0



Is there anyone who can help explain what is going on???

Comments

  • stuh84stuh84 Member Posts: 503
    What book is that from? That sounds like absolute rubbish to be honest. Unless its a deprecated feature of EIGRP, I just don't see how what that says could ever be the case.
    Work In Progress: CCIE R&S Written

    CCIE Progress - Hours reading - 15, hours labbing - 1
  • localpreflocalpref Registered Users Posts: 5 ■□□□□□□□□□
    It is from the CCNP ROUTE 642-902 Official Certification Guide from cisco press.

    They go into some detail on this, wish I could paste the whole thing in here but think that might infringe on copywrite. Since they go into detail on how to apply this didn't think it was a typo. Any help would be much apprectiated.

    Ohh if anyone has this book this can be found on page 128
  • Chris_Chris_ Member Posts: 326
    Yep, it's from the wendell odom book, he's rarely wrong! I read that chapter last week - haven't tried that in a lab yet. I'll try it tonight and see how I get on.
    Going all out for Voice. Don't worry Data; I'll never forget you
    :study: CVoice [X] CIPT 1 [ ] CIPT 2 [ ] CAPPS [ ] TVOICE [ ]
  • down77down77 Member Posts: 1,009
    I can check Books24x7 later but it sounds like an exercise on redistributing your default route into eigrp.
    CCIE Sec: Starting Nov 11
  • Chris_Chris_ Member Posts: 326
    It does sound like it's doing exactly what it says it won't though!!! Have you done a show IP protocols, I imagine it will say that your 50. Loopback will be included under eigrp.
    Going all out for Voice. Don't worry Data; I'll never forget you
    :study: CVoice [X] CIPT 1 [ ] CIPT 2 [ ] CAPPS [ ] TVOICE [ ]
  • UndyUndy Member Posts: 37 ■■□□□□□□□□
    This special case only works when your next hop is an interface. Not sure if there is any other time that this does work. Try changing your next hop for 0.0.0.0/0 to the interface 192.168.1.1 is connected to and you should see the eigrp learned route to 0.0.0.0/0 on your neighbors.
  • Chris_Chris_ Member Posts: 326
    That's a bit worrying then if your next hop isn't an interface, as in localpref's example. It seems to be using the 'network 0.0.0.0' command as a catch all to include all interfaces - which is exactly what the book says it won't do!!
    Going all out for Voice. Don't worry Data; I'll never forget you
    :study: CVoice [X] CIPT 1 [ ] CIPT 2 [ ] CAPPS [ ] TVOICE [ ]
  • UndyUndy Member Posts: 37 ■■□□□□□□□□
    I am not sure why you would use this at all to be honest, but it isn't really a catch all that causes it to advertise the 0.0.0.0/0. A network statement still shouldn't advertise your static routes. They should be redistributed.
  • localpreflocalpref Registered Users Posts: 5 ■□□□□□□□□□
    I have confirmed that it will inject the the default route if the static is pointed towards an interface and will remove the default route if the interface goes down.

    The example in the book uses an interface for its default route but no where does it state that the default route must be towards an interface.

    Even when using an interface for the default route it still continues to send routes for other interfaces that do not have a specific network entires. Which by the book it should not be doing.
  • stuh84stuh84 Member Posts: 503
    This is why I don't like EIGRP, now it advertises a default route out of boredom it seems!
    Work In Progress: CCIE R&S Written

    CCIE Progress - Hours reading - 15, hours labbing - 1
  • localpreflocalpref Registered Users Posts: 5 ■□□□□□□□□□
    Chris sorry forgot to post the findings from your question. IP protocols do not show the 50.50.50.0/24 network but do show 0.0.0.0

    output from show ip protocols

    Routing for Networks:
    10.1.0.0/16
    172.30.0.0
    192.168.1.0
    0.0.0.0
  • Chris_Chris_ Member Posts: 326
    Thanks localpref. this is obviously one of those things that shod be forgotten after the exam!!
    I'm still of the opinion that if this is a feature to advertise a default route, then it should do this without also including all local interfaces on EIGRP. Has any one else ever uses this?
    Going all out for Voice. Don't worry Data; I'll never forget you
    :study: CVoice [X] CIPT 1 [ ] CIPT 2 [ ] CAPPS [ ] TVOICE [ ]
  • localpreflocalpref Registered Users Posts: 5 ■□□□□□□□□□
    Chris I am with you and as the book states that is exactly how it should work. Only injecting the default route and not being a catch all to match all interfaces.

    But in pratice it doesn't work that way.

    Tried to find some documentation on Cisco web site about this method to see if it was an error in the book or if it is a bug but could not find anything.
  • networker050184networker050184 Mod Posts: 11,962 Mod
    Very interesting. Never heard about that before. You truly do learn something new every day no matter how long you have been studying this stuff.
    An expert is a man who has made all the mistakes which can be made.
  • networker050184networker050184 Mod Posts: 11,962 Mod
    Very interesting. Never heard about that before. You truly do learn something new every day no matter how long you have been studying this stuff.
    An expert is a man who has made all the mistakes which can be made.
  • kryollakryolla Member Posts: 785
    I just verified it and it does inject a default and includes all interfaces in eigrp. I found it interesting so I labbed it up

    Rack16R5#sh ip route stat
    S* 0.0.0.0/0 is directly connected, Serial0/1


    Rack16SW1#sh ip route 0.0.0.0
    Routing entry for 0.0.0.0/0, supernet
    Known via "eigrp 1", distance 90, metric 46137344, candidate default path, type internal
    Redistributing via eigrp 1
    Last update from 155.16.37.3 on FastEthernet0/3, 00:03:03 ago
    Routing Descriptor Blocks:
    * 155.16.37.3, from 155.16.37.3, 00:03:03 ago, via FastEthernet0/3
    Route metric is 46137344, traffic share count is 1
    Total delay is 1020990 microseconds, minimum bandwidth is 128 Kbit
    Reliability 255/255, minimum MTU 1500 bytes
    Loading 1/255, Hops 2

    Rack16SW1#

    Rack16R5(config)#router eigrp 1
    Rack16R5(config-router)#do sh ip eigrp top 0.0.0.0
    % IP-EIGRP (AS 1): Route not in topology table

    Rack16R5(config-router)#net 0.0.0.0

    Rack16R5(config-router)#do sh ip eigrp top 0.0.0.0
    IP-EIGRP (AS 1): Topology entry for 0.0.0.0/0
    State is Passive, Query origin flag is 1, 1 Successor(s), FD is 27266304
    Routing Descriptor Blocks:
    0.0.0.0, from Rstatic, Send flag is 0x0
    Composite metric is (27266304/0), Route is Internal
    Vector metric:
    Minimum bandwidth is 1536 Kbit
    Total delay is 999990 microseconds
    Reliability is 255/255
    Load is 1/255
    Minimum MTU is 1500
    Hop count is 0
    Exterior flag is set
    155.16.45.4 (Serial0/1), from 155.16.45.4, Send flag is 0x0
    Composite metric is (71742208/46142464), Route is Internal
    Vector metric:
    Minimum bandwidth is 128 Kbit
    Total delay is 2021180 microseconds
    Reliability is 255/255
    Load is 1/255
    Minimum MTU is 1500
    Hop count is 5
    Exterior flag is set
    Rack16R5(config-router)#

    It makes it internal instead of external
    Studying for CCIE and drinking Home Brew
  • APAAPA Member Posts: 959
    Very odd behaviour... interesting to know though....... good post... :)

    What ever happened to just making use of ´ip default-network 192.168.1.0´ with EIGRP...

    You have the route to 192.168.1.0/24, its a classful boundary so EIGRP will flag it as a candidate for default via the default network statement.... thus it will propagate it within the EIGRP domain, assuming your neighbors all know about 192.168.1.0/24 as well.

    :D

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
  • APAAPA Member Posts: 959
    You truly do learn something new every day no matter how long you have been studying this stuff.

    +1, couldn´t agree more! icon_study.gif

    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
  • ZblaJhaNiZblaJhaNi Member Posts: 35 ■■□□□□□□□□
    localpref wrote: »
    I am trying to verify the follow text via a lab. This comes from a Cisco book

    The other option is to use the network 0.0.0.0 EIGRP subcommand. Oddly enough, this command does not actually match interface IP addresses of interfaces, but is a special case in which IOS thinks “if my routing table has a default route in it, put a default route (0.0.0.0/0) into the EIGRP table.”
    (If the route leaves the routing table, then the router will notify neighbors that the route has failed.)

    My lab seems to show the exact oppsite happening it seems to match on all interfaces and not send out the default route.

    Config from router I want to originate the default route from. Notice there is not a network statement for the 50.50.50.0/24 network.

    router eigrp 90
    network 10.1.0.0 0.0.255.255
    network 172.30.0.0
    network 192.168.1.0
    network 0.0.0.0
    no auto-summary

    ip route 0.0.0.0 0.0.0.0 192.168.1.1

    show command to show the default route is valid

    BB#show ip route
    Gateway of last resort is 192.168.1.1 to network 0.0.0.0

    50.0.0.0/24 is subnetted, 1 subnets
    C 50.50.50.0 is directly connected, Loopback50
    S* 0.0.0.0/0 [1/0] via 192.168.1.1


    routing table from a neighbor. notice he sees the 50.50.50.0/24 network and no default route. From the above statments in the book the oppsite should be happening.

    R3#show ip route
    Gateway of last resort is not set
    50.0.0.0/24 is subnetted, 1 subnets
    D 50.50.50.0 [90/10639872] via 10.1.34.1, 00:11:01, Serial0/0



    Is there anyone who can help explain what is going on???

    Page 128 – 2nd paragraph – 4th line – middle – a sentence begins “Oddly enough, this command does not actually match interface IP addresses of interfaces, but…” – that statement is not true. The network 0.0.0.0 command actually matches all interfaces. To fix the text, delete the yellowed portion shown here.

    Copied from Errata
    ...to the stars through difficulties...
  • sakayaraj20000sakayaraj20000 Member Posts: 1 ■□□□□□□□□□
    hi localpref,

    I read the errata of the Cisco Route 642-902 certification book, and this is what i found.

    Page 128 – 2nd paragraph – 4th line – middle – a sentence begins “Oddly enough, this command does not actually match interface IP addresses of interfaces, but…” – that statement is not true. The network 0.0.0.0 command actually matches all interfaces. To fix the text, delete the red portion shown here.

    It was incorrect information given on the book. The network 0.0.0.0 command adverties all the network interfaces on that router.

    Sakayaraj CCNA.

    Currently studying for the CCNP Route 642-902 Exam
  • pham0329pham0329 Member Posts: 556
    Cool, you bumped a 6 months old thread to say what the guy above you said. The OP have 5 posts, all of which were from this topic back in March. I doubt he's still looking for an answer to his question.
  • GngoghGngogh Member Posts: 164 ■■■□□□□□□□
    hi localpref,

    I read the errata of the Cisco Route 642-902 certification book, and this is what i found.

    Page 128 – 2nd paragraph – 4th line – middle – a sentence begins “Oddly enough, this command does not actually match interface IP addresses of interfaces, but…” – that statement is not true. The network 0.0.0.0 command actually matches all interfaces. To fix the text, delete the red portion shown here.

    It was incorrect information given on the book. The network 0.0.0.0 command adverties all the network interfaces on that router.

    Sakayaraj CCNA.

    Currently studying for the CCNP Route 642-902 Exam

    As i saw on a video on youtube is a shortcut for lazy people...
  • Dieg0MDieg0M Member Posts: 861
    It's actually called a "shotgun" approach. It is really usefull when you want to set up quickly a lab and test something.
    Follow my CCDE journey at www.routingnull0.com
  • Samo3411Samo3411 Member Posts: 35 ■■□□□□□□□□
    i use it when setting labs, it work well with passive interface default , and then put no passive interface on any interface you would like to set for eigrp or ospf .
  • theodoxatheodoxa Member Posts: 1,340 ■■■■□□□□□□
    stuh84 wrote: »
    What book is that from? That sounds like absolute rubbish to be honest. Unless its a deprecated feature of EIGRP, I just don't see how what that says could ever be the case.

    It works...in Packet Tracer at least. He might try adding the static default route before entering the network 0.0.0.0 command and see if that works.
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
Sign In or Register to comment.