Options

question about "ip nat inside" and "ip nat outside"

johnifanx98johnifanx98 Member Posts: 329
here is a simple basic static NAT configuration.
ip nat inside source static 10.1.1.1 170.46.2.1
!
interface ethernet0
  ip address 10.1.1.10 255.255.255.0
  ip nat inside
!
interface Serial0
  ip address 172.46.2.1 255.255.255.0
  ip nat outside
!

So, does "ip nat inside" means the interface e0 does local->global translation, and "ip nat outside" means interface s0 does global->local translation?

Comments

  • Options
    martell1000martell1000 Member Posts: 389
    with these commands you "flag" the interfaces taking part in NAT...
    inside defines the inside interface which is in you private network and outside defines which interface is in the oustside (wan internet etc) network.

    the translation parameters are set in this line

    ip nat inside source static 10.1.1.1 170.46.2.1

    in you example you install a static nat where inside address gets 1:1 mapped to one outside address, in this case
    only 10.1.1.1 is beeing translated since no pool or overload functions are used.
    And then, I started a blog ...
Sign In or Register to comment.