Only VLAN 1 can be pinged or Telneted on a switch?

vazurahanvazurahan Member Posts: 23 ■□□□□□□□□□
Why can't I ping VLAN 2 and VLAN 3 even though I've set them up with IP addresses? Here's my config.
Is it because VLAN 1 is special somehow?

Switch#show run
Building configuration...

Current configuration : 1229 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
spanning-tree mode rapid-pvst
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 10.0.0.1 255.0.0.0
!
interface Vlan2
ip address 20.0.0.1 255.0.0.0
!
interface Vlan3
ip address 30.0.0.1 255.0.0.0
!
ip classless
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line vty 0 4
login
!
!
!
end


Here are my PC Configs

VLAN 1 PC on Fa0/1 on switch

PC>ipconfig

IP Address......................: 10.0.0.2
Subnet Mask.....................: 255.0.0.0
Default Gateway.................: 0.0.0.0

PC>ping 10.0.0.1

Pinging 10.0.0.1 with 32 bytes of data:

Reply from 10.0.0.1: bytes=32 time=63ms TTL=255
Reply from 10.0.0.1: bytes=32 time=94ms TTL=255
Reply from 10.0.0.1: bytes=32 time=63ms TTL=255
Reply from 10.0.0.1: bytes=32 time=203ms TTL=255

Ping statistics for 10.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 63ms, Maximum = 203ms, Average = 105ms

VLAN 2 PC on Fa0/2 on switch

PC>ipconfig

IP Address......................: 20.0.0.2
Subnet Mask.....................: 255.0.0.0
Default Gateway.................: 0.0.0.0

PC>ping 20.0.0.1

Pinging 20.0.0.1 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 20.0.0.1:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),


VLAN 3 PC on Fa0/3 on switch

PC>ipconfig

IP Address......................: 30.0.0.2
Subnet Mask.....................: 255.0.0.0
Default Gateway.................: 0.0.0.0

PC>ping 30.0.0.1

Pinging 30.0.0.1 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 30.0.0.1:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Comments

  • nbeachamnbeacham Users Awaiting Email Confirmation Posts: 23 ■□□□□□□□□□
    Vlan 1 on a switch is typically the management Vlan. If you configure it with an IP address it allows remote access and typically will respond to ICMP requests. In order to route across VLANs you need to incorporate a router into your network, look up 'router on a stick' to get further detail. Because a typical switch is layer 2 only, it can only forward packets in it's LAN, if you are using a VLAN then it will only forward the packets on that VLAN. Hope this helps
  • vazurahanvazurahan Member Posts: 23 ■□□□□□□□□□
    Thanks.
    Finally got it to work. I forgot to assign the other interfaces to their respective VLANs and provide a Default Gateway.

    That's actually 3560 I'm using. I was practicing Inter-Vlan routing on a Layer 3 switch. I managed Inter-VLAN routing by add these commands

    interface FastEthernet0/2
    switchport access vlan 2
    !
    interface FastEthernet0/3
    switchport access vlan 3
  • W StewartW Stewart Member Posts: 794 ■■■■□□□□□□
    vazurahan wrote: »
    Thanks.
    Finally got it to work. I forgot to assign the other interfaces to their respective VLANs and provide a Default Gateway.

    That's actually 3560 I'm using. I was practicing Inter-Vlan routing on a Layer 3 switch. I managed Inter-VLAN routing by add these commands

    interface FastEthernet0/2
    switchport access vlan 2
    !
    interface FastEthernet0/3
    switchport access vlan 3


    Man I drove all the way to mcdonalds to get wifi on my laptop just so I could tell you that. Glad you figured it out though. That's probably what ICND2 will be like.
    Being a sys admin sucks but I love it
  • Greenmet29Greenmet29 Member Posts: 240
    @ W Stuart... I'm glad i'm not the only crazy one! Love the effort!
  • W StewartW Stewart Member Posts: 794 ■■■■□□□□□□
    Yea I was born to do tech support lol.
    Being a sys admin sucks but I love it
Sign In or Register to comment.